Advanced search  


cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.

Pages: [1]   Go Down

Author Topic: Advice on Fatal error: message when upgrading  (Read 7821 times)

0 Members and 1 Guest are viewing this topic.


  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Advice on Fatal error: message when upgrading
« on: January 25, 2006, 06:47:56 pm »

Hi all,

Apologies if this has been discussed elsewhere; I couldn't find a solution that worked for me (despite a number of people appearing to have similar/ related problems).

When upgrading from 1.3.5 to 1.4.3 the upgrade appeared to go smoothly (following the instructions) but I would get the dreaded 'Fatal error:' message with an empty page - no other info was on the screen.  I eventually remembered to turn the debug option on directly on the config table in the database, and the error - I'm afraid I cannot remember the exact words but it was a db permission problem - made me think of checking my mysql user permissions.  Sure enough, my user did not have 'alter' privileges.

The upgrade script actually gives a clue (if I'd read it properly).  On running it the first time it claimed that many of it's DB actions had been 'already done'.  Of course they weren't.  I guess the error handling in that script doesn't know about permissions errors (I'm not a php programmer so cannot check, unfortunately).

Providing that privilege - and if you don't have it you may need 'create' as well - solved my problem.  Run the upgrade script again, and voila - it all works!

Hope that helps someone out there.



Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
Re: Advice on Fatal error: message when upgrading
« Reply #1 on: January 26, 2006, 08:29:49 am »

you're right, this is a known issue: when running the update, the script runs the queries against the database, but doesn't check if they have been succesfully been applied. Alas it's a bit tricky to do that, and it would complicate the whole process of upgrading. I'm considering an extra function integrated into update.php (as well as the installer) that does some advanced checking of the database permissions for cpg1.5.x, so I'm moving this thread from the support section to the approved feature requests section, so this issue doesn't get overlooked. Thanks for bringing this up.

Pages: [1]   Go Up

Page created in 0.015 seconds with 19 queries.