Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Re: Bug found in 1.4.2 for different translatiosn  (Read 5761 times)

0 Members and 1 Guest are viewing this topic.

hfohrman

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 7
    • Bokskogsbackens Consulting
Re: Bug found in 1.4.2 for different translatiosn
« on: December 12, 2005, 04:58:17 pm »

Yes I found that afterwords and I have been in contact with them. No problem.

But I still have the 2 bugs that i Found. And I werifyed that with one of the other translaters yesterday.

1. In file picEditor.php. Line 214. There you have hardcoded text that are displayed.  $message = "Thumbnail successfully saved - you can close this window now";

2. This one I have been doing test with the other translated languages and it's there all the time. After logged in if I switch from admin to user mode and back. There is a confirmation message displayed. And If fallback is on in the config this text is always displayed in englich. Even if there is a translation in the language file.
If I switch of fallback. Then it reads the local file. And I done tests with Swedish , German . Same procedure.

Hans
« Last Edit: December 15, 2005, 07:16:12 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Re: Bug found in 1.4.2 for different translatiosn
« Reply #1 on: December 12, 2005, 06:06:39 pm »

Lang fallback doesn't work so well with numeric keys, change langfallback.inc.php

Code: [Select]
if (defined('MODE_PHP')) {
  $lang_mode_php_en = cpg_get_default_lang_var('lang_mode_php','english');
  $lang_mode_php = array_merge($lang_mode_php_en, $lang_mode_php);
}

to

Code: [Select]
if (defined('MODE_PHP')) {
  $lang_mode_php_en = cpg_get_default_lang_var('lang_mode_php','english');
  $lang_mode_php = isset($lang_mode_php) ? $lang_mode_php : $lang_mode_php_en;
}
Logged

Nibbler

  • Guest
Re: Re: Bug found in 1.4.2 for different translatiosn
« Reply #2 on: December 15, 2005, 07:15:25 pm »

Fix committed to CVS.
Logged

Guerrilla

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Bug found in 1.4.2 for different translatiosn
« Reply #3 on: December 22, 2005, 04:10:45 pm »

Hi guys !!!
I have almost the same problem ... please read this thread
http://forum.coppermine-gallery.net/index.php?topic=25415.0

Hope you can help me :)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Bug found in 1.4.2 for different translatiosn
« Reply #4 on: December 23, 2005, 11:13:41 am »

don't try to hijack threads. You already got an answer on the other thread, no need to advertize your thread here.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.