Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Adding own links deactivates cpg links  (Read 4388 times)

0 Members and 1 Guest are viewing this topic.

Cyclist

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 42
Adding own links deactivates cpg links
« on: December 11, 2005, 12:18:45 pm »

I added some extra links to my custom footer. But this somehow deactivated all standard coppermine links. I couldn't use anymore the prev/next, slidshow, pic information buttons nor the album links. They are dead. This problem doesn't exist in IE but when using Firefox. I tried to add the links directly to the template but this didn't make any difference. As soon as I removed the extra links all cpg links started working again. Any solution for this?
Logged

Cyclist

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 42
Re: Adding own links deactivates cpg links
« Reply #1 on: December 11, 2005, 12:24:17 pm »

It seems to have something to do with the css position. If I don't assign the css to the link + div it doesn't cause any problem. Strange...
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Adding own links deactivates cpg links
« Reply #2 on: December 11, 2005, 09:46:54 pm »

always post a link to your site if you post such questions, it's a pain having to go back to your older postings to find the link.
Logged

Cyclist

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 42
Re: Adding own links deactivates cpg links
« Reply #3 on: December 12, 2005, 02:59:01 pm »

I run cpg still on my test server not online so there is no way posting a working link. If I had one I would have posted it. I solved the problem for me deleting the css code for position. But anyway I think it's something the developers should be aware of. If I put a div in  the custom footer and assign css code for relative or absolute position to it no cpg links are working anymore. Deleting the css code makes the links working again.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Adding own links deactivates cpg links
« Reply #4 on: December 12, 2005, 05:56:55 pm »

could you package your custom theme into a zip and attach it to your posting, so we could take a look at it to reproduce. It's hard to imagine that adding links could actually disable existing ones.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.