Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: mandatory files install.php, update.php and upgrade-1.0-to-1.2.php?  (Read 2575 times)

0 Members and 1 Guest are viewing this topic.

fishfreek

  • Coppermine newbie
  • Offline Offline
  • Posts: 5

I just updated to 1.4.2 and I see in the version checker the following files are listed as being mandintory  install.php, update.php and upgrade-1.0-to-1.2.php.  I find it strange as in most scripts your told to remove the install, and upgrade scripts when done using them.  The site seems to run fine with out those three files being there.  Do they not pose a sort of secuirty risk by having them in place?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: mandatory files install.php, update.php and upgrade-1.0-to-1.2.php?
« Reply #1 on: December 08, 2005, 06:13:23 pm »

no, as the existence of the install.lock file in the include folder keeps the install file from being run. Running the update.php file won't do any harm. You're free to find this out by yourself - just run those files. However, it won't hurt if you delete them as well.
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 20 queries.