Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Approval doesn't work  (Read 2663 times)

0 Members and 1 Guest are viewing this topic.

Vermeer

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 21
Approval doesn't work
« on: December 06, 2005, 09:19:35 am »

Hi,
i think i have done everything right, but approval seems not to work! ( i have attached my settings)
With these settings, a user of group "uploader" should upload pictures in public folders WITH approval - but this doesnt' work.
The image is shown at once in the gallery without any approval.

Any idea?

Vermeer

« Last Edit: December 08, 2005, 06:08:55 pm by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Approval doesn't work
« Reply #1 on: December 06, 2005, 10:23:26 am »

post a link and non-admin test user account that is within this group. Make sure this user isn't member of another group that allows uploading without approval.
Logged

Vermeer

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 21
Re: Approval doesn't work
« Reply #2 on: December 06, 2005, 10:43:53 am »

Can i sent the URL and the user-account by PM? - because this gallery isn't published yet, it's still in testing mode an not for the public now.
Logged

Vermeer

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 21
Re: Approval doesn't work
« Reply #3 on: December 06, 2005, 12:47:32 pm »

Hi gaugau,
i found the solution for my problem in an other posting from you: "in other words: everybody who accesses your site will be able to upload.
If a user actually logs in, he's by default member of the "registered" group, so the settings for this group apply."

When i change the approval form the group "registered" from "no" to "yes" (this group can't upload pictures) everything works fine: The users of my group "uploader" can't upload pictures without approval.

I think it has to be present in the documentation that the group "registered" affects all other groups.

Regards
Vermeer
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.