Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: how moving the {title} of the image on top of the page?  (Read 6137 times)

0 Members and 1 Guest are viewing this topic.

Cyclist

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 42
how moving the {title} of the image on top of the page?
« on: December 01, 2005, 01:40:06 pm »

Hello,

It’s me again with another problem…

I would like to change the order of certain elements on the page. Within displayimage.php the standard order of the element is as following:
1) Navbar
2) Medium sized image
3) Title of the image
4) Pic information (Keywords, dated added, …)

But I would prefer using the title as headline of that page and therefore I need following order:
1) Title of the image
2) Navbar
3) Medium sized image
4) Pic information

For displaying the navbar and medium sized image including title are used two different templates.

If I put the placeholder {TITLE} on top of the page it isn’t parsed anymore. It needs to be within the image template and because of that I can’t move it on top of the page and use it as headline. So far I have only managed to move the navbar below the image and then moving the title on top of it. But that’s not what I want.

Do you have any idea how I could get the title of the image on top of the page (before the navbar)?
« Last Edit: December 02, 2005, 04:17:44 pm by Cyclist »
Logged

Cyclist

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 42
Re: how moving the {title} of the image on top of the page?
« Reply #1 on: December 04, 2005, 12:33:51 am »

I decided to put the navbar below the image. But now I have a problem when using the slideshow. Then the placeholder for the title is displayed - but it shouldn't be displayed at all.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: how moving the {title} of the image on top of the page?
« Reply #2 on: December 05, 2005, 07:23:41 am »

link?
Logged

Cyclist

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 42
Re: how moving the {title} of the image on top of the page?
« Reply #3 on: December 05, 2005, 08:33:40 pm »

Hi Gaugau, I am sorry but since I have the cpg by now only on a test server available I don't have a working link. But I have taken a screenshot which might help. I could also post the sourcecode if necessary.

(http://www.cyclingimages.com/test/cpg.JPG)
« Last Edit: December 05, 2005, 08:49:59 pm by Cyclist »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: how moving the {title} of the image on top of the page?
« Reply #4 on: December 06, 2005, 09:13:17 am »

ah ok, I think I have seen this before. Please search the board (including the cpg1.3.x support board), I think there is a fix.
Logged

Cyclist

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 42
Re: how moving the {title} of the image on top of the page?
« Reply #5 on: December 06, 2005, 12:31:25 pm »

After doing the search also for the older versions of coppermine gallery I retrieved one thread with a similar topic but there is a small but important difference.

The theme where the problem occurred was a user contributed theme but the theme I am using is based on the classic theme. The solution suggested there is to move the {title} below the image – that’s standard in the classic theme in version 1.42. If I have the {Title} below the intermediate image – the title placeholder  isn’t displayed in the slideshow but for design reasons I do need the Title above the image when displaying the intermediate image. Therefore moving the title below isn’t a solution for me. The only thing I have done was changing the order from {image} and {Title} but that’s exactly what is causing the problem. But from my point of view it should be possible changing the order without effecting the display of the slideshow. Somewhere there must be a piece of code which causes the problem when changing the order.

Moving the navbar below the image didn’t cause any problems nor did the modification of the order of the navbuttons. But exactly this is happening when modifying the order of the elements for displayimage. When viewing the intermediate image in “normal” view the title is parsed correctly, the problem only exists when switching to the slideshow mode. I have no idea why this happens and how to avoid this when I want to keep my design.

The old topic: http://forum.coppermine-gallery.net/index.php?topic=13049.0
« Last Edit: December 06, 2005, 12:55:20 pm by Cyclist »
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 19 queries.