Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Unable to change language from admin panel  (Read 7267 times)

0 Members and 1 Guest are viewing this topic.

zentari

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Unable to change language from admin panel
« on: November 30, 2005, 07:30:40 pm »

on Coppermine Photo Gallery 1.4.2 (stable)
As the subject suggests , I'm unable to change the language to bulgarian (or any other language) from the admin panel. I get the message "Coppermine configuration was updated" but, the language remains english and when I return to the admin panel - it is again set to english. I see all the characters corretly.

I read    http://forum.coppermine-gallery.net/index.php?topic=24075.msg111088#msg111088

But just exiting the site and deleting the cookies/cash/form information does not seem to help at all.

Just to be on the safe side, I tried this as well - but it did not help either

http://forum.coppermine-gallery.net/index.php?topic=24342.0

On the same machine coppermine 1.3.X worked with no such problems.
Any ideas? (By the way, could this be server side problem?)
« Last Edit: November 30, 2005, 10:54:47 pm by GauGau »
Logged

Nibbler

  • Guest
Re: Unable to change language from admin panel
« Reply #1 on: November 30, 2005, 07:31:49 pm »

Can you post a link ?
Logged

zentari

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Unable to change language from admin panel
« Reply #2 on: November 30, 2005, 07:39:34 pm »

Can you post a link ?

Not really sure if u can open it from outside of bulgaria, but - here it is

http://www.animebg.com/mods/gallery/index.php

(tnx for the fast reply)
Logged

zentari

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Update
« Reply #3 on: November 30, 2005, 07:47:37 pm »

Update

 it seems that I can choose the language from the language bar on the bottom. And the language for my user is now set to Bulgarian. When I go to the config menu - it even shows that the language is set to Bulgarian. But the unregistered see it in english. After that I leave the site , clear cookies and stuff, revisit the gallery and the language is again english.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Unable to change language from admin panel
« Reply #4 on: November 30, 2005, 07:53:57 pm »

There's no "real" bulgarian language file, the one you're using comes from cpg1.3.x and therefor doesn't contain all needed strings. Make sure you have enabled language fallback and set the encoding to unicode (utf-8). This should show the gallery to the visitor in his/her language if the language exists. Only if it doesn't exist, the page will default back to the language you set up in config.

Joachim
Logged

zentari

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Unable to change language from admin panel
« Reply #5 on: November 30, 2005, 08:14:25 pm »

Mhm - well - after I switch manually to the language I want (bulgarian) from the language scroll menu in the bottom, it works good enough for me. The problem is that I can't save the changes i the config menu. I change from english to bulgarian, click "save new configuration" and after I refresh the page , the language menu is still selected to english.

After I switch manually to bulgarian - in the config menu - in the language menu I see it set to Bulgarian. I change it to english , save, refresh teh page - and it sais agian bulgarian...and so on  (but only I see the bulgarian it does not reflect to the global settings)

As I said - after I manually switch the language from the bottom language barr - the page displays correcly. The enconding is utf-8 and I do not have problems with it - everything displays perfectly

If the config chechks the language file and after seeing that it is not correct, decides to fall back to the default? And the language scroll menu in the bottom loads it dirrectly without checking it?
« Last Edit: November 30, 2005, 08:20:19 pm by zentari »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Unable to change language from admin panel
« Reply #6 on: November 30, 2005, 08:19:24 pm »

PM me a link to your coppermine site and an admin account. Add reference to this thread as well.
Logged

zentari

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Unable to change language from admin panel
« Reply #7 on: November 30, 2005, 08:30:33 pm »

PM me a link to your coppermine site and an admin account. Add reference to this thread as well.


done
Logged

zentari

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Unable to change language from admin panel
« Reply #8 on: November 30, 2005, 10:12:00 pm »

Thank you for the help guys, but the solutions u proposed don't work for me. I'll be downgrading to version 1.3.5 , so feel free to close the post.
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 19 queries.