Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Character encoding - Cyrillic (koi8-r) - Cyrillic (windows-1251) once again  (Read 18625 times)

0 Members and 1 Guest are viewing this topic.

Makc666

  • Translator
  • Coppermine addict
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 1614
  • Русский (ISO-8859-1) - Russian - (Windows)
    • Makc's home page

Gallery Configuration - Coppermine Photo Gallery 1.4.2 (stable)
Language & Charset settings
Character encoding

There is choice --> Cyrillic (koi8-r)
There is no choice for --> Cyrillic (windows-1251)

You can see attached screenshot...

P.S. Fresh install!!!
« Last Edit: November 27, 2005, 07:38:11 pm by GauGau »
Logged

Makc666

  • Translator
  • Coppermine addict
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 1614
  • Русский (ISO-8859-1) - Russian - (Windows)
    • Makc's home page

Or. I found it. Forgot about my old post here:
http://forum.coppermine-gallery.net/index.php?topic=19587.0

There is no line:
Code: [Select]
'Cyrillic' => 'windows-1251',in file: admin.php

Code: [Select]
$charsets = array('Default (not recommended)' => 'language file',
'Arabic' => 'iso-8859-6',
'Baltic' => 'iso-8859-4',
'Central European' => 'iso-8859-2',
'Chinese Simplified' => 'euc-cn',
'Chinese Traditional' => 'big5',
'Cyrillic' => 'koi8-r',
'Greek' => 'iso-8859-7',
'Hebrew' => 'iso-8859-8-i',
'Icelandic' => 'x-mac-icelandic',
'Japanese' => 'euc-jp',
'Korean' => 'euc-kr',
'Maltese' => 'iso-8859-3',
'Thai' => 'windows-874 ',
'Turkish' => 'iso-8859-9',
'Unicode (recommended)' => 'utf-8',
'Vietnamese' => 'windows-1258',
'Western' => 'iso-8859-1'
);


In charsetmgr.php there is code for this one (windows-1251):
Code: [Select]
$charsets = array(//'Default' => 'language file',
'Arabic' => 'iso-8859-6',
'Baltic' => 'iso-8859-4',
'Central European' => 'iso-8859-2',
'Chinese Simplified' => 'euc-cn',
'Chinese Traditional' => 'big5',
'Cyrillic (windows-1251)' => 'windows-1251',
'Cyrillic (koi8-r)' => 'koi8-r',
'Greek' => 'iso-8859-7',
'Hebrew' => 'iso-8859-8-i',
'Icelandic' => 'x-mac-icelandic',
'Japanese' => 'euc-jp',
'Korean' => 'euc-kr',
'Maltese' => 'iso-8859-3',
'Thai' => 'windows-874',
'Turkish' => 'iso-8859-9',
'Unicode' => 'utf-8',
'Vietnamese' => 'windows-1258',
'Western' => 'iso-8859-1'
);
« Last Edit: November 27, 2005, 12:54:30 am by Makc666 »
Logged

Makc666

  • Translator
  • Coppermine addict
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 1614
  • Русский (ISO-8859-1) - Russian - (Windows)
    • Makc's home page

But you can't add like this in admin.php
Code: [Select]
'Cyrillic' => 'windows-1251',
'Cyrillic' => 'koi8-r',

As it will not work and these two lines have the same name between '' tags ('Cyrillic').

So you have to add like this one:
Code: [Select]
'Cyrillic windows' => 'windows-1251',
'Cyrillic koi8' => 'koi8-r',

So the final "good" code will look like:
Code: [Select]
$charsets = array('Default (not recommended)' => 'language file',
'Arabic' => 'iso-8859-6',
'Baltic' => 'iso-8859-4',
'Central European' => 'iso-8859-2',
'Chinese Simplified' => 'euc-cn',
'Chinese Traditional' => 'big5',
'Cyrillic windows' => 'windows-1251',
'Cyrillic koi8' => 'koi8-r',
'Greek' => 'iso-8859-7',
'Hebrew' => 'iso-8859-8-i',
'Icelandic' => 'x-mac-icelandic',
'Japanese' => 'euc-jp',
'Korean' => 'euc-kr',
'Maltese' => 'iso-8859-3',
'Thai' => 'windows-874 ',
'Turkish' => 'iso-8859-9',
'Unicode (recommended)' => 'utf-8',
'Vietnamese' => 'windows-1258',
'Western' => 'iso-8859-1'
);

Here a fixed screenshot:
Logged

Joachim Mller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

why not use unicode?
Logged

Makc666

  • Translator
  • Coppermine addict
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 1614
  • Русский (ISO-8859-1) - Russian - (Windows)
    • Makc's home page

why not use unicode?
Because here in Russian we like to use Cyrillic windows-1251.
I posted not enough information about this BUG, so it can be fixed?
Logged

Joachim Mller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

not a bug. The dev team has decided that we'll use unicode exclusively. The other encodings will vanish soon. This is not a matter of personal preferences or taste imo.
Logged

natalina

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Female
  • Posts: 96
    • Interior & Architecture

I have the same problem & found the solution (very boring). I saved on my computer lang.php in windows1251, then rewrite translation & upload the file to the server. It works perfect. But now I' m still using unicode - 2 much 2 translate. But I'll do it anyway -because of few but awfull mistakes in Russian  - like До свидание (goodbye) is absolutely wrong...

Joachim Mller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

your reply is not relevant, you're free to convert the utf-8 file to something else. Phrases that are translated wrongly (in your opinion) are not related to this at all. Repyling to a thread on the bugs board that is marked as "invalid" is not a clever move. Locking thread now (it's sad that we're forced to do this - I wish people respected board rules).
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 19 queries.