Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: HTTPS Issue  (Read 9049 times)

0 Members and 1 Guest are viewing this topic.

Made68

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
HTTPS Issue
« on: April 07, 2024, 11:28:36 am »

Hello,

I have created a free ZerroSSL SSL certificate and install it on my domain hosting provider.
The site works perfect in http, but it give give me an error in https, but when i edit the certificate it mention that the certificate is trusted and valid.

Error HTTPS: Blank page with mention
Forbidden
You don't have permission to access this resource.

Edit Certificate:
This page is secure (valid HTTPS).  See attachement

I have search to enable HTTPS option in admin panel but found nothing.

What do i need to do to get this to work?

Thanks for your help.


Version: Coppermine Photo Gallery 1.4.14 (will upgrade ASAP)
Logged

lurkalot

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 949
  • +Tinyportal Support team.
Re: HTTPS Issue
« Reply #1 on: April 07, 2024, 02:18:05 pm »

Did you change the URL of your Coppermine gallery folder to https in config?
Logged
Running SMF 2.1.4  / Tinyportal 3.0.0, bridged with Coppermine 1.6.25, plus cpmfetch 2.0.0

Made68

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: HTTPS Issue
« Reply #2 on: April 07, 2024, 03:29:39 pm »

No, the only place where i have change it is on the admin page (General Parameters), URL to your Gallery and url to your Homepage, but that did not resolved the problem so i set back to http.

Do i need to change it into the config.php file only?

Thanks for your help.
Logged

Made68

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: HTTPS Issue
« Reply #3 on: April 07, 2024, 03:43:54 pm »

If you mean config on the administration page, yes i change bot http:// url's to https.  (did not solve the problem.)
Logged

lurkalot

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 949
  • +Tinyportal Support team.
Re: HTTPS Issue
« Reply #4 on: April 07, 2024, 04:09:36 pm »

Well the folder in the coppermine admin panel (Config) must should be https

Are you using a custom theme, because that might have urls hard coded in it.
Logged
Running SMF 2.1.4  / Tinyportal 3.0.0, bridged with Coppermine 1.6.25, plus cpmfetch 2.0.0

Made68

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: HTTPS Issue
« Reply #5 on: April 07, 2024, 05:16:30 pm »

Set both url's back to https://
Yes, i ma using rainy day template,  Edit the .php files into template folder but nothing that describes http or https.
Logged

Made68

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: HTTPS Issue
« Reply #6 on: April 07, 2024, 05:20:45 pm »

Bot links to site into admin pannel modified to https://


Result:
It shows still the valid https certification icon with valid certification description but blank page with .....

Forbidden
You don't have permission to access this resource.

Crazy..

Logged

Made68

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: HTTPS Issue
« Reply #7 on: April 07, 2024, 09:55:06 pm »

Problem Solved,

Just got a mail from my hosting provider explained that my site was pointing to a wrong folder (Private/Public folder)

A made the requested modification into site admin panel, changed site links in gallery config to https and all now is working in https://   :) :) :)

Thanks all for your help.

Kr,
Marc
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.