Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: My browsers never use Unicode (UTF-8)  (Read 12993 times)

0 Members and 1 Guest are viewing this topic.

Seelachs

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
    • Sardinien-Galerie
My browsers never use Unicode (UTF-8)
« on: November 24, 2005, 05:59:06 pm »

If I look at the html source code of http://sardinien.sa.funpic.de/galerie/index.php  I can see the tag
Code: [Select]
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />But my browsers (both Firefox 1.0.7 and Internet Explorer 6 SP2) use the Western ISO-8859-1 coding even if I set the Firefox defaults to Unicode.
So I always see ß, ä and so on instead of , ...
But e.g. Wikipedia and the new demo at http://coppermine-gallery.net/Obsolete are displayed correctly in Unicode.
Why cpg not? (I just installed the newest version 1.4.2)


Greetz and thx
SehLax
« Last Edit: November 24, 2005, 07:35:42 pm by Seelachs »
Logged

daniel_w

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 10
Re: My browsers never use Unicode (UTF-8)
« Reply #1 on: November 24, 2005, 10:57:43 pm »

same here
Logged

Joachim Mller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: My browsers never use Unicode (UTF-8)
« Reply #2 on: November 24, 2005, 11:05:08 pm »

may be related to the pop-up ad that your webhost adds - it keeps the page from being valid.
Logged

daniel_w

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 10
Re: My browsers never use Unicode (UTF-8)
« Reply #3 on: November 24, 2005, 11:05:44 pm »

I'm running my own server ;)
Logged

Joachim Mller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: My browsers never use Unicode (UTF-8)
« Reply #4 on: November 24, 2005, 11:41:14 pm »

doesn't matter, the pop-up ruins the html ouput, no matter where this is being hosted. There mustn't be any html output after </html>. Attached is the output your page creates.

Joachim
Logged

daniel_w

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 10
Re: My browsers never use Unicode (UTF-8)
« Reply #5 on: November 25, 2005, 09:38:34 am »

Code: [Select]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html dir="ltr">
<head>

This ist what my output - without any changes to the template...

(and there is no output after the </html>)
Logged

Joachim Mller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: My browsers never use Unicode (UTF-8)
« Reply #6 on: November 25, 2005, 09:43:59 am »

the pop-up may not be visible for you, but it is for others. This is something funpic.de does. The "funny" chars at the start come from a BOM - did you edit your language file?
Logged

daniel_w

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 10
Re: My browsers never use Unicode (UTF-8)
« Reply #7 on: November 25, 2005, 09:57:52 am »

Sorry, but again: I'm running coppermine on my own server - no funpic! And what is "BOM"? (No, I did no changes to the language file)
Logged

Joachim Mller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: My browsers never use Unicode (UTF-8)
« Reply #8 on: November 25, 2005, 10:06:52 am »

Look, you can take my word on it that your page looks different to you than it looks to others - did you never ask yourself why funpic.de is giving you a subdomain for free? I attached a screenshot how your site looks for me. If you don't believe me, go to another PC and view your gallery there.
BOM: http://en.wikipedia.org/w/index.php?title=Byte_Order_Mark
Logged

daniel_w

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 10
Re: My browsers never use Unicode (UTF-8)
« Reply #9 on: November 25, 2005, 10:10:08 am »

I'm not "Seelachs" - I'm "daniel_w" - and http://sardinien.sa.funpic.de/galerie/index.php is not my gallery...
Logged

Joachim Mller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: My browsers never use Unicode (UTF-8)
« Reply #10 on: November 25, 2005, 10:20:46 am »

ah ok, sorry. Guess this comes from thread hijacking. Seems like you haven't actually posted a link to your site so far. Do so now.
Logged

Seelachs

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
    • Sardinien-Galerie
Re: My browsers never use Unicode (UTF-8)
« Reply #11 on: November 25, 2005, 01:11:35 pm »

doesn't matter, the pop-up ruins the html ouput, no matter where this is being hosted. There mustn't be any html output after </html>. Attached is the output your page creates.

Joachim

Yeah, I always see my popup  :(
But they didn't have one in the older days ...
So maybe I have to translate the Language file to ISO or change my hoster   ??? :-\\
But thanks for your help.
Logged

alanlai

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 53
    • Goddess
Re: My browsers never use Unicode (UTF-8)
« Reply #12 on: November 28, 2005, 01:41:34 pm »

put this:

<?php header("Content-Type: text/html; charset=utf-8"); ?>

into your "custom header" file

it helps

Seelachs

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
    • Sardinien-Galerie
Re: My browsers never use Unicode (UTF-8)
« Reply #13 on: November 28, 2005, 03:02:11 pm »

put this:

<?php header("Content-Type: text/html; charset=utf-8"); ?>

into your "custom header" file

it helps

Yeah, thanks a lot, it really works!
So, GauGau, you should include this into the great CPG!
Logged
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 19 queries.