Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Problème BDD et UTF-8 avec Copp. 1.3.5  (Read 4609 times)

0 Members and 1 Guest are viewing this topic.

Ante

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Problème BDD et UTF-8 avec Copp. 1.3.5
« on: November 06, 2005, 05:01:05 pm »

Salut à tous,

Je poste pour vous faire part d'une erreur que je rencontre depuis aujourd'hui (hier bizarrement tout fonctionnait bien...). Lorsque j'upload une image de mon DD ou lorsque je donne une URL d'une image sur mon serveur, il me dit que l'upload s'est fait avec succès, mais après il me dit ceci :

Code: [Select]
Warning: exec() has been disabled for security reasons in /home/www/cedzone/www/galeries/include/picmgmt.inc.php on line 162

Warning: chmod(): No such file or directory in /home/www/cedzone/www/galeries/include/picmgmt.inc.php on line 224

Warning: getimagesize(./albums/edit/preview_3b586e48.jpg): failed to open stream: No such file or directory in /home/www/cedzone/www/galeries/include/picmgmt.inc.php on line 226

Bizarrement il me parle de CHMOD, mais j'ai testé avec un CHMOD 755 et 777 comme indiqué dans la documentation de Coppermine.

Autre truc spécial, lorsque je navigue sur le site, il affiche les caractères correctement, mais après quelques clics, il déconne et affiche de faux caractères pour les accentuations (je suis pourtant en French UTF-8...)

Je précise que cela est apparu aujourd'hui, hier pas de prob. Et la seul modif que j'ai fait, c'est de changer le thème par défaut pour utiliser le thème Kubrik...

Merci pour votre aide.


Cédric.
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9094
  • aka Frantz
    • Ma galerie
Re: Problème BDD et UTF-8 avec Copp. 1.3.5
« Reply #1 on: November 06, 2005, 05:27:06 pm »

Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

Ante

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Problème BDD et UTF-8 avec Copp. 1.3.5
« Reply #2 on: November 06, 2005, 07:32:43 pm »

Merci! Le problème d'upload des images est reglé!

Par contre je n'ai tjr pas trouvé ce qui clochait avec mes caractères.... apparement ca me le fait dans FireFox 1.0.7, et pas dans IE 6...
Ce qui est bizarre c'est que hier je n'avais pas de problème ni ds Firefox ni ds IE. Et apparement ce n'est pas lié au thème (ce qui est logique en soi) car j'ai testé avec différents thèmes.
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9094
  • aka Frantz
    • Ma galerie
Re: Problème BDD et UTF-8 avec Copp. 1.3.5
« Reply #3 on: November 06, 2005, 07:40:12 pm »

J'ai le même genre de problème  :-\\
ça se passe entre le codage des pages et l'encodage des caractères définis par le navigateur (il me semble, mais Titooy pourra préciser, il est bien plus compétent que moi sur ce sujet (et sur d'autres  ;D))
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

Ante

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Problème BDD et UTF-8 avec Copp. 1.3.5
« Reply #4 on: November 06, 2005, 07:45:12 pm »

Effectivement, lorsque je force FireFox en UTF-8 le problème disparait  :(.....................
Logged

Titooy

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 736
    • under construction...
Re: Problème BDD et UTF-8 avec Copp. 1.3.5
« Reply #5 on: November 06, 2005, 10:49:14 pm »

Que dit le code source ?
<meta http-equiv="Content-Type" content="text/html; charset=???" />

Une autre possibilité est que la détection automatique de l'encodage n'est peut-être pas activée dans Firefox...

Un lien pour voir si on a le même problème ?
Logged
Pages: [1]   Go Up
 

Page created in 0.025 seconds with 19 queries.