Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: MyTopix bridge file for 1.4  (Read 13473 times)

0 Members and 1 Guest are viewing this topic.

Nibbler

  • Guest
MyTopix bridge file for 1.4
« on: November 05, 2005, 09:38:33 pm »

Bridge file for use with MyTopix forum software. To use, extract file and fill in the info:

Code: [Select]
// local path to your mytopix config file
$path = '../mytopix/';
$this->use_post_based_groups = 0;

Then upload into your cpg bridge dir and run the bridge manager, entering 'mypix' as a custom bridge file. Set post based groups to 1 to import usergroups from the board. If you leave it as 0 then everyone gets dumped into the members group for easy administration.

Logged

DARRKCLOUD

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: MyTopix bridge file for 1.4
« Reply #1 on: November 06, 2005, 12:34:37 pm »

It works very well, but there is an problem. If you go to my profile, and try to edit it, then it outputs:
Quote
The system cannot find the appropriate data to match your request. Please ensure that your input is in the correct format.
I fixed this by finding
Code: [Select]
// Pages to redirect to
$this->page = array(
'register' => '/index.php?a=register',
'editusers' =>  '/index.php?a=members',
'edituserprofile' => '/index.php?a=ucp&CODE=00'
);
and changing it to
Code: [Select]
// Pages to redirect to
$this->page = array(
'register' => '/index.php?a=register',
'editusers' =>  '/index.php?a=members',
'edituserprofile' => '/index.php?a=ucp&id='
);
Otherwise it works perfectly. :D

DEMO:
http://www.nitrocarcentral.ath.cx/community/
http://www.nitrocarcentral.ath.cx/gallery/
Logged

DARRKCLOUD

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: MyTopix bridge file for 1.4
« Reply #2 on: November 06, 2005, 03:35:13 pm »

Realised an bug. If you login, click car gallery, and go back to the forums, then all of your posts are duplicated. You also get an duplicate entry in the active users, so i think that is connected. Any ideas? Screen below:
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: MyTopix bridge file for 1.4
« Reply #3 on: November 06, 2005, 03:40:42 pm »

How could the bridge file interfere with your board? This process is only possible vice versa afaik.
Logged

DARRKCLOUD

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: MyTopix bridge file for 1.4
« Reply #4 on: November 06, 2005, 03:52:17 pm »

It was working fine before i used the bridge.  I think it is coppermine's active users doing it, so i am going to find it an comment it out. :(
« Last Edit: November 06, 2005, 04:10:46 pm by DARRKCLOUD »
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 19 queries.