Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Internet Explorer Problem  (Read 18084 times)

0 Members and 1 Guest are viewing this topic.

Anna

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Internet Explorer Problem
« on: October 21, 2005, 01:14:11 am »

So I customized the waterdrop theme and it looks great in firefox browser but awful in internet explorer.

IE: http://img472.imageshack.us/img472/361/galleryie4fg.jpg
Firefox: http://img472.imageshack.us/img472/9995/galleryf8ld.jpg

Anyone have an ideas on how this could be fixed?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Internet Explorer Problem
« Reply #1 on: October 21, 2005, 06:55:49 am »

post a link to your site instead of links to screenshots. The supporters have different browsers as well, there's little sense in looking just at screenshots without being able to see what you did.
Logged

Anna

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Internet Explorer Problem
« Reply #2 on: October 22, 2005, 05:04:15 am »

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Internet Explorer Problem
« Reply #3 on: October 22, 2005, 09:20:21 am »

there are several issues with your page: you have a JavaScript error, and you have
Code: [Select]
<MAP NAME="yea">
<AREA SHAPE=RECT COORDS="226,274,246,285" HREF="http://thrill-threat.cjb.net/gallery/">

<AREA SHAPE=RECT COORDS="252,270,281,285" HREF="http://thrill-threat.cjb.net/gallery/register.php">
<AREA SHAPE=RECT COORDS="285,271,308,284" HREF="http://thrill-threat.cjb.net/gallery/login.php?referer=%2Fgallery%2Findex.php">
<AREA SHAPE=RECT COORDS="313,272,338,284" HREF="http://thrill-threat.cjb.net/gallery/thumbnails.php?album=lastup&cat=0">
<AREA SHAPE=RECT COORDS="342,273,367,285" HREF="http://thrill-threat.cjb.net/gallery/search.php">
</MAP>
<!-- End of CSIM -->
right after the </html> tag, which is bullsh*t
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Internet Explorer Problem
« Reply #4 on: October 22, 2005, 12:08:28 pm »

@Anna: If the Firefox version is the correct one, you should unhide the Powered by credit line.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Internet Explorer Problem
« Reply #5 on: October 22, 2005, 02:03:00 pm »

No further support until you properly display the Powered by tag line.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Internet Explorer Problem
« Reply #6 on: October 22, 2005, 02:37:17 pm »

oh, yes - I didn't notice that you hid this line. Do as suggested and put it back. Making in "invisible" by assigning the same text color as the backgrund equals removing it, which is a copyright violation. >:(
Logged

Anna

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Internet Explorer Problem
« Reply #7 on: October 22, 2005, 04:23:27 pm »

@Anna: If the Firefox version is the correct one, you should unhide the Powered by credit line.

That wasn't on purpose. I am still trying to fix the theme so everything is working properlly, and haven't exactly figured out how to make it show up.
Logged

Anna

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Internet Explorer Problem
« Reply #8 on: October 22, 2005, 04:32:09 pm »

there are several issues with your page: you have a JavaScript error, and you have
Code: [Select]
<MAP NAME="yea">
<AREA SHAPE=RECT COORDS="226,274,246,285" HREF="http://thrill-threat.cjb.net/gallery/">

<AREA SHAPE=RECT COORDS="252,270,281,285" HREF="http://thrill-threat.cjb.net/gallery/register.php">
<AREA SHAPE=RECT COORDS="285,271,308,284" HREF="http://thrill-threat.cjb.net/gallery/login.php?referer=%2Fgallery%2Findex.php">
<AREA SHAPE=RECT COORDS="313,272,338,284" HREF="http://thrill-threat.cjb.net/gallery/thumbnails.php?album=lastup&cat=0">
<AREA SHAPE=RECT COORDS="342,273,367,285" HREF="http://thrill-threat.cjb.net/gallery/search.php">
</MAP>
<!-- End of CSIM -->
right after the </html> tag, which is bullsh*t

Where should I put that then? I need the image map for my menu.







And for the coppermine link, I just put it in anycontent because I couldn't think of an easy way to unhide it since I liked my colors.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Internet Explorer Problem
« Reply #9 on: October 22, 2005, 05:42:26 pm »

CSS - footer class.  Unhide it.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Anna

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Internet Explorer Problem
« Reply #10 on: October 22, 2005, 08:44:55 pm »

CSS - footer class.  Unhide it.

I put the link in the anycontent area instead. Because I am not sure exactly how to unhide it without changing all of my colors.

Unless you can tell me how to do it.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Internet Explorer Problem
« Reply #11 on: October 22, 2005, 08:45:53 pm »

style.css - footer

Change the color.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Anna

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Internet Explorer Problem
« Reply #12 on: October 22, 2005, 08:52:08 pm »

style.css - footer

Change the color.


Ooo. ok. All fixed now. Sorry about that. I must have changed it accidently when I was customizing the gallery.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Internet Explorer Problem
« Reply #13 on: October 23, 2005, 01:35:17 pm »

sure, only accidentally - not on purpose. Happens all the times. Happens to me as well. Even if you don't know your way around at all in html, you still find out how to accidentally mis-edit the footer class that isn't doing anything but determining the look of the "Powered by Coppermine" tag. How about saying something like "sorry"? Would make more sense instead of saying you edited it by accident, especially if you want support.
Logged

Anna

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Internet Explorer Problem
« Reply #14 on: October 23, 2005, 06:20:58 pm »

sure, only accidentally - not on purpose. Happens all the times. Happens to me as well. Even if you don't know your way around at all in html, you still find out how to accidentally mis-edit the footer class that isn't doing anything but determining the look of the "Powered by Coppermine" tag. How about saying something like "sorry"? Would make more sense instead of saying you edited it by accident, especially if you want support.

I honestly did do it by accident. I am not a freaking liar. When I was chaning the colors I wasn't paying attention to what the title of each section was. I just chose what color I wanted to change and went down the page replacing each one that matched with the new color. I am new at this so didn't exactly know what I was doing.There would be no reason I would try to hide it on purpose. I didn't even notice it was hidden till you pointed it out to me yesterday.

sjghssjdghsdjkg

And I DID say I was sorry. And I DID do it by accident since I was going through the thing pretty quickly. IF there is anything I hate more than anything else, it is being accused of something I didn't actually do.
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Internet Explorer Problem
« Reply #15 on: October 23, 2005, 07:06:53 pm »

FWIW, Anna did say she based the theme on water_drop. When I compared her version (from before) and water drop, it seemed the footer styles were unmodified. Since she insists it was an accident, I'd give her the benefit of the doubt, since it does seem like an oversight not to modify the footer section to account for her added black background.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Internet Explorer Problem
« Reply #16 on: October 24, 2005, 07:47:27 am »

OK, sorry, let's get back to the initial question then. You haven't removed the section
Code: [Select]
<MAP NAME="yea">
<AREA SHAPE=RECT COORDS="226,274,246,285" HREF="http://thrill-threat.cjb.net/gallery/">
<AREA SHAPE=RECT COORDS="252,270,281,285" HREF="http://thrill-threat.cjb.net/gallery/register.php">

<AREA SHAPE=RECT COORDS="285,271,308,284" HREF="http://thrill-threat.cjb.net/gallery/login.php?referer=%2Fgallery%2Findex.php">
<AREA SHAPE=RECT COORDS="313,272,338,284" HREF="http://thrill-threat.cjb.net/gallery/thumbnails.php?album=lastup&cat=0">
<AREA SHAPE=RECT COORDS="342,273,367,285" HREF="http://thrill-threat.cjb.net/gallery/search.php">
</MAP>
- it's still after the </html> section. Edit http://www.thrill-threat.cjb.net/gallery/themes/water_drop/template.html, and replace everything with
Code: [Select]
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html dir="{LANG_DIR}">
<head>
<title>{TITLE}</title>
<meta http-equiv="Content-Type" content="text/html; charset={CHARSET}" />
<meta http-equiv="Pragma" content="no-cache" />
{META}
<link rel="stylesheet" href="themes/water_drop/style.css" />
<script type="text/javascript" src="scripts.js"></script>
<!-- $Id: template.html,v 1.4 2004/07/24 15:04:23 gaugau Exp $ -->
</head>
<body>
<table width="70%" height="100%" border="0" cellpadding="20" cellspacing="20">
<tr>
        <td valign="top" bordercolor="#666666" bgcolor="#000000" style="border: 1px solid #ccd7e0; background-color: #000000;">

                <table width="100%" border="0" cellspacing="0" cellpadding="0">
                       <tr>
                                <td width="100%" align="center">
                                        <img src="http://img257.imageshack.us/img257/696/pmheader8sl.jpg" usemap="#yea" width="484" height="287" border="0" alt="" />
                                        <br />
                                      {LANGUAGE_SELECT_FLAGS}<br>{LANGUAGE_SELECT_LIST}&nbsp;
                                        {THEME_SELECT_LIST}
                                </td>

                        </tr>
                </table>
                <img src="images/spacer.gif" width="1" height="15" /><br />
                <table width="100%" border="0" align="center" cellpadding="0" cellspacing="0">
                        <tr>
                                <td align="center" valign="top">
                                        {ADMIN_MENU}
                                        {GALLERY}

                                </td>
                        </tr>

                </table>
        </td>
</tr>
</table>
<map name="yea">
<area shape=rect coords="226,274,246,285" href="http://thrill-threat.cjb.net/gallery/">
<area shape=rect coords="252,270,281,285" href="http://thrill-threat.cjb.net/gallery/register.php">
<area shape=rect coords="285,271,308,284" href="http://thrill-threat.cjb.net/gallery/login.php">
<area shape=rect coords="313,272,338,284" href="http://thrill-threat.cjb.net/gallery/thumbnails.php?album=lastup&amp;cat=0">
<area shape=rect coords="342,273,367,285" href="http://thrill-threat.cjb.net/gallery/search.php">
</map>
</body>
</html>
However, that's so-called "mystery meat navigation". If I was to go to your page, I wouldn't find it logical to hover over an image that doesn't clearly show that it's meant to be used for page navigation. The text is much too small to be visible as navigation, I would have taken it as watermark. I guarantee that many users will leave your site just because they can't find the right spot.

Joachim
Logged

Anna

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Internet Explorer Problem
« Reply #17 on: October 24, 2005, 10:54:26 pm »

OK, sorry, let's get back to the initial question then. You haven't removed the section
Code: [Select]
<MAP NAME="yea">
<AREA SHAPE=RECT COORDS="226,274,246,285" HREF="http://thrill-threat.cjb.net/gallery/">
<AREA SHAPE=RECT COORDS="252,270,281,285" HREF="http://thrill-threat.cjb.net/gallery/register.php">

<AREA SHAPE=RECT COORDS="285,271,308,284" HREF="http://thrill-threat.cjb.net/gallery/login.php?referer=%2Fgallery%2Findex.php">
<AREA SHAPE=RECT COORDS="313,272,338,284" HREF="http://thrill-threat.cjb.net/gallery/thumbnails.php?album=lastup&cat=0">
<AREA SHAPE=RECT COORDS="342,273,367,285" HREF="http://thrill-threat.cjb.net/gallery/search.php">
</MAP>
- it's still after the </html> section. Edit http://www.thrill-threat.cjb.net/gallery/themes/water_drop/template.html, and replace everything with
Code: [Select]
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html dir="{LANG_DIR}">
<head>
<title>{TITLE}</title>
<meta http-equiv="Content-Type" content="text/html; charset={CHARSET}" />
<meta http-equiv="Pragma" content="no-cache" />
{META}
<link rel="stylesheet" href="themes/water_drop/style.css" />
<script type="text/javascript" src="scripts.js"></script>
<!-- $Id: template.html,v 1.4 2004/07/24 15:04:23 gaugau Exp $ -->
</head>
<body>
<table width="70%" height="100%" border="0" cellpadding="20" cellspacing="20">
<tr>
        <td valign="top" bordercolor="#666666" bgcolor="#000000" style="border: 1px solid #ccd7e0; background-color: #000000;">

                <table width="100%" border="0" cellspacing="0" cellpadding="0">
                       <tr>
                                <td width="100%" align="center">
                                        <img src="http://img257.imageshack.us/img257/696/pmheader8sl.jpg" usemap="#yea" width="484" height="287" border="0" alt="" />
                                        <br />
                                      {LANGUAGE_SELECT_FLAGS}<br>{LANGUAGE_SELECT_LIST}&nbsp;
                                        {THEME_SELECT_LIST}
                                </td>

                        </tr>
                </table>
                <img src="images/spacer.gif" width="1" height="15" /><br />
                <table width="100%" border="0" align="center" cellpadding="0" cellspacing="0">
                        <tr>
                                <td align="center" valign="top">
                                        {ADMIN_MENU}
                                        {GALLERY}

                                </td>
                        </tr>

                </table>
        </td>
</tr>
</table>
<map name="yea">
<area shape=rect coords="226,274,246,285" href="http://thrill-threat.cjb.net/gallery/">
<area shape=rect coords="252,270,281,285" href="http://thrill-threat.cjb.net/gallery/register.php">
<area shape=rect coords="285,271,308,284" href="http://thrill-threat.cjb.net/gallery/login.php">
<area shape=rect coords="313,272,338,284" href="http://thrill-threat.cjb.net/gallery/thumbnails.php?album=lastup&amp;cat=0">
<area shape=rect coords="342,273,367,285" href="http://thrill-threat.cjb.net/gallery/search.php">
</map>
</body>
</html>
However, that's so-called "mystery meat navigation". If I was to go to your page, I wouldn't find it logical to hover over an image that doesn't clearly show that it's meant to be used for page navigation. The text is much too small to be visible as navigation, I would have taken it as watermark. I guarantee that many users will leave your site just because they can't find the right spot.

Joachim

I tried the code and it still looks bad in Internet Explorer.


And I knew there was something I forgot to do. I was going to put "Navigation" in big text above it on the image, but I totally forgot. Haha. Thanks for the reminder.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Internet Explorer Problem
« Reply #18 on: October 25, 2005, 12:46:58 am »

in http://www.thrill-threat.cjb.net/gallery/themes/water_drop/template.html, find
Code: [Select]
<td valign="top" bordercolor="#666666" bgcolor="#000000" style="border: 1px solid #ccd7e0; background-color: #000000;">and replace with
Code: [Select]
<td valign="top" style="border:1px solid #CCD7E0; background-color:#000000;">
Logged

Anna

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Internet Explorer Problem
« Reply #19 on: October 25, 2005, 01:55:49 am »

in http://www.thrill-threat.cjb.net/gallery/themes/water_drop/template.html, find
Code: [Select]
<td valign="top" bordercolor="#666666" bgcolor="#000000" style="border: 1px solid #ccd7e0; background-color: #000000;">and replace with
Code: [Select]
<td valign="top" style="border:1px solid #CCD7E0; background-color:#000000;">

*le sigh*

Still not working.

Logged
Pages: [1] 2   Go Up
 

Page created in 0.103 seconds with 19 queries.