Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Multiple file upload fails - Single file upload works ok.  (Read 6087 times)

0 Members and 1 Guest are viewing this topic.

simon.cook

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Multiple file upload fails - Single file upload works ok.
« on: October 13, 2005, 02:26:21 pm »

I have looked through the forum, haven't seen this particular issue noted.

Problem description:
File-URI uploads are staged successfully but fail to be committed to the selected photo album with the following error.

"The previous file could not be placed.
You have successfully placed all the files."

The above error occurs with a single or multiple files selected for upload via the "File-URI", "Multiple file uploads only" and "URI uploads only" methods.
"Single file upload only" method works fine.

Problem environment:
PHP version: 5.0.5
Coppermine version: 1.3.5
Operating system: Windows 2003 Server SP1
Web server: IIS 6

Have followed troubleshooting steps in "General Upload Troubleshooting" article.
http://forum.coppermine-gallery.net/index.php?topic=5841.0

Permissions are ok.
All system variables are as documented.

Batch uploading also works without issue.

Have created test account for support access;
username: testuser
password: coppermine
url: http://cgi.valebridge.net/photo/index.php

Debugging is switched on.
Upload method for testuser is currently set to "File-URI".

Any assistance with this is greatly appreciated.

Best regards

Simon Cook
« Last Edit: October 15, 2005, 02:19:49 pm by Abbas Ali »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Multiple file upload fails - Single file upload works ok.
« Reply #1 on: October 14, 2005, 07:35:13 am »

is allow_url_fopen  enabled on your server? If no, you can't use "upload by uri".
Logged

simon.cook

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Multiple file upload fails - Single file upload works ok.
« Reply #2 on: October 14, 2005, 10:39:52 am »

Good morning and thanks for looking into this,

From PHPInfo... sorry about the formatting

allow_url_fopen = on

Please remove any information you feel is sensitive.

Configuration
PHP Core
Directive   Local Value
allow_call_time_pass_reference   Off
allow_url_fopen   On
always_populate_raw_post_data   Off
arg_separator.input   &
arg_separator.output   &
asp_tags   Off
auto_append_file   no value
auto_globals_jit   On
auto_prepend_file   no value
browscap   no value
default_charset   no value
default_mimetype   text/html
define_syslog_variables   Off
disable_classes   no value
disable_functions   no value
display_errors   Off
display_startup_errors   Off
doc_root   C:\Inetpub\wwwroot
docref_ext   no value
docref_root   no value
enable_dl   On
error_append_string   no value
error_log   no value
error_prepend_string   no value
error_reporting   2039
expose_php   On
extension_dir   C:\php\ext
file_uploads   On
highlight.bg   #FFFFFF
highlight.comment   #FF8000
highlight.default   #0000BB
highlight.html   #000000
highlight.keyword   #007700
highlight.string   #DD0000
html_errors   On
ignore_repeated_errors   Off
ignore_repeated_source   Off
ignore_user_abort   Off
implicit_flush   Off
include_path   .;C:\php5\pear
log_errors   On
log_errors_max_len   1024
magic_quotes_gpc   Off
magic_quotes_runtime   Off
magic_quotes_sybase   Off
mail.force_extra_parameters   no value
max_execution_time   30
max_input_time   60
open_basedir   no value
output_buffering   4096
output_handler   no value
post_max_size   8M
precision   14
register_argc_argv   Off
register_globals   Off
register_long_arrays   On
report_memleaks   On
report_zend_debug   On
safe_mode   Off
safe_mode_exec_dir   no value
safe_mode_gid   Off
safe_mode_include_dir   no value
sendmail_from   no value
sendmail_path   no value
serialize_precision   100
short_open_tag   On
SMTP   localhost
smtp_port   25
sql.safe_mode   Off
track_errors   Off
unserialize_callback_func   no value
upload_max_filesize   2M
upload_tmp_dir   no value
user_dir   no value
variables_order   GPCS
xmlrpc_error_number   0
xmlrpc_errors   Off
y2k_compliance   On
zend.ze1_compatibility_mode   Off


Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Multiple file upload fails - Single file upload works ok.
« Reply #3 on: October 14, 2005, 12:17:17 pm »

do the troubleshooting again please.. for me neither URI nor file works

simon.cook

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Multiple file upload fails - Single file upload works ok.
« Reply #4 on: October 14, 2005, 01:03:08 pm »

Hi Stramm,

That is the problem....

Single file upload works fine.
File-URI upload does not.
« Last Edit: October 14, 2005, 01:09:42 pm by simon.cook »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Multiple file upload fails - Single file upload works ok.
« Reply #5 on: October 14, 2005, 01:55:03 pm »

enable single file uploads and post when you have done so, to give us a chance to look at the debug stuff on your site.
Logged

simon.cook

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Multiple file upload fails - Single file upload works ok.
« Reply #6 on: October 14, 2005, 02:02:54 pm »

Thanks GauGau,

"Single file uploads" configured for "testuser" as requested.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Multiple file upload fails - Single file upload works ok.
« Reply #7 on: October 15, 2005, 09:54:02 am »

post a link to the file you were trying to uri-upload that failed.
Logged

simon.cook

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Multiple file upload fails - Single file upload works ok.
« Reply #8 on: October 15, 2005, 01:30:16 pm »

No specific URL was used, I simply browsed to an arbitary web URL with a jpeg on the end.

I presume any would suffice... for example;
http://cgi.valebridge.net/family/baby2/images/scans/20050317a.jpg

My main concern is the multiple file upload mechanism.

I take it you are satisfied that the single file upload mechanism is working without issue.
So I have switched the testuser account over to "File-URI" uploads.

Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Multiple file upload fails - Single file upload works ok.
« Reply #9 on: October 15, 2005, 01:32:01 pm »

please recheck permissions.. something is wrong here
single upload works but when trying to delete the system isn't able to remove the images. Reuploading the same pic again fails

simon.cook

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Multiple file upload fails - Single file upload works ok.
« Reply #10 on: October 15, 2005, 01:51:59 pm »

No problem...

Through ftp client, perms are 777 for albums and include folders.
Through the OS security tab, IUSR_<servername> has;
Read & Execute
List Folder Contents
Read
Write

This was as per the following article on the coppermine site.
http://coppermine-gallery.net/tutorial/permissions/iis.php

I agree it does sound like a permissions issue.
I will elevate the rights for IUSR_<servername> to modify for the Album and Include folders.
« Last Edit: October 15, 2005, 02:06:05 pm by simon.cook »
Logged

simon.cook

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Multiple file upload fails - Single file upload works ok.
« Reply #11 on: October 15, 2005, 01:58:52 pm »

It's a winner, sometimes it takes a fresh pair of eyes on a problem to spot the issue.

IUSR_<servername> requires Modify permissions on the Album folder (and subfolders)...
Makes sense...

READ, WRITE, EXECUTE & DELETE.

The IIS config article only shows Write perms...
http://coppermine-gallery.net/tutorial/permissions/iis.php
You need Modify for the Delete right.

Although this doesn't explain why single file upload works and Multi File does not...?

Thanks for your assistance with this issue guys, top job.... have a good weekend.
« Last Edit: October 15, 2005, 06:34:40 pm by simon.cook »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Multiple file upload fails - Single file upload works ok.
« Reply #12 on: October 16, 2005, 11:24:12 pm »

Glad you were able to solve this. However, this is wrong: you said
Through ftp client, perms are 777 for albums and include folders.
Through the OS security tab, IUSR_<servername> has;
Read & Execute
List Folder Contents
Read
Write
You appear to be on a Windows box using IIS, so there is no CHMOD, the FTP client report is bull* - it can not be 777, as there's no such thing in Windows. As it seems you who is in charge of running the server, I strongly recommend learning more about permissions and server setup. Only if you know what you're doing you can safely operate a server.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 22 queries.