Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [BUGFIX] Votes & comment are not visible in displayimage  (Read 22130 times)

0 Members and 1 Guest are viewing this topic.

gtroll

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 618
    • CPG-Nuke
[BUGFIX] Votes & comment are not visible in displayimage
« on: December 06, 2003, 03:59:47 am »

This is settable in the album properties and group control panel.
BUT there is a bug in cpgnuke1.2.1 scroll down for the answer...

muziqneeds

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
[BUGFIX] Votes & comment are not visible in displayimage
« Reply #1 on: December 06, 2003, 04:02:32 am »

Hi Again

I still getting problem all options are activated in group menu. and there is no option in category menu. http://liquidsnake.net/1.jpg See this screen shot. plese tell me in detail. what to do. i check all options but i think this is a problem of SQL or coding. if you want admin pass then tell me. i will gave you in mail. but please solve my problem

Thanks
Logged

gtroll

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 618
    • CPG-Nuke
No Votes or Comments displayed
« Reply #2 on: December 06, 2003, 05:14:26 am »

OK this is a bug
FIND line 543 displayimage.php

Quote
/*
// Retrieve data for the current album
if (isset($CURRENT_PIC_DATA)) {
    $result = db_query("SELECT title, comments, votes, category FROM {$CONFIG['TABLE_ALBUMS']} WHERE aid='{$CURRENT_PIC_DATA['aid']}' LIMIT 1");
    if (!mysql_num_rows($result)) cpg_die(CRITICAL_ERROR, sprintf($lang_errors['pic_in_invalid_album'], $CURRENT_PIC_DATA['aid']), __FILE__, __LINE__);
    $CURRENT_ALBUM_DATA = mysql_fetch_array($result);
    if (is_numeric($album)) {

Replace with:
Quote

// Retrieve data for the current album
if (isset($CURRENT_PIC_DATA)) {
    $result = db_query("SELECT title, comments, votes, category FROM {$CONFIG['TABLE_ALBUMS']} WHERE aid='{$CURRENT_PIC_DATA['aid']}' LIMIT 1");
    if (!mysql_num_rows($result)) cpg_die(CRITICAL_ERROR, sprintf($lang_errors['pic_in_invalid_album'], $CURRENT_PIC_DATA['aid']), __FILE__, __LINE__);
    $CURRENT_ALBUM_DATA = mysql_fetch_array($result);
}
/*
    if (is_numeric($album)) {

This happened when we changed the breadcrumb display....one change can have many effects be careful mod-ing out there....

muziqneeds

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
[BUGFIX] Votes & comment are not visible in displayimage
« Reply #3 on: December 06, 2003, 05:29:07 am »

Thanks For helping me.

but tell me where is this file, in which file i replace the code

thanks
Logged

gtroll

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 618
    • CPG-Nuke
[BUGFIX] Votes & comment are not visible in displayimage
« Reply #4 on: December 06, 2003, 05:38:36 am »

line 543 modules/coppermine/displayimage.php
The only difference if you notice is the comment /* is moved and a } is added above I provided the example find and replace for your reference...and added the file and line# though editing...

eengvig

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
[BUGFIX] Votes & comment are not visible in displayimage
« Reply #5 on: December 06, 2003, 03:19:50 pm »

I have a kind of similar error. After having updated cpg1.1d to cpg1.2.1nuke i cant post comments. The comments that was added in the 1.1d album is still there, but i cant post new ones.
Logged

muziqneeds

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
[BUGFIX] Votes & comment are not visible in displayimage
« Reply #6 on: December 06, 2003, 05:59:00 pm »

Thanks its working
Logged

Celinefan

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
[BUGFIX] Votes & comment are not visible in displayimage
« Reply #7 on: December 07, 2003, 11:21:50 am »

Quote from: "eengvig"
I have a kind of similar error. After having updated cpg1.1d to cpg1.2.1nuke i cant post comments. The comments that was added in the 1.1d album is still there, but i cant post new ones.


I have the same too! I CAN see comments now, but it's not possible to place comments and give votes, is there a fix for it? Thnx in advance!
Logged

gtroll

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 618
    • CPG-Nuke
[BUGFIX] Votes & comment are not visible in displayimage
« Reply #8 on: December 07, 2003, 11:27:40 am »

album properties and config?

Celinefan

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
[BUGFIX] Votes & comment are not visible in displayimage
« Reply #9 on: December 07, 2003, 11:34:31 am »

Quote from: "gtroll"
album properties and config?


I've checked that already, but that seems to be OK :-)

This is my DEBUG info:

Code: [Select]
Debug info Integretion vars
Selected Nuke Theme: Xmas2
Nuke Version: 7.0
Module path modules/coppermine
Nukelink modules.php?name=coppermine
Coppermine Theme: default
$_SERVER vars
DOCUMENT_ROOT: /home/httpd/vhosts/blaat.us/httpdocs
HTTP_ACCEPT_LANGUAGE: nl
HTTP_USER_AGENT: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
SCRIPT_FILENAME: /home/httpd/vhosts/blaat.us/httpdocs/modules.php
 
QUERY_STRING: name=coppermine
PHP_SELF: /modules.php
CPG Config
TABLE_PICTURES cpg_pictures
TABLE_ALBUMS cpg_albums
TABLE_COMMENTS cpg_comments
TABLE_CATEGORIES cpg_categories
TABLE_CONFIG cpg_config
TABLE_USERGROUPS cpg_usergroups
TABLE_VOTES cpg_votes
TABLE_USERS nuke_users
allow_private_albums 0
Site url (ecards_more_pic_target) http://www.blaat.us/
fullpath modules/coppermine/albums/
ALBUM_SET  
FORBIDDEN_SET  
Language Directory modules/coppermine
Queries
GET Array
(
    [name] => coppermine
)

 
POST Array
(
)

 
Page generated in 1.131 seconds - 47 queries in 0.19 seconds - Album set :  
 
   

   
 Advanced debug mode PHP version: 4.3.3


mySQL version: 3.23.56

--------------------------------------------------------------------------------

Image Lib(s)
gd
GD Support  enabled  
GD Version  bundled (2.0.15 compatible)  
FreeType Support  enabled  
FreeType Linkage  with freetype  
GIF Read Support  enabled  
JPG Support  enabled  
PNG Support  enabled  
WBMP Support  enabled  
XBM Support  enabled  
 
Server restrictions (safe mode)?
Directive Local Value Master Value
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
safe_mode_exec_dir no value no value
sql.safe_mode Off Off
disable_functions no value no value
file_uploads On On
include_path .:/php/includes:/usr/share/php .:/php/includes:/usr/share/php
open_basedir /home/httpd/vhosts/blaat.us/httpdocs:/tmp no value

email
Directive Local Value Master Value
sendmail_from me@localhost.com me@localhost.com
sendmail_path /usr/sbin/sendmail -t -i  /usr/sbin/sendmail -t -i  
SMTP localhost localhost
smtp_port 25 25

Size and Time
Directive Local Value Master Value
max_execution_time 6000 6000
max_input_time -1 -1
upload_max_filesize 100M 100M
post_max_size 80M 80M


Maybe you can see an error there? 8)
Logged

laprank

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
stuff
« Reply #10 on: December 14, 2003, 08:27:55 am »

I have the same probleme everything works perfectly i've set up all the configs to what they should be and yet the ranking and the comments do not show up.....

I have installed cpgnuke1.2.1 from scrath (twice) and yet no difference i've also edited to code like you said to do earlier on but with no effect...

I would greatly appreciated it if you could releast a fix to this probleme as this option is what my whole site depends on.

Thanks in Advance,
LaPrank Webmaster
Logged
Making the world better since 1969

laprank

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
arg
« Reply #12 on: December 14, 2003, 10:54:48 pm »

maybe its just me but your site only has blocks i cannot see any modules and the link you gave doesn't seem to work  :?
Logged
Making the world better since 1969

laprank

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
works
« Reply #13 on: December 15, 2003, 08:03:08 pm »

Scrath that last post the fixed work......... Thanks Alot

I suggest that you put it in the releast because this is a quite important to many people and well i think they would apreciate it :D

Smell you later
Logged
Making the world better since 1969
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 18 queries.