Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: bad config of broken theme  (Read 4520 times)

0 Members and 1 Guest are viewing this topic.

cflann01

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
bad config of broken theme
« on: September 21, 2005, 09:27:23 am »

I f'd up.

I accidentally tried to configure coppermine to use a template (reynolds) that had only partially uploaded.
"Warning: main(themes/reynolds.1/theme.php): failed to open stream: No such file or directory in /hsphere/local/home/chrisfla/coppermine.chrisflannery.com/include/init.inc.php on line 338

Fatal error: main(): Failed opening required 'themes/reynolds.1/theme.php' (include_path='.:/usr/local/lib/php') in /hsphere/local/home/chrisfla/coppermine.chrisflannery.com/include/init.inc.php on line 338"

my site: http://coppermine.chrisflannery.com/

Is there anyway to backout of this without reinstalling everything?

If not will it be difficult to keep teh albums and have a new install of coppermine grab them?

Thanks for any help,
Chris

PS Reynolds.1 is the theme folder (its not just a goof)
« Last Edit: September 21, 2005, 05:28:33 pm by GauGau »
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: bad config of broken theme
« Reply #1 on: September 21, 2005, 09:42:55 am »

if you still have classic theme installed then just
domain/coppermine path/index.php?theme=classic

then either delete or fix reynolds theme

deleting the cookie works too

artistsinhawaii

  • VIP
  • Coppermine addict
  • ***
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 856
    • evj art and photography
Re: bad config of broken theme
« Reply #2 on: September 21, 2005, 09:45:45 am »

cflann01,

I believe you simply need to copy a fresh copy of the reynolds theme over the existing reynolds folder replacing all files within it.

You can also get to your site entering  http://coppermine.chrisflannery.com/index.php?theme=classic.  Reset your default theme.

Then proceed as usual.  But DO replace the reynolds theme.

Dennis
Logged
Learn and live ... In January of 2011, after a botched stent attempt, the doctors told me I needed a multiple bypass surgery or I could die.  I told them I needed new doctors.

cflann01

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
Re: bad config of broken theme
« Reply #3 on: September 21, 2005, 09:59:35 am »

thank you Both, i'm almost there.

i entered though: /index.php?theme=classic
and tried to configure to a theme which had work previously
theme didnt take hold stayed as classic, and when i tried to enter my galleries from the default directory i got the same errors as before

so i cleared cookies.

now i am able to get to the albums from the default directory (http://coppermine.chrisflannery.com) - however no theme changes will take hold just stays classic

thanks again,
chris
Logged

cflann01

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
Re: bad config of broken theme
« Reply #4 on: September 21, 2005, 10:03:19 am »

nevermind it works! just needed to clear cookies again.

thanks for your help! much appreciated
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 19 queries.