Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: upload.php - Line: 963  (Read 6682 times)

0 Members and 1 Guest are viewing this topic.

Liquid_N2

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
upload.php - Line: 963
« on: August 28, 2005, 01:32:59 pm »

Hi all,

Had an issue appear when I performed an upgrade the gallery stopped allowing uploads, the plain text error was Invalid action for form creation. I upgraded both the gallery from 1.3.2 to 1.3.3 and the vbullletin forum from 3.0.4 to 3.0.8 so im not sure which one broke it.

We have just moved hosts and I have reinstalled everything and now I have the exact same error appearing, I am running coppermine 1.3.4 and vbulletin 3.0.8 now

Here are the site details:
Quote
Forum URL: http://www.hopelessheroes.co.uk
Gallery URL: http://www.hopelessheroes.co.uk/gallery
Test Account: testuser
Password: password

The databases are seperate but this is how it has always been and working fine until the recent upgrade.

I am using a bridge file called vbulletin3gamma.inc from my last install as the normal vb one doesnt seem to work correctly.

Code: [Select]
**********************************************/
// ------------------------------------------------------------------------- //
// vBulletin 3.0 Integration for Coppermine
// ------------------------------------------------------------------------- //

// ------------------------------------------------------------------------- //
// Modify the values below according to your Board installation
// ------------------------------------------------------------------------- //
// database configuration
define('VB_CUST_NO', '******'); // Your vBulletin license number (NOT your customer number)
define('VB_DB_NAME', '*******'); // The name of the database used by the board
define('VB_BD_HOST', '*****'); // The name of the database server
define('VB_DB_USERNAME', '****'); // The username to use to connect to the database
define('VB_DB_PASSWORD', '******'); // The password to use to connect to the database

// The web path to your vBulletin Board directory
// In this example http://yoursite_name.com/vbulletin3/
define('VB_WEB_PATH', '/forum/');
// ------------------------------------------------------------------------- //
// Nothing to edit below this line
// ------------------------------------------------------------------------- //
// Prefix and names for the database tables
define('VB_TABLE_PREFIX', ''); // Leave empty, not supported by vBulletin 2.3
define('VB_USER_TABLE', 'user'); // The members table
define('VB_SESSION_TABLE', 'session'); // The sessions table
define('VB_GROUP_TABLE', 'usergroup'); // The groups table

The gallery works fine from an authenticating user standpoint, I can batch upload images fine, I can do everything except when it comes to the upload file section where it gives the following debug information:

Quote
Error
Invalid action for form creation.

File: /hsphere/local/home/mostonni/hopelessheroes.co.uk/gallery/upload.php - Line: 963

now line 963 is         

Code: [Select]
array($lang_upload_php['picture'], 'userpicture', 1, 1),

CHMOD on userpics is 777 and everything seems to be setup ok but im just lost as to what the issue could be, i am using a legal vbulletin licence.

The debug information is as follows:

Code: [Select]
USER:
------------------
Array
(
    [ID] => fac2797d0be6080c65ec4f02bcb3bea2
    [am] => 1
)

==========================
USER DATA:
------------------
Array
(
    [0] => 1
    [user_id] => 1
    [1] => [HH] Lickeh
    [user_name] => [HH] Lickeh
    [2] => 6
    [mgroup] => 6
    [3] => *********************
    [password] => ***********************
    [4] => 6
    [group_id] => 6
    [5] => Administrators
    [group_name] => Administrators
    [6] => 0
    [group_quota] => 0
    [7] => 0
    [has_admin_access] => 0
    [8] => 1
    [can_rate_pictures] => 1
    [9] => 1
    [can_send_ecards] => 1
    [10] => 1
    [can_post_comments] => 1
    [11] => 1
    [can_upload_pictures] => 1
    [12] => 0
    [can_create_albums] => 0
    [13] => 0
    [pub_upl_need_approval] => 0
    [14] => 0
    [priv_upl_need_approval] => 0
    [15] => 3
    [upload_form_config] => 3
    [16] => 1
    [custom_user_upload] => 1
    [17] => 10
    [num_file_upload] => 10
    [18] => 10
    [num_URI_upload] => 10
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content FROM cpg134_filetypes;
    [1] => SELECT userid as user_id, username as user_name, usergroupid as mgroup, password FROM `mostonn_forum`.user WHERE userid='1'
    [2] => SELECT * FROM cpg134_usergroups WHERE group_id = '6'
    [3] => DELETE FROM cpg134_banned WHERE expiry < '2005-08-28 06:31:22'
    [4] => SELECT * FROM cpg134_banned WHERE ip_addr='82.34.16.7' OR ip_addr='82.34.16.7' OR user_id=1
    [5] => SELECT aid, title FROM cpg134_albums WHERE category < 10000 ORDER BY title
    [6] => SELECT aid, title FROM cpg134_albums WHERE category='10001' ORDER BY title
    [7] => DELETE FROM cpg134_temp_data WHERE timestamp < 1125225082
)

==========================
GET :
------------------
Array
(
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 4.3.11 - OK
------------------
mySQL version: 4.0.24-standard-log
------------------
Coppermine version: 1.3.4
==========================
Module: gd
------------------
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled
==========================
Module: mysql
------------------
Active Persistent Links 0
Active Links 2
Client API version 4.0.16
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.1.4
Linked Version 1.1.4
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/usr/local/lib/php | .:/usr/local/lib/php
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | me@localhost.com | me@localhost.com
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | -1 | -1
upload_max_filesize | 2M | 2M
post_max_size | 8M | 8M
==========================
Page generated in 0.055 seconds - 8 queries in 0.006 seconds - Album set :

Any help is greatly appreciated.

Many thanks
« Last Edit: September 01, 2005, 12:10:20 am by Liquid_N2 »
Logged

Nibbler

  • Guest
Re: upload.php - Line: 963
« Reply #1 on: August 29, 2005, 01:10:17 am »

Hi,

The constant 'USER_UPLOAD_FORM' is supposed to be defined in the bridge file. This determines what upload options are shown to the user. The vb3gamma bridge file appears to be missing the code to define this setting. You can try adding this code into the end of the udb_authenticate() function.

Code: [Select]
define('USER_UPLOAD_FORM', (int)$USER_DATA['upload_form_config']);
It seems to be missing a few more defines in addition to this. I can't advise any definite solution as I don't have a vb forum.
Logged

Liquid_N2

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: upload.php - Line: 963
« Reply #2 on: August 29, 2005, 06:31:37 pm »

Thank you for your reply.

I tried adding the line in and the gallery wouldnt even load.

What I dont understand is what has changed from 1.3.2/vb 3.0.5-3.0.8 that would affect this. I just tried doing a new install with the gallery dbase inside the same dbase as the forum which has not made any difference.

Is there anything else I could try?
Logged

Liquid_N2

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: upload.php - Line: 963
« Reply #3 on: September 03, 2005, 01:23:20 am »

I have managed to fix this issue after I made some modifications to the bridge file.

If you are having the same issue as me, then here is the modified version of my vbulletin3gamma file

vbulletin3gamma.inc :  5.23 KB
« Last Edit: September 03, 2005, 01:59:42 pm by Liquid_N2 »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: upload.php - Line: 963
« Reply #4 on: September 03, 2005, 11:38:44 am »

the link you posted is down for me. Try attaching your bridge file to your posting using the "Additional Options..." link at the bottom of the screen when composing your message.
Logged

Liquid_N2

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: upload.php - Line: 963
« Reply #5 on: September 03, 2005, 01:59:16 pm »

Sorry missed the extension, have modifed link and also attached below.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 19 queries.