Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: XP_Publish not logged in with bridge active  (Read 3626 times)

0 Members and 1 Guest are viewing this topic.

phatbloke

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
XP_Publish not logged in with bridge active
« on: August 07, 2005, 04:47:15 am »

Hi
I managed to get the xp_publish going with the fixes in the topic  below

http://forum.coppermine-gallery.net/index.php?topic=15227.20

Unfortunatly when my xoops bridge is active i cannot use it, say's not logged in please use "remember me" option etc
Does anyone else have this bug when a bridge is active?

I am using IE to log in to the site before trying to publish as well. When i disable the bridge and use xp_publish it actually asks for a login and continues on ok. This is fine but I would like to be able to keep the bridge active and just be asked for a login when publishing.

Cheers
If any more info is needed please let me know
« Last Edit: September 06, 2005, 11:25:59 am by GauGau »
Logged

the_todd

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Posts: 42
    • JoomBla!
Re: XP_Publish not logged in with bridge active
« Reply #1 on: August 07, 2005, 08:38:52 pm »

Please Read in that same topic you linked to:
Quote
"omniscientdeveloper"
Just a note for everyone:

If you have a particular bridge file that you want xp_publish to work with, you have to create a login method for it. See the coppermine bridge file for an example. I'm going to do the Mambo bridge file, so those two will/should work with xp_publish.
You will have to write your own integration script. This is not a bug but a missing feature. xp_publish is currently not combatible stock with bridge files. An example would be with my script with Invision Board I used the bridge functions that are already available to read the correct cookie information, or if that fails display a login screen. What you need to do this is like omniscientdeveloper said. Its right in front of you.

~Todd

note: maybe sometime in the next month or so when I get time I will modify the script to check for logins generically and post in the hacks/mods section.

note2: @phatbloke - I just saw how much support you were asking for in the other post, please note that the bridge is not a bug, as you probably already know, and please quite asking for support within the bugs reporting forum. Please wait for the release of 1.4 before starting posts asking for support.
« Last Edit: August 07, 2005, 08:49:41 pm by the_todd »
Logged

phatbloke

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: XP_Publish not logged in with bridge active
« Reply #2 on: August 07, 2005, 09:49:41 pm »

Thanks

I didn't realise it was a missing feature. I have a reasonable amount of php knowledge so will try to integrate login support for xoops and see how i go.

It can often be a fine line between asking for support and reporting bugs etc. I'm not expecting support generally just trying to help out the cause and contribute where i can.

Hopefully i can sus out this bridge conflict and help out.

:)
Logged

Nibbler

  • Guest
Re: XP_Publish not logged in with bridge active
« Reply #3 on: August 07, 2005, 11:05:10 pm »

Commited a login method into udb_base.php (1.12) that should support bridge login for anything that uses md5(password) in the database. Any other bbs will need to override the method in their own bridge file.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.