Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Invalid argument supplied for foreach() in ORC4  (Read 3414 times)

0 Members and 1 Guest are viewing this topic.

gobracer

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Invalid argument supplied for foreach() in ORC4
« on: November 30, 2003, 02:01:02 am »

Commented out all the ob_end_flush uploaded some pictures and now I am getting this error message:  
Quote
Warning: Invalid argument supplied for foreach() in /home/virtual/site25/fst/var/www/html/modules/coppermine/config.php on line 257


Debug info Integretion vars
Selected Nuke Theme: Xmas2
Nuke Version: 6.9
Module path modules/coppermine
Nukelink modules.php?name=coppermine
Coppermine Theme: default
$_SERVER vars
DOCUMENT_ROOT: /home/virtual/site25/fst/var/www/html
HTTP_ACCEPT_LANGUAGE: en-us
HTTP_USER_AGENT: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
SCRIPT_FILENAME: /home/virtual/site25/fst/var/www/html/modules.php
PHP_SELF: /modules.php
CPG Config
TABLE_PICTURES cpg_pictures
TABLE_ALBUMS cpg_albums
TABLE_COMMENTS cpg_comments
TABLE_CATEGORIES cpg_categories
TABLE_CONFIG cpg_config
TABLE_USERGROUPS cpg_usergroups
TABLE_VOTES cpg_votes
TABLE_USERS nuke_users
allow_private_albums 0
Site url (ecards_more_pic_target) http://www.isalenes.com/
fullpath modules/coppermine/albums/
ALBUM_SET  
FORBIDDEN_SET  
Queries
GET Array
(
    [name] => coppermine
    [file] => config
)

 
POST Array
(
)

 
Page generated in 0.03 seconds - 1 queries in 0.001 seconds - Album set :
Logged

gobracer

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Config.php Error
« Reply #1 on: November 30, 2003, 06:09:01 pm »

After un-install and re-install it seems that when I activate blocks,  that is what creates the error.  I can deactivate the blocks and coppermine works.  I can upload pictures, etc.  Not sure what is causing this, will need to investigate further.
Logged

DJMaze

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 831
    • Dragonfly CMS
Invalid argument supplied for foreach() in ORC4
« Reply #2 on: November 30, 2003, 06:30:09 pm »

Could you tell by using which block you get the error ?

Notice: Only the CPG- blocks work
Logged
There are 2 kinds of users in this world: satisfied and complainers.
Why do we never hear something from the satisfied users?
http://coppermine-gallery.net/forum/index.php?topic=24315.0

gobracer

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
CPG Blocks
« Reply #3 on: November 30, 2003, 07:15:26 pm »

I deactivated all the blocks and then started adding them one by one.  Added three in the center and three on the right side, everything worked fine after adding each block.  The error occurs when I added a block to the left side.  I changed it to the right side and everything worked.  Tried a different block on the left side and got the same error, switched it back to the right side and everything fine again.  I am only using the CPG blocks that came with RC4
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 18 queries.