Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Pictures are showing as .jpg icons and not as pictures  (Read 4820 times)

0 Members and 1 Guest are viewing this topic.

Terboggs

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
    • Susan G's Gallery
Pictures are showing as .jpg icons and not as pictures
« on: July 21, 2005, 10:07:36 pm »

I did three searches in the Support forums trying to find another example of this problem. This version (1.3.3) is newly loaded and the uploading of the pictures went great using Microsoft's Web Publisher. The link is http://pcresurrection.com/.
A test account has been setup. I am using the XP opperating system. I checked using two different browers with the same result on both.

Thanks in advance for your help  :)

Terrence Boggs
« Last Edit: July 22, 2005, 07:23:13 am by GauGau »
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #1 on: July 21, 2005, 11:53:00 pm »

First thing - there are a lot of HTML errors on your site.  For example,

Code: [Select]
<table width="90%" cellspacing="0" cellpadding="0" border="0" align="center">
<td>

Tables are constructed like this:

Code: [Select]
<table><tr><td></td></tr></table>
You should validate your site's HTML and CSS.

Second thing - don't put spaces in your filenames.  This is most likely causing your problems.  I don't see any icons, just broken images.

Third thing - if you created a test account, you should post the username/password.

I also recommend reading the documentation, if you haven't done so yet.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Nibbler

  • Guest
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #2 on: July 21, 2005, 11:58:25 pm »

Looks like you have hotlink protection enabled on your site which is not properly configured. Either review the settings or disable it.
Logged

Terboggs

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
    • Susan G's Gallery
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #3 on: July 22, 2005, 12:49:40 am »

User name is test.
Password is test
 I didn't upload the hotlink protection. The onlything I did was to upload the site and post three pictures.


I didn't eneble hotlink protection. I just uploaded the site and posted three pictures, nothing else.
How do I  validate my site's HTML and CSS. My tables were constructed by my site, not me, so I'm not sure how the HTML errors got there.
Test is the log on
Test is the password.

Thanks for your reply,
Terrence










« Last Edit: July 22, 2005, 05:21:18 am by GauGau »
Logged

Terboggs

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
    • Susan G's Gallery
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #4 on: July 22, 2005, 01:27:47 am »

How could the HTML code be off. Its has not been changed from the orignial program. I loaded one more picture with a one word title, no spaces. It still doesn't show the picture. I wish I knew what too do. As I mentioned I didn't construct any tables, the program constructed them.
Terrence
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #5 on: July 22, 2005, 02:07:36 am »

When you say "the program constructed them", what program are you talking about?  Microsoft Web Publisher?  That would explain the incorrect html coding, because those programs do a very bad job of writing code.

Here's what I recommend.  Download a fresh zip of 1.3.3 from our site.  Upload all of the files to your website with a real FTP client, not anything made by Microsoft (you can download evaluation versions of any FTP client, like TurboFTP or WS_FTP or Voyager FTP.)  Don't edit any of the files before uploading them.

Check your website's control panel and make sure you don't have any hotlink prevention enabled.  Make sure there are no .htaccess files in your album directory.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Terboggs

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
    • Susan G's Gallery
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #6 on: July 22, 2005, 03:02:03 am »

Thank you very much for replying Kegobeer. I just did everthing that you suggested. I'm using the classic interface. No changes made to the program in any manner. I loaded a picture using XP Web Publishing Wizard in the manner recommend by the documentation using a one word label for the picture. There is still a problem. Logon is test, password is test.

Thanks for your all your help, but I'm at a loss.

Terrence
Logged

Terboggs

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
    • Susan G's Gallery
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #7 on: July 22, 2005, 03:10:59 am »

Can somebody take alook at this site and see if a setting is wrong? I've on made a couple of changes in the configeration pannel.

Thanks,

Terrence
Logged

Nibbler

  • Guest
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #8 on: July 22, 2005, 03:13:15 am »

Sorry for repeating myself, but the problem is your hotlink protection. Disable that and you'll be fine.
Logged

Terboggs

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
    • Susan G's Gallery
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #9 on: July 22, 2005, 03:34:36 am »

I hate to repeating myself, but this is a new copy of this program. There is no code for hotlinking in the album folder that I downloaded an hour ago. Unless your including it in 1.3.3 and I don't know it. I have opened my FTP program and checked three times. If it is included in the stable version, how do I disable it? I would love too. But looking at my site and saying its the hotlink when it is a fresh program puzzles me.

Terrence
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #10 on: July 22, 2005, 03:51:18 am »

I don't think you understand hotlink protection.  It doesn't come with Coppermine, it's a setting you can enable from your website's control panel application.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Terboggs

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
    • Susan G's Gallery
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #11 on: July 22, 2005, 04:04:53 am »

Your right, I don't. Do you mean my website hosting control panel? I wrote them an e-mail asking how to disable it.

Again. thank you for all your help.
 I keep hoping that I learn enough about getting this corrected before you guys quit answering my E-mail for help. I'm still puzzeled as to how it was turned on. When I go to my website I cannot view the image: pcresurrection.com. When I right click on the properties and put the URL shown for the picture, the picture is show. But I don't have a .hta file in my albums folder. How do I disable hotlink if the file is not there?

Terrence
Logged

Nibbler

  • Guest
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #12 on: July 22, 2005, 04:10:29 am »

The .htaccess file doesn't need to be directly in the albums folder, it can be anywhere in the directory tree above the pic to be protected, maybe even above where you have access to.
Logged

Terboggs

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 32
    • Susan G's Gallery
Re: Pictures are showing as .jpg icons and not as pictures
« Reply #13 on: July 22, 2005, 06:09:00 am »

Problem solved. Thank you very much for your help. I learned alot.

Terrence
Logged
Pages: [1]   Go Up
 

Page created in 0.025 seconds with 20 queries.