Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: small documentation bug?  (Read 3049 times)

0 Members and 1 Guest are viewing this topic.

veeber77

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
small documentation bug?
« on: July 19, 2005, 04:12:43 pm »

I just upgraded from 1.3.3 to 1.4.1 beta.  I ran the upgrade as written in the documentation.  Seems to work fine.  When I view the version check it gives an error for two missing index.php files within the albums directory. 
   albums/index.php   and albums/userpics/index.php   

The instructions said not to upload the albums directory.  There was an index.html in each directory from the 1.3.3.  I'm not sure if this really matters, but it does show up bright read in versioncheck.  I just copied in the corresponding index.php to get rid of the error. 
« Last Edit: August 01, 2005, 08:02:31 am by GauGau »
Logged

OmegaGOD

  • Supporter
  • Coppermine frequent poster
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 346
  • I approve.
Re: small documentation bug?
« Reply #1 on: July 19, 2005, 06:25:30 pm »

Thanks for reporting this.  The index.html file located at ./albums/ and ./albums/userpics/ for CPG 1.3.x have been replaced with index.php located under the same corresponding directories for CPG 1.4.x.

The reason the documentation stresses not to upload the albums directory is that with some FTP clients, will actually replace the albums directory which means that your photos will be overwritten with an 'empty' ./albums directory. You can manually place the two index.php files on your webserver; however, those two files do not effect the functionality of CPG.

@GauGau: maybe we should address that in the documentation? If not in the beta version then we should address that in the stable release.
« Last Edit: July 19, 2005, 06:43:01 pm by OmegaGOD »
Logged
Please do not PM me with support questions. Please read the manual and then if posting questions please place them in the proper sub-boards.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: small documentation bug?
« Reply #2 on: July 20, 2005, 07:09:17 am »

I'll just address this in versioncheck.php - marking them as "optional" instead of "mandatory" - this should do the trick. Fix committed.
« Last Edit: August 01, 2005, 08:02:53 am by GauGau »
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 19 queries.