Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Critical Error when deleting album or pictures within album  (Read 2240 times)

0 Members and 1 Guest are viewing this topic.

tcman

  • Coppermine newbie
  • Offline Offline
  • Posts: 10

Hi,

I'm trying to delete an album and it is giving me "Critical Error....Directory 'albums/2005_0402_my_retirement/' is not writable, files can't be deleted".  I made sure the chmod is 777 on this folder for everything, but still getting error.  Also getting same error when trying to delete some pictures in same album that are not displaying. Instead of displaying picture, just the filename displays.   I am able to delete pictures that display correctly in this album.  Other albums seem to be fine.  Any ideas on how to correct this problem?

Thank you in advance,
tcman
« Last Edit: July 15, 2005, 07:41:52 am by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Critical Error when deleting album or pictures within album
« Reply #1 on: July 14, 2005, 11:00:08 am »

you mustn't delete files that exist in your coppermine database by FTP, but you should use the controls built into coppermine. Restore the pics as they were, then use coppermine's user interface to delete them, as only this method will remove both the files and the db entry. This has been asked before, for details, search the forum.
Another possible reason is your server setup: you might need other permissions than 777. Try 755 for example.
Logged

tcman

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Critical Error when deleting album or pictures within album
« Reply #2 on: July 15, 2005, 05:19:10 am »

Yes, I deleted the files using ftp.  Anyway, I went into mysql and deleted the album and the pictures manually and now everything is ok.
Thanks for the advice.

tcman
Logged
Pages: [1]   Go Up
 

Page created in 0.013 seconds with 19 queries.