Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Xoops bridging error & fix  (Read 7391 times)

0 Members and 1 Guest are viewing this topic.

Knyte

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Xoops bridging error & fix
« on: July 11, 2005, 06:51:19 am »

Hi, great work on 1.4, so far I like it a lot!  I've been waiting for better integration ("bridging") with Xoops for awhile...looks like you're on the right track - it's looking really good.

OK so I followed all the installation instructions, etc.  I already had a working Xoops site.  So I copied the CP dir to the Xoops dir structure, which is in the root of my webserver (IIS 5).  So the root document then is index.php for Xoops, and CP is in a folder called gallery.  Anyway, carrying on with the CP bridging instructions, all went well, I logged in to CP standalone, uploaded a couple of files, and they displayed OK and everything worked.

Then I ran the bridging wizard, and all was OK - until I clicked that last confirmation button.  Then I got an error - unfortunatly I didn't think to record it - however the error indicated the file xoops.inc.php in the /gallery/bridge folder.  Opening xoops.inc.php with NoteTab Lite, I found an error on line 28 which reads "require_once('../xoops/mainfile.php');" - I edited this to read "require_once('../mainfile.php');" (removed the "/xoops") and it worked.  Since my "mainfile.php" is in the root dir, and NOT in a folder /xoops/, this of course stands to reason.

Hope that helps someone!

Looking forward to more,

-Knyte
« Last Edit: July 31, 2005, 03:36:40 pm by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Xoops bridging error & fix
« Reply #1 on: July 11, 2005, 07:17:57 am »

confirming this bug, there's a hardcoded path in the bridge file.
Logged

phatbloke

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Xoops bridging error & fix
« Reply #2 on: July 11, 2005, 09:52:24 am »

I managed also to get coppermine going although i cannot get my admin account in xoops to be recognised as admin on coppermine so that i can sync the groups etc. Anyone have any ideas?

*EDIT*

do not use " Use post-based groups?:" as this was stopping me login as admin once setup.

If anyone figures out how to add the full xoops header and menu it would be most appreciated otherwise i will keep fudging my way through it tomorrow
« Last Edit: July 11, 2005, 12:54:07 pm by phatbloke »
Logged

Nibbler

  • Guest
Re: Xoops bridging error & fix
« Reply #3 on: July 11, 2005, 02:16:14 pm »

Code: [Select]
define('USE_BRIDGEMGR', 0);
That should be on by default

Code: [Select]
define('USE_BRIDGEMGR', 1);
That way it will use the path you specify in config. The require_once('../xoops/mainfile.php'); is there for if you want to overide the bridge manager's settings.

Change committed.
Logged

Knyte

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Xoops bridging error & fix
« Reply #4 on: July 11, 2005, 09:17:15 pm »

Kewl - thanks :)
Logged

thkiat

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Xoops bridging error & fix
« Reply #5 on: July 31, 2005, 08:03:32 pm »

Bridge Wizard: path(s) used by your BBS app:-
Forum URL:
Relative path to your BBS's config file:

My mainfile.php is at root directory of www.usm.net.my and CPG is installed at www.usm.net.my/photogallery.
What should I enter for the above?

I entered as below:
Forum URL: http://www.usm.net.my
Relative path to your BBS's config file: ../

 I ended up with this erro message: Parse error: parse error, unexpected '&', expecting T_VARIABLE or '$' in /home/httpd/vhosts/usm.net.my/httpdocs/photogallery/bridge/xoops.inc.php on line 104

I did change line 28, i.e.: require_once('../xoops/mainfile.php'); to require_once('../mainfile.php');

Please help.

Logged

Nibbler

  • Guest
Re: Xoops bridging error & fix
« Reply #6 on: July 31, 2005, 09:06:28 pm »

Locking this thread to prevent it being further hijacked to post duplicate bug reports and support questions.
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 19 queries.