Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: "Fatal error" upgrading to cpg 1.4  (Read 11758 times)

0 Members and 1 Guest are viewing this topic.

reallove

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 18
    • Personal photo gallery
"Fatal error" upgrading to cpg 1.4
« on: July 06, 2005, 10:00:28 am »

Hello,
My first coppermine install was the 1.3.2 version.I've made succesfuly the upgrade to 1.3.3 when this latest version was released.After a while,I moved the entire gallery to another server,more powerfull. (saved the mysql schema,archived the entire public_html and move them all to the new server).I had no problems,the gallery was running ok.
The problems occured when I wanted to upgrade to 1.4 beta from the new server.After running update.php,it displayed correctly the changes but when clicked to proceed to the gallery main page .. fatal error .I tried then to upgrade to my old server hosting,there I haven't deleted anything.And surprise,all was ok,upgrade was succesfuly.
To see what's the error go to http://reallove.sunbx.net . The 'downgrade' works fine,from this 'fatal error' 1.4 back to 1.3.3.
The server details (the new one who caused trouble) are :
linux 2.6.11.12
httpd -v output : Server version: SBXWS/3.1b (Unix)
PHP 5.0.4 (cli) (built: Apr  6 2005 01:05:54)
I use GD 2 ,ImageMagick is not installed.

If you need any details just let me know.
Thanks!
« Last Edit: July 06, 2005, 06:38:50 pm by GauGau »
Logged
Dan/reallove

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Fatal error" upgrading to cpg 1.4
« Reply #1 on: July 06, 2005, 10:02:24 am »

enable debug_mode to see what query actually fails when getting the fatal error.
Logged

reallove

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 18
    • Personal photo gallery
Re: "Fatal error" upgrading to cpg 1.4
« Reply #2 on: July 06, 2005, 10:11:24 am »

Ok,it's enabled.Seems an error from mysql ? :-o
Logged
Dan/reallove

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Fatal error" upgrading to cpg 1.4
« Reply #3 on: July 06, 2005, 10:50:48 am »

it appears that your mySQL user doesn't have the privileges needed to perform the upgrade (ALTER TABLE). Use a tool like phpMyAdmin to check if the column "player" actually exists in the table "cpg132_filetypes". Try running there the query
Code: [Select]
ALTER TABLE `cpg132_filetypes` ADD `player` VARCHAR( 5 ) ;there to see if there is an error message. Modify the permissions of the mySQL user if yes.
Logged

reallove

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 18
    • Personal photo gallery
Re: "Fatal error" upgrading to cpg 1.4
« Reply #4 on: July 06, 2005, 02:32:05 pm »

Ok,fixed after talking to the admin and changed my mysql user permissions.
Thanks for the tips !
Logged
Dan/reallove

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Fatal error" upgrading to cpg 1.4
« Reply #5 on: July 06, 2005, 06:35:57 pm »

OK, glad this has been fixed. As it wasn't actually a coppermine bug that kept the upgrade from working, but an improper webserver setup, I'm marking this thread as "invalid".

Joachim
Logged

newyorkrunaway

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: "Fatal error" upgrading to cpg 1.4
« Reply #6 on: July 08, 2005, 05:52:17 am »

enable debug_mode to see what query actually fails when getting the fatal error.

How do i actually enable debug_mode if i cant even load the gallery?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Fatal error" upgrading to cpg 1.4
« Reply #7 on: July 08, 2005, 06:01:58 am »

no need to enable debug mode for you, as you already know what query fails (see your posting on the other thread). Just check the permissions of your mySQL user as suggested in this thread (that's why I refered to it). However, if you want to enable debug mode first, use a tool like phpMyAdmin to directly edit your database, browse coppermine's config table and set debug mode from 0 to 1 there. This has been explained very often already, please search before posting, especially if you're looking for help for an unsupported version, we expect testers of new versions to have above average skills - this includes being able to use the search button.
Logged

newyorkrunaway

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: "Fatal error" upgrading to cpg 1.4
« Reply #8 on: July 08, 2005, 06:06:01 am »

WOW!!!! your so helpfull, but i guess thats what your here for!!!!! I love you GAUGAU!!!!!!  ;) ;)

 ::)


anyways....
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Fatal error" upgrading to cpg 1.4
« Reply #9 on: July 08, 2005, 07:36:09 am »

no need for your sarcasm. I did explain how to enable debug mode "manuall", and I told you what to do to fix your issues. Instead of your above posting, you could have told us what exactly you didn't understand from my explanation and the rest of this thread. We could then look into this particular issue. Just posting "I don't understand" is not very helpfull. I strongly suggest, however, that you don't upgrade to cpg1.4.x, but keep your current cpg1.3.x install - using beta software needs a certain skill level and you have to be ready to put an additional effort into it. That's why it's labelled "beta software" and comes without support - we (the dev team) simply don't have the time to walk newbies through setting up a software package that is a bit harder to set up than the stable one.
Logged

newyorkrunaway

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: "Fatal error" upgrading to cpg 1.4
« Reply #10 on: July 08, 2005, 08:34:15 am »

you dont have to worry about it anymore, i fixed it, go check it out, all i have to do is upload my pics now!!! http://photos.tournashville.net

have a GREAT day gaugau!!!!!!  :-*
Logged

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
Re: "Fatal error" upgrading to cpg 1.4
« Reply #11 on: July 08, 2005, 08:40:04 am »

Hmmm so what was wrong?
Logged
SANIsoft PHP applications for E Biz

newyorkrunaway

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: "Fatal error" upgrading to cpg 1.4
« Reply #12 on: July 09, 2005, 05:55:23 am »

it had nothing to do with the sql settings, it only had to do with an improperly named file in the /include/makers file called .ds_store.

frontpage 2003 will not allow any files that are not named, and in that case, windows recognizes it as an extension only because of the "." in front of it. so, all i had to do was upload it with another program, and it was fine.

that fixed this problem!

Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: "Fatal error" upgrading to cpg 1.4
« Reply #13 on: July 09, 2005, 07:21:49 am »

"improperly named" is relative. ;) In *nix, it is how hidden files are named.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Fatal error" upgrading to cpg 1.4
« Reply #14 on: July 09, 2005, 09:39:20 pm »

do not use MS Frontpage to upload coppermine. In fact, never use Frontpage to upload any php driven app. After thinking about it twice: never use Frontpage at all.

Joachim
Logged

newyorkrunaway

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: "Fatal error" upgrading to cpg 1.4
« Reply #15 on: July 10, 2005, 07:32:50 am »

then what would you recomend people use all knowing gaugau?
Logged

aravot

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 73
    • Product Compare for Virtuemart Shopping Cart
Re: "Fatal error" upgrading to cpg 1.4
« Reply #16 on: July 10, 2005, 07:41:20 am »

then what would you recomend people use all knowing gaugau?

http://www.crimsoneditor.com/
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Fatal error" upgrading to cpg 1.4
« Reply #17 on: July 10, 2005, 11:39:14 am »

for editing, any plain text editor is fine, notepad.exe will do. For uploading, use a decent FTP app, like Filezilla, SmartFTP, WsFTP, WinSCP. WYSIWYG editors (like MS Frontpage) are notorious for making "code improvements" that will result in broken files. They touch things they're not meant to touch. MS Frontpage is fine for complete newbies who want to create a static (HTML-only) web page without wanting to learn HTML or other web-related stuff at all. Dynamic pages (pages that are built using server-sided scripting languages like PHP, ASP, Perl) will break when WYSIWYG-editors are being used. This even applies to good products like Dreamweaver as well if you're running them with out-of-the-box settings, but at least good editors have a switch in their config that allows you to specify that the editor mustn't try to "enhance" code. Apps like MS Frontpage don't have such a switch or the switch isn't working well enough.

Joachim

P.S. Why don't you stop posting sarcastic comments like "all knowing gaugau"? I'm trying to do my best to help you as well as others by sharing what I know. I certainly don't know everything about the web, but I do know some things about coppermine (and stuff related to it, like what editor to use or not to use to be out of harms way).
Logged

Ragnarok

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: "Fatal error" upgrading to cpg 1.4
« Reply #18 on: August 10, 2005, 06:56:42 pm »

hi,
i also have this error.
index.php only displays this:

Fatal error :<br />

the db user has alter rights, but after running update.php the dbs are looking still very different, but update.php said, all is fine.

inserting $CONFIG['debug_mode']='1'; into config.in.php results in no additional messages

so what todo? whats the recommended upgrade path from 1.3.3 to 1.4?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Fatal error" upgrading to cpg 1.4
« Reply #19 on: August 10, 2005, 07:02:35 pm »

Read the thread! There's no support for cpg1.4.1 yet! Replying to a thread that is marked "invalid" is not a good idea. Now I have to lock it.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 19 queries.