Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Incorrect Login Path  (Read 8280 times)

0 Members and 1 Guest are viewing this topic.

huwnet

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 7
    • Huw.org.uk
Incorrect Login Path
« on: July 03, 2005, 06:50:33 pm »

I have a bridged install with SMF. For some reason Coppermine is ignoring the forum path. Instead of going to http://<site>/smf/index.php?action=login it goes to http://<site>/index.php?action=login

The path names are set correctly in the configuration.

How can I fix this problem?

Thanks
« Last Edit: July 10, 2005, 01:08:51 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Incorrect Login Path
« Reply #1 on: July 03, 2005, 06:55:58 pm »

Can you post what you actually have in the configuration and the paths for coppermine and smf ?
Logged

huwnet

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 7
    • Huw.org.uk
Re: Incorrect Login Path
« Reply #2 on: July 03, 2005, 07:37:01 pm »

Don't mean to sound like a newbie but which files shall i post?  ???

Nibbler

  • Guest
Re: Incorrect Login Path
« Reply #3 on: July 03, 2005, 10:27:47 pm »

I just want to know what you entered for paths or urls into the bridge manager, and where your coppermine and smf are in relation to eachother, ie http://www.mydomain.com/cpg and http://www.mydomain.com/smf ?
Logged

huwnet

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 7
    • Huw.org.uk
Re: Incorrect Login Path
« Reply #4 on: July 04, 2005, 04:56:23 pm »

huwnet

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 7
    • Huw.org.uk
Re: Incorrect Login Path
« Reply #5 on: July 09, 2005, 03:20:05 pm »

anyone

Nibbler

  • Guest
Re: Incorrect Login Path
« Reply #6 on: July 09, 2005, 03:21:43 pm »

Still waiting to hear what you set as the path in the bridge manager....
Logged

huwnet

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 7
    • Huw.org.uk
Re: Incorrect Login Path
« Reply #7 on: July 09, 2005, 03:29:04 pm »

Sorry:

Bridge Wizard: enable/disable BBS integration
Your bridge settings
Forum URL:    http://192.168.0.4/smf
Relative path to your BBS's config file:    ../smf/
Use post-based groups?:    0

Nibbler

  • Guest
Re: Incorrect Login Path
« Reply #8 on: July 09, 2005, 03:39:26 pm »

What do you have set for your $boardurl in SMF's Settings.php ?
Logged

huwnet

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 7
    • Huw.org.uk
Re: Incorrect Login Path
« Reply #9 on: July 09, 2005, 03:50:24 pm »

$boardurl = 'http://192.168.0.4/smf';

I think I forgot to mention before that I am running SMF 1.1 Beta 3. I used modifyed code for the forum bridge that I found in this forum.

http://forum.coppermine-gallery.net/index.php?topic=17088.0

Code: [Select]
                                $this->usertable = $this->db['prefix'] . $this->table['users'];
                                $this->groupstable = $this->db['prefix'] . $this->table['groups'];

Nibbler

  • Guest
Re: Incorrect Login Path
« Reply #10 on: July 09, 2005, 04:27:11 pm »

Well unless you get the same problem with SMF 1.0 and an unmodified version of the bridge file this isn't a bug.
Logged

donnoman

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1615
  • From donovanbray.com
    • Donovan Bray
Re: Incorrect Login Path
« Reply #11 on: July 09, 2005, 06:37:56 pm »

Use post groups should be 1, no matter what with SMF.

Logged

Nibbler

  • Guest
Re: Incorrect Login Path
« Reply #12 on: July 09, 2005, 07:07:59 pm »

Why's that ? It should work fine both ways.
Logged

donnoman

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1615
  • From donovanbray.com
    • Donovan Bray
Re: Incorrect Login Path
« Reply #13 on: July 09, 2005, 10:06:37 pm »

Commited fix for login issue, update smf and udb_base bridge files.

Groups come over ok for me, make sure you selected to use post based groups in bridge manager, this really means all bb maintained groups, not just those based on posts.

It took some digging but I remembered it from somewhere. ;)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Incorrect Login Path
« Reply #14 on: July 10, 2005, 11:27:29 am »

as the original poster was refering to smf1.1beta (which is not supported yet), can we mark this thread as invalid then?
Logged

buzcarter

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Incorrect Login Path
« Reply #15 on: September 13, 2005, 08:16:14 am »

I had the same problem... until I noticed the path was relative, not absolute. Changinging it to:

Code: [Select]
// The web path to your SMF Board directory
define('SMF_WEB_PATH', "/forums/");

from just "forums/" fixed it. Hope that helps the next bloke.

btw, awesome bridge, ten minutes ... nice
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 18 queries.