Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Database error after upgrade from 1.1 -> 1.3  (Read 6411 times)

0 Members and 1 Guest are viewing this topic.

cookie-monster

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Database error after upgrade from 1.1 -> 1.3
« on: June 28, 2005, 02:39:03 am »

After reading the instructions i updated my standalone version from 1.1 to 1.3

did the install etc (cant remember wot happened then) but now i keep getting the following error
Code: [Select]
While executing query "SELECT cid, catname, description FROM cpg_categories WHERE parent = ''  ORDER BY pos" on 0

mySQL error: Unknown column 'catname' in 'field list'

File: modules/coppermine/include/functions.inc.php - Line: 101

Ive tried searching the forums with no luck. I also have a full backup of the old one but im hoping its some stupid mistake that is easily corrected.

If you need anymore info let me know

Thanx in advance
« Last Edit: June 30, 2005, 10:24:28 pm by kegobeer »
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Database error after upgrade from 1.1 -> 1.3
« Reply #1 on: June 28, 2005, 03:00:15 am »

Quote
File: modules/coppermine/include/functions.inc.php - Line: 101

Standalone?  Isn't that a nuke location?

Did you follow the upgrade instructions completely for 1.1?

Quote
3.2 Upgrading from releases of version 1.1
First, make a backup (dump) of your database.
Backup your include/config.inc.php file, your anycontent.php file and your "albums" directoy.
Unpack the archive
If the file install.php exists in the root directory, delete it.
Upload all of the new files and directories
CHMOD the albums directory and all subfolders once more to 755 or 777 (depending on your server config)
Call the upgrade script http://yousitename/coppermine_dir/update.php
Your upgrade should be complete.

Did you upload all of the Coppermine 1.3.3 files to your site?  Run the update.php script?
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

cookie-monster

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Database error after upgrade from 1.1 -> 1.3
« Reply #2 on: June 28, 2005, 06:17:40 pm »

hmmmm have i downloaded the wrong version of it ?
           In that case which one should i DL

Or have i just misworded it.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Database error after upgrade from 1.1 -> 1.3
« Reply #3 on: June 28, 2005, 07:09:28 pm »

Did you download Coppermine 1.3.3?
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

cookie-monster

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Database error after upgrade from 1.1 -> 1.3
« Reply #4 on: June 29, 2005, 06:14:39 pm »

yes...
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Database error after upgrade from 1.1 -> 1.3
« Reply #5 on: June 29, 2005, 07:03:14 pm »

Did you upload all of the files, verify file permissions, and then run update.php?

Post a link to your site.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

cookie-monster

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Database error after upgrade from 1.1 -> 1.3
« Reply #6 on: June 29, 2005, 09:28:35 pm »

Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Database error after upgrade from 1.1 -> 1.3
« Reply #7 on: June 30, 2005, 12:39:14 am »

You are using the nuke port of Coppermine, so I moved your post to the appropriate board.  You can't upgrade using the standalone version, and there is no support for the nuke port.  Read the stickies on this board.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

cookie-monster

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Database error after upgrade from 1.1 -> 1.3
« Reply #8 on: June 30, 2005, 08:37:39 pm »

Damn. sorry about that...

Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.