Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Browser locking  (Read 7936 times)

0 Members and 1 Guest are viewing this topic.

Owens Never Sleeps

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
    • http://www.tetongravity.com
Browser locking
« on: November 14, 2003, 06:54:29 am »

I am running Coppermine in combo with VBulletin.  For some reason I am getting periodic browser lock up.  Sometimes it is immediate and sometimes it's after I've been using the galery for a while.  There seems to be no rhyme or reason to it.  No pattern anyway.  When it locks me up, I can't view images from any site or any page.  Anybody run into this?  You can check it out at http://www.tetongravity.com.

Also, it seems to not want to let me out of user mode or admin mode - like I click the user mode buttong and the page cycles, but it still leaves me in admin mode.
Logged

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
Browser locking
« Reply #1 on: November 14, 2003, 07:12:06 am »

http://coppermine.sourceforge.net/faq.php?q=howtoask#howtoask

The link you gave does not work because of the . at the end and even then it takes to some page where I could not locate where the CPG is
Logged
SANIsoft PHP applications for E Biz

moorey

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 404
Browser locking
« Reply #2 on: November 14, 2003, 07:16:20 am »

http://www.tetongravity.com/usergalleries/

You have browser (or server, but pretty sure browser) issues, not CPG issues, as it works fine for me. Have you tried with different browsers?
Logged

Owens Never Sleeps

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
    • http://www.tetongravity.com
Browser locking
« Reply #3 on: November 14, 2003, 08:57:49 am »

Yes -
i've tried on different computers and browsers various
IE versions and netscape.
Logged

moorey

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 404
Browser locking
« Reply #4 on: November 14, 2003, 10:21:14 am »

How about a different machine at a different place?
Logged

Owens Never Sleeps

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
    • http://www.tetongravity.com
Browser locking
« Reply #5 on: November 14, 2003, 06:05:50 pm »

Yes - different machines at several different locations - plus some user complaints of the same problem.
Logged

moorey

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 404
Browser locking
« Reply #6 on: November 14, 2003, 07:08:14 pm »

I can't seem to get my latest IE on PC or Safari on Mac to lockup. In fact, I have never experienced a "browser-lockup" before (at most, it's Java loading too slow, and then some).

Perhaps a little bit details about your server? I can't access your phpinfo as well.
Logged

Oasis

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 252
  • iNSiGNiA
    • Pixnet Gallery
Browser locking
« Reply #7 on: November 14, 2003, 09:37:53 pm »

This has been bothering me for a while too. I have been wondering whether it was a copermine problem or not, because once it happens, it affects all images that try to load in that window, whether in coppermine or not. In other words, if the lockup occurs, I can't see images in any website I surf to using that window, whether it be google, yahoo or whatever. This is with IE6 on WINXP, on mozilla there is no such problem, however 95% of my users use IE6.

Indeed it does seem to happen at random, EXCEPT for one single user album, which I have found to cause lockups EVERY SINGLE TIME I open the album. To try it yourself, go to the following url, and then try to open any other website using that window. I can assure you no images will show up (OK, at least they don't on my computer, or any computer near me right now).
Hold Shift while clicking to open in new window: http://photo.enctu.org/czar
You will notice that many of the pictures in this album already do not show up, even though the files ARE on the server. I know they are there because I checked, and they are physically there, and they are accessible if you type the direct URLs to the images.

Coppermine IS doing something to the browser, that is disabling it from displaying images. I am utterly clueless what may be causing this, because from the source file, I see nothing different from other pages.

Owens, I assume this is the same kind of problem you are having?
Logged
Pixnet Gallery: http://www.pixnet.net
iNSiGNiA Weblog: http://www.jayliu.org

Oasis

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 252
  • iNSiGNiA
    • Pixnet Gallery
Browser locking
« Reply #8 on: November 14, 2003, 09:48:41 pm »

OK since the images in this browser window are gone, I cannot find the link to edit my post, so I'll just have to add: Some of the pictures in that link have partial (very very very partial nudity) if I remember correctly (I can't see the images now, so I can't make sure)

Also, you might want to take a look at the source of the page. Look at the source URLs of the images that aren't showing up, and try to open them in a new window. As I said before, they ARE there on the server, and your computer DOES have access to them, It is just a problem with that particular window not being able to display them. This is definitely NOT a server issue, because once the lockup occurs, images from ANY website will fail to show up.

This is with IE6 on WINXP. On mozilla, it's fine.
Logged
Pixnet Gallery: http://www.pixnet.net
iNSiGNiA Weblog: http://www.jayliu.org

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Browser locking
« Reply #9 on: November 14, 2003, 11:18:36 pm »

I'm 99% sure I've read a similar post somewhere, and I'm rather sure there's an explanation and a fix as well.

Could someone do an intensive search on this (especially on the old board)?

GauGau
Logged

moorey

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 404
Browser locking
« Reply #10 on: November 14, 2003, 11:25:46 pm »

Oasis, all the images show up fine. Usually I'm on a Mac, but I'm at home now with Windows XP, IE6 and I definitely see the pictures fine - no broken images or anything (I have currently 6 browser windows opened).

The first thought that came to me after reading your replies was proxy issues. Transparent proxies have been known to be very, very naughty and cause a lot of issues, but when they are properly configured there's no problemo.

Assuming the majority of your users are connected from the uni, is it possible that they are using a central transparent proxy/gateway? Do a traceroute and you'd be able to tell.

My other thoughts - server performances; including Apache, MySQL, PHP. If the load is tremendous, I can imagine it'll be a detriment.. "tremendous" would really have to be hugely tremendous though since these server apps are very matured and optimised. CPG obviously depends on these apps in more than one ways.
Logged

Oasis

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 252
  • iNSiGNiA
    • Pixnet Gallery
Browser locking
« Reply #11 on: November 15, 2003, 06:11:42 am »

Well this is strange...  :lol:
The images from that user's page never fully load on my computer. And none of the images on Owens homepage load either (except on mozilla).

I'm not sure what a transparent proxy is, but I'm guessing it's a proxy that works on the network without needing to be configured on the user's computer. Proxy problems do seem quite possible, since I have only been able to test using computers inside the university. However the strange thing here is that when I try to load an image using the affected window and the image does not load, the request DOES get logged on the server, and it's logged with my IP, not the proxy IP. Usually if the proxy is checking the server it is logged as w3-cahce3.HCRC.edu.tw or something similar, but it isn't... So it appears that the file is being called directly from the server, but isn't loading... In a new window, it loads with no problems.. Here are some screenshots, though I doubt they will help:

(http://photo.enctu.org/lockup.jpg)
(http://photo.enctu.org/nolockup.jpg)
(http://photo.enctu.org/poorgoogle.jpg)
Logged
Pixnet Gallery: http://www.pixnet.net
iNSiGNiA Weblog: http://www.jayliu.org

moorey

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 404
Browser locking
« Reply #12 on: November 15, 2003, 07:51:10 am »

It is a bit out of the ordinary. Could you confirm your ip address here? http://www.whatismyipaddress.com/ ? (Googled that one). If you have a proxy, the ip will be different from yours.
Logged

Oasis

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 252
  • iNSiGNiA
    • Pixnet Gallery
Browser locking
« Reply #13 on: November 15, 2003, 09:13:29 am »

It's showing me my IP.   :?

@gaugau: This is the most similar one I can find:
http://coppermine.sourceforge.net/oldboard/viewtopic.php?t=2178&highlight=images+loading
But it doesn't seem to help...
Logged
Pixnet Gallery: http://www.pixnet.net
iNSiGNiA Weblog: http://www.jayliu.org

hyperion

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 1317
  • - retired -
Browser locking
« Reply #14 on: November 20, 2003, 06:19:14 pm »

Logged
"Then, Fletch," that bright creature said to him, and the voice was very kind, "let's begin with level flight . . . ."

-Richard Bach, Jonathan Livingston Seagull

(http://www.mozilla.org/products/firefox/buttons/getfirefox_small.png)

Oasis

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 252
  • iNSiGNiA
    • Pixnet Gallery
Browser locking
« Reply #15 on: November 21, 2003, 05:36:01 am »

That explains it!  :lol:
Logged
Pixnet Gallery: http://www.pixnet.net
iNSiGNiA Weblog: http://www.jayliu.org
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 19 queries.