Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: stupid issue I can't fix ....  (Read 5077 times)

0 Members and 1 Guest are viewing this topic.

Fed

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 50
    • Imagetemple.com
stupid issue I can't fix ....
« on: April 30, 2005, 04:38:35 pm »

Hi guys
I have a stupid issue and I can't go through fixing it

see my gallery at www.imagetemple.com/gallery

when I click on the categories in the gallery home page the links don't work

as you can see the links are wrong, they took a wrong path, that one is the path of my temporary working folder and I'd like to fix this problem but I dunno where to put my hands

I'm sure you'll be able to give me the solution...

thanks a lot

Fed
« Last Edit: May 03, 2005, 09:44:20 am by GauGau »
Logged

donnoman

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1615
  • From donovanbray.com
    • Donovan Bray
Re: stupid issue I can't fix ....
« Reply #1 on: April 30, 2005, 05:19:33 pm »

It looks like you opened your theme.php with a graphical editor like frontpage... Never ever do that.

to solve this issue specifically I would start looking at your theme.php and  start looking for problems at where "$template_cat_list=" is.

There are likely other problems that were introduced into your theme.php.
Logged

Fed

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 50
    • Imagetemple.com
Re: stupid issue I can't fix ....
« Reply #2 on: April 30, 2005, 05:47:02 pm »

It looks like you opened your theme.php with a graphical editor like frontpage... Never ever do that.

to solve this issue specifically I would start looking at your theme.php and  start looking for problems at where "$template_cat_list=" is.

There are likely other problems that were introduced into your theme.php.

sure...I open them in dreamweaver from that folder....

I immediately try your sugestion....thanks!
Logged

Fed

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 50
    • Imagetemple.com
Re: stupid issue I can't fix ....
« Reply #3 on: April 30, 2005, 05:50:06 pm »

this is what it contains....

what do I have to change?

Code: [Select]
$template_cat_list = <<<EOT

<!-- BEGIN header -->

...
Logged

donnoman

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1615
  • From donovanbray.com
    • Donovan Bray
Re: stupid issue I can't fix ....
« Reply #4 on: April 30, 2005, 06:29:19 pm »

In dreamweaver theres something you can turn off like code beautification or something, search the forums for "dreamweaver"

post the contents of $template_cat_list = <<<EOT all the way until the next EOT;
Logged

Fed

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 50
    • Imagetemple.com
Re: stupid issue I can't fix ....
« Reply #5 on: April 30, 2005, 06:39:22 pm »

Code: [Select]
$template_cat_list = <<<EOT

<!-- BEGIN header -->

        <tr>

                <td class="tableh1" width="80%"><b>{CATEGORY}</b></td>

                <td class="tableh1" width="10%" align="center"><b>{ALBUMS}</b></td>

                <td class="tableh1" width="10%" align="center"><b>{PICTURES}</b></td>

        </tr>

<!-- END header -->

<!-- BEGIN catrow_noalb -->

        <tr>

                <td class="tableh2" colspan="3"><table border="0" ><tr><td>{CAT_THUMB}</td><td><span class="catlink"><b>{CAT_TITLE}</b></span>{CAT_DESC}</td></tr></table></td>

        </tr>

<!-- END catrow_noalb -->

<!-- BEGIN catrow -->

        <tr>

                <td class="tableb"><table border="0"><tr><td>{CAT_THUMB}</td><td><span class="catlink"><b>{CAT_TITLE}</b></span>{CAT_DESC}</td></tr></table></td>

                <td class="tableb" align="center">{ALB_COUNT}</td>

                <td class="tableb" align="center">{PIC_COUNT}</td>

        </tr>

     <!--if (isset(CAT_ALBUMS)){-->

          <tr>

            <td class="tableb" colspan=3>{CAT_ALBUMS}</td>

      </tr><!--};-->

<!-- END catrow -->

<!-- BEGIN footer -->

        <tr>


                <td colspan="3" class="tableh1" align="center"><span class="statlink"><b>{STATISTICS}</b></span></td>

        </tr>

<!-- END footer -->

<!-- BEGIN spacer -->

        <img src="images/spacer.gif" width="1" height="17" /><br />

<!-- END spacer -->



EOT;
Logged

Fed

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 50
    • Imagetemple.com
Re: stupid issue I can't fix ....
« Reply #6 on: May 01, 2005, 11:28:37 am »

UP :D

I'm still here with the problem, and didn't find the way to disable code beautification in Dreamweaver....

someone who has an idea?( maybe for both the problems  8) )
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: stupid issue I can't fix ....
« Reply #7 on: May 01, 2005, 11:51:29 am »

use a plain text editor (notepad is fine)
Logged

Fed

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 50
    • Imagetemple.com
Re: stupid issue I can't fix ....
« Reply #8 on: May 01, 2005, 04:10:44 pm »

use a plain text editor (notepad is fine)

and what about the problem of my wrong links ?

what do I have to change to have them working again?  :-\\
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: stupid issue I can't fix ....
« Reply #9 on: May 01, 2005, 04:26:43 pm »

UP :D

I'm still here with the problem, and didn't find the way to disable code beautification in Dreamweaver....

someone who has an idea?( maybe for both the problems 8) )
http://forum.coppermine-gallery.net/index.php?topic=11903.msg58141#msg58141
Logged

donnoman

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1615
  • From donovanbray.com
    • Donovan Bray
Re: stupid issue I can't fix ....
« Reply #10 on: May 01, 2005, 04:58:58 pm »

The problem isn't with your theme, as you can switch to classic and the problem persists.

Look in your index.php

look specifically at this function "function get_subcat_data"

Did you apply any mods?
Logged

Fed

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 50
    • Imagetemple.com
Re: stupid issue I can't fix ....
« Reply #11 on: May 01, 2005, 07:46:14 pm »

I found thos wrong links in index php, I tried changing something but it didn't work, it retook the wrong ones....

what if I upload a standard index.php file from the coppermine packet?
Logged

donnoman

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1615
  • From donovanbray.com
    • Donovan Bray
Re: stupid issue I can't fix ....
« Reply #12 on: May 02, 2005, 01:17:46 am »

That would be a good starting point.
Logged

Fed

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 50
    • Imagetemple.com
Re: stupid issue I can't fix ....
« Reply #13 on: May 02, 2005, 01:21:01 pm »

That would be a good starting point.

will I loose any configuration setting or something I made? (except any code change I could have made but I don't think I have...)
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: stupid issue I can't fix ....
« Reply #14 on: May 02, 2005, 04:30:42 pm »

Configuration settings are stored in the mysql database so you will not lose them if you are only replacing index.php

Make sure to backup your version. Then use winmerge to compare yours and the cpg version to see what changes occurred.
Logged

Fed

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 50
    • Imagetemple.com
Re: stupid issue I can't fix ....
« Reply #15 on: May 02, 2005, 05:25:49 pm »

it seems to work fine now

if you find any bugs please advise me ;)

thanks for the support guys!
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 19 queries.