Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 [2]   Go Down

Author Topic: Fault: unable to upload any pics  (Read 15953 times)

0 Members and 1 Guest are viewing this topic.

hyperion

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 1317
  • - retired -
Fault: unable to upload any pics
« Reply #20 on: April 21, 2004, 11:35:37 pm »

Yes, you can reinstall PHP.  Just go get the latest version from www.php.net and follow the instructions.

Have you run scandisk yet? Also, you need to get a UPS with shutdown software to save you from this type of misery in the future.
Logged
"Then, Fletch," that bright creature said to him, and the voice was very kind, "let's begin with level flight . . . ."

-Richard Bach, Jonathan Livingston Seagull

(http://www.mozilla.org/products/firefox/buttons/getfirefox_small.png)

hyperion

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 1317
  • - retired -
Fault: unable to upload any pics
« Reply #21 on: April 21, 2004, 11:38:06 pm »

Echo5ive,

You are using the beta. There is not beta support right now.  If you want to see the cause fot he error, you need to drop down to Single uploads only using the Group console.
Logged
"Then, Fletch," that bright creature said to him, and the voice was very kind, "let's begin with level flight . . . ."

-Richard Bach, Jonathan Livingston Seagull

(http://www.mozilla.org/products/firefox/buttons/getfirefox_small.png)

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Fault: unable to upload any pics
« Reply #22 on: April 22, 2004, 06:44:46 am »

@xtreme: did you set the permissions for the temporary folders as suggested? Describe in detail what you did. Imo this is related to the fact that you're running your own server without actually knowing what you do (not recommended at all, you might get caught 'pants down' by any script kiddy attack).

GauGau
Logged

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Fault: unable to upload any pics
« Reply #23 on: April 28, 2004, 12:24:34 am »

Right guys it has taken me a while but here goes:
1. I reinstalled cpm by copying it over my existing instalatioin - no effect
2. I upgraded to PHP4.6 from PHP4.3 - No effect
3.I uninstalled IIS & Reinstalled - No Effect ( this took me quite some time )
4. i has a backup of the whole HDD , i restored to a backup - No Effect , i am asuming i had the problem b4 i did the backup.

now that leaves me with user permissions for teh whole PHP directory
http://homepage.ntlworld.com/shawn.gates/permisions.JPG
i have both my iusr & iwam acc listed here but they both have read/write access.

so what am i missing here ???
Please


« Last Edit: April 29, 2004, 06:46:29 pm by xtreme »
Logged
Go Big Or go the F*ck Home !!!!

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Re: Fault: unable to upload any pics
« Reply #24 on: May 03, 2004, 05:32:59 pm »

Anyone ?
I will try Any ideas !!!!

Thanks
X
Logged
Go Big Or go the F*ck Home !!!!

GayleR

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Fault: unable to upload any pics
« Reply #25 on: July 09, 2005, 06:25:21 pm »

OK here's one for ya.

I am getting this same error message as the others in this thread:



Impossible to move GayleRichter_July4_O.png to albums/userpics/10001/ !

File: /home/gayler/public_html/cpg133/db_input.php - Line: 267

Warning: move_uploaded_file(albums/userpics/10001/GayleRichter_July4_O.png): failed to open stream: Permission denied in /home/gayler/public_html/cpg133/db_input.php on line 266


now for the funny part. I cannot upload as a user or as admin. Some of my registered users cannot upload either, BUT many registered users are uploading just fine. And I have tried to upload from my daughters computer (and she can upload fine).  So whats going on here?

Here is the debug info:

USER:
------------------
Array
(
    [ID] => 25bbfd3bee4ee29cd6d06f61d9aef588
    [am] => 1
    [liv] => Array
        (
           
  • => 31
  • [1] => 30
                [2] => 34
                [3] => 33
                [4] => 25
            )

    )

    ==========================
    USER DATA:
    ------------------
    Array
    (
       
[user_id] => 1
    [user_group] => 1
    [user_active] => YES
    [user_name] => gayler
    [user_password] => ********
    [user_lastvisit] => 2005-07-09 11:07:10
    [user_regdate] => 2005-05-12 22:19:48
    [user_group_list] =>
    [user_email] =>
    [user_website] =>
    [user_location] =>
    [user_interests] =>
    [user_occupation] =>
    [user_actkey] =>
    [disk_max] => 10000
    [disk_min] => 10000
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 0
    [ufc_min] => 0
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 0
    [group_quota] => 10000
    [can_see_all_albums] => 1
    [group_id] => 1
    [groups] => Array
        (
            [1] => 1
        )

)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content FROM cpg133_filetypes;
  • [1] => SELECT * FROM cpg133_users WHERE user_id='1'AND user_active = 'YES' AND user_password != '' AND BINARY MD5(user_password) = 'f2a415aa78c7621831da5995e1447242'
        [2] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg133_usergroups WHERE group_id in (1)
        [3] => SELECT group_name FROM  cpg133_usergroups WHERE group_id= 1
        [4] => DELETE FROM cpg133_banned WHERE expiry < '2005-07-09 11:16:00'
        [5] => SELECT * FROM cpg133_banned WHERE ip_addr='12.226.105.76' OR ip_addr='12.226.105.76' OR user_id=1
        [6] => SELECT category FROM cpg133_albums WHERE aid='4'
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
       
[album] => 4
    [MAX_FILE_SIZE] => 10240000
    [title] =>
    [caption] =>
    [keywords] =>
    [event] => picture
    [user1] =>
    [user2] =>
    [user3] =>
)

==========================
VERSION INFO :
------------------
PHP version: 4.3.10 - OK
------------------
mySQL version: 4.0.24-standard
------------------
Coppermine version: 1.3.3
==========================
Module: gd
------------------
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled
==========================
Module: mysql
------------------
Active Persistent Links 0
Active Links 1
Client API version 4.0.24
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.1.4
Linked Version 1.1.4
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/usr/lib/php:/usr/local/lib/php | .:/usr/lib/php:/usr/local/lib/php
open_basedir | /home/gayler/:/usr/lib/php:/usr/local/lib/php:/tmp | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail -t -i | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | -1 | -1
upload_max_filesize | 10M | 10M
post_max_size | 55M | 55M
==========================
Page generated in 0.067 seconds - 7 queries in 0.001 seconds - Album set :
Logged

Nibbler

  • Guest
Re: Fault: unable to upload any pics
« Reply #26 on: July 09, 2005, 06:27:26 pm »

CHMOD albums/userpics/10001 to 777 or 755. Please post in a board appropriate to the version of coppermine you are running.
Logged
Pages: 1 [2]   Go Up
 

Page created in 0.02 seconds with 19 queries.