Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Unable to add users - Error Username must be 2 character long minimum  (Read 4347 times)

0 Members and 1 Guest are viewing this topic.

tkundhi

  • Coppermine newbie
  • Offline Offline
  • Posts: 3

I have a new Coppermine 1.3.2 installation. It appeares to have  installed properly, meaning no errors reported.

However, once I try to add a user. I got the error message as follows:

Error - Username must be 2 characters long minimum'

I've tried severl different name inclusing jmast, test, joclelyn. All with no luck.
Logged

schun

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Unable to add users - Error Username must be 2 character long minimum
« Reply #1 on: March 28, 2005, 06:48:05 pm »

I am getting the same problem.
I downloaded cpq 1.3.2 and did a fresh install..

Logged

tkundhi

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Unable to add users - Error Username must be 2 character long minimum
« Reply #2 on: March 29, 2005, 05:29:37 pm »

Schum,

Did that solve the problem?

t.
Logged

schun

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Unable to add users - Error Username must be 2 character long minimum
« Reply #3 on: March 29, 2005, 06:37:48 pm »

nope. Fresh install didn't help. Stiill getting the same error when I try to add users.

Logged

tkundhi

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Unable to add users - Error Username must be 2 character long minimum
« Reply #4 on: March 29, 2005, 07:00:47 pm »

I solved my problem with a fresh install. The one thing I did differently this time is I did not mess around with a custom php.ini file. Originally I was trying to adjust the memory limits in a custom PHP file to accomodate lrage file uploads.  The servers default config was

memory_limit= 40M
post_max_size=8M
upload_max_file size=20M

this does not conform to what I read in another FAQ post on how to ensure file uploads.
upload_max_file size<post_max_size<memory_limit

My hosting provider said I could put a custom php.ini file in my coppermine directory to change the defaults. Furthermore they said to only add entries for the parameters I wanted to change so I did the following with some trial and error.

memory_limit= 40M
post_max_size=32M
upload_max_file size=20M

I couldn't simply add the post_max_size like the suggested because then the other values dropped to some other defaults memory_linit=8M and upload_max_file_size=2M.

However with my cusotm php.ini file I couldn't add users or relly do anything else. Once I removed the it and used the system defaults things began to work. 

Nore, I have set folder permissions on albums and include to 777. If you have tried both the 777 and 755 permissions on albums and include I would suggest you look at the php config.

HTH,

t.
Logged

schun

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Unable to add users - Error Username must be 2 character long minimum
« Reply #5 on: March 30, 2005, 02:56:58 am »

I didn't make any changes to the fresh install and having this problem, so not sure what to do..
In addition to not being able to add any users, I am not able to change any settings in Config, not being able to upload any files.. and many more..

I am running php 4.1.2 and mysql v. 3.23.49..
GD 2.0 is installed.. and running in CGI Server..

For information, I have installed phpBB 11 and its running beautifully without any issue..

What can I do? Any advice will be much appreciated!!

Thanks!!


Logged

Nibbler

  • Guest
Re: Unable to add users - Error Username must be 2 character long minimum
« Reply #6 on: March 30, 2005, 03:03:51 am »

If you are happy to PM me an FTP or cpanel login for your site I can take a look for you.
Logged

schun

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Unable to add users - Error Username must be 2 character long minimum
« Reply #7 on: March 31, 2005, 02:42:09 pm »

Hi,

I just sent you my site address and username/password using PM.

Thanks alot!
Sarah
Logged

Nibbler

  • Guest
Re: Unable to add users - Error Username must be 2 character long minimum
« Reply #8 on: March 31, 2005, 05:51:21 pm »

For reference, I was able to fix this by correcting the value for $PHP_SELF in init.inc.php. The value in the server vars (likely the true address) was being 302ed (to a tidier address), causing the POST request to usermgr.php to be (correctly) changed to a GET request (as required by RFC2616), thereby losing the data contained in the POST, and presenting an empty $_POST array to the usermanager script, which interpreted it as empty value for the fields. Setting $PHP_SELF to the address that was the redirection destination solves the problem. In this case it was possible to do the correction with a str_replace.

Maybe a similar approach could solve the issue for the origianl poster also.
Logged
Pages: [1]   Go Up
 

Page created in 0.212 seconds with 19 queries.