Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Bugs in Themes 5-6.0  (Read 6276 times)

0 Members and 1 Guest are viewing this topic.

ArniesAirsoft

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Bugs in Themes 5-6.0
« on: September 29, 2003, 05:34:49 pm »

Okay.. there's a heap of bugs in the Nuke port of the themes.

In any theme.php that you want to use there's a typo throughout.

"USER_ID" is used as a template variable. This is incorrect, it should be "UID". All variables in coppermin/themes/[themname]/theme.php need to be changed.

Next up.. I prefer to link the profile back to the forum profile for that user, rather than to the coppermine profile. Just a personal choice.

If you want to do so, change the code (again in your theme.php you are using) from (around line 348):

Code: [Select]
// HTML template for the USER info box in the user list view
$template_user_list_info_box = <<<EOT

        <table cellspacing="1" cellpadding="0" border="0" width="100%" class="user_thumb_infobox">
                <tr>
                        <th><a href="modules.php?name=coppermine&file=profile&uid={UID}">{uname}</a></th>
                </tr>
                <tr>
                        <td>{ALBUMS}</td>
                </tr>
                <tr>
                        <td>{PICTURES}</td>
                </tr>
        </table>

EOT;


to:

Code: [Select]
// HTML template for the USER info box in the user list view
$template_user_list_info_box = <<<EOT

        <table cellspacing="1" cellpadding="0" border="0" width="100%" class="user_thumb_infobox">
                <tr>
                        <th><a href="modules.php?name=Forums&file=profile&mode=viewprofile&u={UID}">{uname}</a></th>
                </tr>
                <tr>
                        <td>{ALBUMS}</td>
                </tr>
                <tr>
                        <td>{PICTURES}</td>
                </tr>
        </table>

EOT;
Logged
Webmaster ArniesAirsoft.co.uk

sigi

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 68
    • http://www.allygally.de
Re: Bugs in Themes
« Reply #1 on: September 29, 2003, 07:11:53 pm »

Quote from: "ArniesAirsoft"
Okay.. there's a heap of bugs in the Nuke port of the themes.

In any theme.php that you want to use there's a typo throughout.

"USER_ID" is used as a template variable. This is incorrect, it should be "UID". All variables in coppermin/themes/[themname]/theme.php need to be changed.


mhmm , to me it seems theres a connection between the template variable "USER_ID" and the phpnuke database field name User_id from nuke_users... that is, für phpNuke 6.5 and up, this should be USER_ID, for 6.0 and less it should be UID ...
Logged
Siegfried Schlosser

Berlin, Germany

had a big Coppermine gallery with more than 250.000 pics  at
www.allygally.de, but due to juristical problems that is closed now ....
Now trying Coppermine 1.4.x at http://walexis.pytalhost.de/

ArniesAirsoft

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Bugs in Themes 5-6.0
« Reply #2 on: September 29, 2003, 08:39:12 pm »

Well I'm using phpnuke 6.0 and using the port for Nuke 6, rather than 6.5 and above. There are two ports in the nuke distribution zip file sorry I should have said which I was using.
Logged
Webmaster ArniesAirsoft.co.uk
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 19 queries.