Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [SOLVED] Fatal Error While Processing Query + question  (Read 4756 times)

0 Members and 1 Guest are viewing this topic.

dalai-llama

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
[SOLVED] Fatal Error While Processing Query + question
« on: November 15, 2003, 08:46:02 pm »

I'm a total newbie, so please accept my apologies if I ask something so stupid that it's a waste of your time. :oops:

I've got (I think) the right version of Coppermine installed, but when I try to access it I get the following message:
Quote
Fatal error :
There was an error while processing a database query


Here's the (probably very) stupid question:  
Gtroll posted that Imagemagick was a requirement to run coppermine.  Which version and where do I put it?  I'm running W98 on my home machine, but the server that's hosting the site seems to be some sort of Unix-based system (only an assumption based on the fact that WS_FTP uses CHMOD to change permissions).  Do I need one of the binaries found here?  I've looked around a little and I don't see directions for installing it on the server, but I'm probably so clueless that I don't even know what I'm looking for.

Here are details:

Site:  http://www.dalai-llama.com
Username:  guest
Password:  guest

PHP-Nuke version:  6.5
PHP version:  I don't know where to find this, sorry.
Database:  Not sure; I know it's mySQL and the admin header says "abforums running on 10.0.6.3 - phpMyadmin 2.4.0"
Specific Error: Fatal error :
There was an error while processing a database query
Output of Coppermine Debug: I get the above error message when I try to access Coppermine config from the admin panel.
Coppermine Version: cpgnuke1.2.0rc2.zip (copy-and-pasted the filename to be sure I got it right); I couldn't find a file named "cpg1.2.0rc2_phpnuke.zip"
Browsers I've Tried: Mozilla Firebird 0.6.1, IE 6.0.2800.1106

Other things you may want to know:

 - I tried to install the wrong version of Coppermine first.  When it didn't work, I deleted and re-installed it a couple of times.  Same thing with the new version.

- When I tried to access the "dalai-llama.com/modules/coppermine/install.php" page: I got the screen where it asked if I wanted to use cpg_ as the prefix; when I clicked "Go", it would return a blank screen.  I eventually installed the tables directly from myAdmin.  No joy.  After a little bit of fiddling and deleting the tables, I tried the "http:...install.php" link again and it returned a table with a list of database-looking commands on the left and "Succeeded" on the right.

- The site uses the "Flashylite" theme and is very Flash-heavy. I thought that the weird theme might be causing the problem; I tried others but got the same error.

- I've added some custom blocks, but they're fairly simple and I don't think they're part of the problem.

- There's a content page in the "Cotillion Belles" section that has pictures of a wet t-shirt contest.  As far as net porn goes it isn't too bad, but it's still not something you want to be looking at when your boss walks in.  It should be easy to avoid.

- There's a section called "Sacred Cows" that might interest DJMaze.  I laughed when I saw his avatar.

Thank you for your help.  I thought that I just didn't know what I was doing, but after looking around around on the forums and Imagemagick's download area I think I may be in way over my head.  :shock:

The Dalai LLama[/i][/list][/url][/quote]
Logged

gtroll

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 618
    • CPG-Nuke
[SOLVED] Fatal Error While Processing Query + question
« Reply #1 on: November 15, 2003, 09:44:24 pm »

Imagemagick or GD is what I posted...If you want to run imagemagick on windows I believe you need the .dll . The imagemagick setup is the same as the standalone CPG if you search the new and old  boards for ImageMagick somebody has prob. asked and answer your questions about IM.

I don't think your install was complete
 [list=1]
  • delete all 4 cpg fields added to nuke_users: user_group_cp, user_active_cp, user_lastvisit_cp, user_regdate_cp
  • delete all table you created in phpmyadmin, the cpg_ones
  • If you are absolutly positive you have cpgnuke1.2.0rc2.zip delete your local files, unzip and copy to correct directories again, reupload, delete config.inc.php if it exists on the server
  • Login on your homepage at http://www.dalai-llama.com/nuked/admin.php
  • chmod /coppermine/include, albums and albums/userpics to 777
  • Go to http://www.dalai-llama.com/nuked/modules/coppermine/install.php
  • When and if there is an error STOP installing,and post error here!
  • [/list:o]
    Thank for your complete post.

dalai-llama

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Thank You!
« Reply #2 on: November 16, 2003, 01:51:02 am »

[size=18]You rock![/size]

Thank you for the quick, simple, and very helpful response.

I thought GD was a program that I would have to download and install (like ImageMagick, only not as easy to find in Google.). I didn't realize it was already built into PHP!

I also thought that I had deleted and reposted all of the files, but I guess I missed something.  I followed your directions and it worked like a charm, first time!

I'm sure I'll be back with another goofy question before too long, but it's working fine for now.  Thank you again for your help!
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.