Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: installation error - Failed opening required 'udb_base.inc.php'  (Read 5541 times)

0 Members and 1 Guest are viewing this topic.

andreasass

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

I get this error after running the install page -

Fatal error: main() [function.require]: Failed opening required 'udb_base.inc.php' (include_path='.:/usr/local/lib/php') in /home/ftpuser/asimpson/cpg/bridge/coppermine.inc.php on line 26

My web host runs in Safe Mode - Apache/2.0.52 (Unix) PHP/5.0.3. I have Chmod suggested folders to 777 as per documentation, I have also checked "define safe mode" is active in include file.

Not sure what else to check.

Any help would be greatly apprecaited.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: installation error - Failed opening required 'udb_base.inc.php'
« Reply #1 on: March 03, 2005, 02:17:14 am »

Are you sure you're running 1.3.x?  Looks like 1.4, which is still in alpha stage and has no support.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

andreasass

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: installation error - Failed opening required 'udb_base.inc.php'
« Reply #2 on: March 04, 2005, 01:10:51 pm »

Are you sure you're running 1.3.x?  Looks like 1.4, which is still in alpha stage and has no support.

Ahh.. yes, it seems it was 1.4. Sorry.

I have installed 1.3.2 now and still have errors. I can't get past the install page. I input the data (which is correct) and it just reloads the page with these errors -
Undefined index: PATH_TRANSLATED in /home/ftpuser/asimpson/cg/install.php on line 21

Notice: Undefined offset: -1 in /home/ftpuser/asimpson/cg/install.php on line 22

I have checked through PhpAdmin and it has not written any files to the database. At least with 1.4 it created records, although I couldn't get it to work!
Any advice would be appreaciated greatly!!



Logged

Nibbler

  • Guest
Re: installation error - Failed opening required 'udb_base.inc.php'
« Reply #3 on: March 04, 2005, 01:12:17 pm »

You have to make some changes to your PHP setup if you use PHP5 with CPG 1.3.2 Please search th board for PHP5.
Logged

andreasass

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: installation error - Failed opening required 'udb_base.inc.php'
« Reply #4 on: March 04, 2005, 01:20:04 pm »

You have to make some changes to your PHP setup if you use PHP5 with CPG 1.3.2 Please search th board for PHP5.

As I'm using a host so I have no control over how Php 5 is setup.  Does this mean I cannot run cpg in its present form?  (I had a quick read and that's what my understanding now is)
Logged

Nibbler

  • Guest
Re: installation error - Failed opening required 'udb_base.inc.php'
« Reply #5 on: March 04, 2005, 01:31:47 pm »

You need long arrays enabled to use CPG 1.3.2 with PHP5, if your host does not have that set the best idea would be to wait for 1.4 to be released, but I cannot give you a date on that.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: installation error - Failed opening required 'udb_base.inc.php'
« Reply #6 on: March 04, 2005, 02:05:02 pm »

You can always ask your host to enable long arrays for you.  It never hurts to ask.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: installation error - Failed opening required 'udb_base.inc.php'
« Reply #7 on: March 04, 2005, 02:40:58 pm »

a decent webhost should have no problems with enabling this for you - in fact, it's even recommended to enable long arrays in the first place, to provide backwards compatibility.

Joachim
Logged

andreasass

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: installation error - Failed opening required 'udb_base.inc.php'
« Reply #8 on: March 04, 2005, 11:27:05 pm »

a decent webhost should have no problems with enabling this for you - in fact, it's even recommended to enable long arrays in the first place, to provide backwards compatibility.

Joachim

thank you all for your responses!

I will ask my host to enable long arrays if possible, if not I'll wait for 1.4.
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 19 queries.