Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: some meta albums: No image to display  (Read 5955 times)

0 Members and 1 Guest are viewing this topic.

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
some meta albums: No image to display
« on: February 28, 2005, 12:15:56 am »

When I click on a thumb from a "top rated" meta album, it says:
Quote
No image to display

I tried this suggestion and it didn't work.

I tried with an image with 3 votes.
« Last Edit: March 02, 2005, 02:37:18 am by donnoman »
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Top Rated: No image to display
« Reply #1 on: February 28, 2005, 12:30:12 am »

It's not just that meta album.  Last uploads and Most viewed also has the same issue, but only if you click them while inside of an album.  I think it's because the images are being pulled from all images and not just the album you are in.  Since there's no image that corresponds to the URL, the error message is displayed.

I don't know about last comments - haven't tried it yet - but I wager the same problem exists.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Top Rated: No image to display
« Reply #2 on: February 28, 2005, 12:58:39 am »

You're right about last uploads and most viewed.

Last comments is ok.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Top Rated: No image to display
« Reply #3 on: February 28, 2005, 01:44:37 am »

I think it's where the $META_ALBUM_SET is defined.  As far as I can tell, there are no album restrictions being passed into the $META_ALBUM_SET variable.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

donnoman

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1615
  • From donovanbray.com
    • Donovan Bray
Re: some meta albums: No image to display
« Reply #4 on: March 01, 2005, 05:35:49 am »

META_ALBUM_SET should be all albums the current CAT and below, with the exception of any FORBIDDEN_SET albums.

I'm looking into this.
Logged

donnoman

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1615
  • From donovanbray.com
    • Donovan Bray
Re: some meta albums: No image to display
« Reply #5 on: March 01, 2005, 07:32:09 am »

$META_ALBUM_SET wasn't getting set at all on the thumbnails page, and it was allowing pic's from the private albums get mixed in. That was throwing off all the positions.

I just comitted a fix, if you can test again I'd appreciate it.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: some meta albums: No image to display
« Reply #6 on: March 01, 2005, 12:48:58 pm »

Works for me.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.