Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Question of performance  (Read 2662 times)

0 Members and 1 Guest are viewing this topic.

flogghe

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 44
    • MaritimeDigital Archive
Question of performance
« on: February 27, 2005, 04:36:10 pm »

Hello

After looking at some topics, I could not fiind many information on how to speed up my gallery. I found that  disabling the random sections and using the classic theme helps a lot, but are there other issues that could help?  Is GD faster dan IM?

The site is: http://www.ibiblio.org/maritime/photolibrary (navigation on the left will not work yet)

Does Coppermine support caching?

Thanks in advance
Frederic
« Last Edit: February 27, 2005, 04:52:16 pm by flogghe »
Logged
Kind regards,

Frederic Logghe
Webmaster MaritimeDigital Archive
http://www.ibiblio.org/maritime

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Question of performance
« Reply #1 on: February 28, 2005, 08:33:30 am »

The image libraries are only used when new images are being added to coppermine's database, so the general speed of a page browsed by regular users doesn't relate to the use of GD vs. ImageMagick. There are many things you can do to tweak the performance, most often less details on the gallery's start page (index page) helps most. You already disabled most fancy resource-eaters from the index, and your page loads very fast for me, so I see little point in optimization. If the page is still to slow for you, you might want to do some benchmarking and talk this over with your webhost. If everything fails, you will have to upgrade your webhosting package or even find a new webhost who offers better performance (but, like I said: the page loads fine imo, you should leave it as is). Make sure not to test only from your local pc - there might be issues with your machine in particular. Try testing from a friend's pc as well.

Joachim
Logged

flogghe

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 44
    • MaritimeDigital Archive
Re: Question of performance
« Reply #2 on: February 28, 2005, 08:32:01 pm »

Thanks for the information. I will check it on another PC.

Kind  regards,
Frederic
Logged
Kind regards,

Frederic Logghe
Webmaster MaritimeDigital Archive
http://www.ibiblio.org/maritime
Pages: [1]   Go Up
 

Page created in 0.034 seconds with 19 queries.