Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Search error: clicking results goes to wrong pictures!  (Read 2928 times)

0 Members and 1 Guest are viewing this topic.

busterjet

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Search error: clicking results goes to wrong pictures!
« on: February 26, 2005, 10:56:35 pm »

Hello

I hope someone can help me.

This problem only seems to happen in Firefox (IE is fine) and even then it only happens 50% of the time:

When running a search, the results are displayed correctly with appropriate thumbnails. However, when you click a thumbnail it takes you to a completely different picture. Whatever the search term, when you click a result you get a different picture.

I think this must be something to do with a cache somewhere which has "remembered" a previous search but I have flushed out the Firefox cache and still the problem happens (but not always!). I notice that whatever you search for, the URL of the results are always the same, eg ...displayimage.php?album=search&cat=0&pos=0, pos=1 so there must be a hidden variable that points to the correct full size image. This is why I think it might be a cache problem because it is going to a previous pos=0 etc. Hope this makes sense.

My site is http://www.freedigitalphotos.net - I have made some modifications to the "out of the box" code but have not touched the search scripting as I wouldn't know how!

If someone could help me with this I would be so pleased  :) You will almost certainly not experience the problem I describe so I hope one of you regulars know what I mean.

Thanks

PS: Coppermine is otherwise fantastic!

cheers
Logged

Nibbler

  • Guest
Re: Search error: clicking results goes to wrong pictures!
« Reply #1 on: February 27, 2005, 04:27:26 pm »

The search you entered is stored in a cookie on your machine. If you clear the coppermine and/or all cookies then it will forget the previous search term and it will work again.
Logged

busterjet

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Search error: clicking results goes to wrong pictures!
« Reply #2 on: February 27, 2005, 04:40:58 pm »

Thank you - that worked.

Is this a known problem? Are my site visitors likely to have this trouble? Do I need my site to set cookies? I have disabled user registration and log in so see no need for it. :D

Thanks again.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.