Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: After 1st upload confirmed, I get error: HTTP 500, The page cannot be displayed.  (Read 3918 times)

0 Members and 1 Guest are viewing this topic.

ikerstges

  • Coppermine newbie
  • Offline Offline
  • Posts: 1

Hi,

In Coppermine 1.3.0, When I want to upload a jpg file (214 k), I have the following problem..

After selecting the file by using the browse-button in coppermine, the file is transmitted to the server (it says: "1 uploads were successful." and I can actually see the file on the webserver location in directoryname "10001" (/albums/userpics/10001/filename.jpg). When I then click 'CONTINUE', I get to a page where I actually have to enter the details like "Album", "File title", "File description" and "Keywords". When I then click on 'CONTINUE', I get the error: HTTP 500, The page cannot be displayed
There is a problem with the page you are trying to reach and it cannot be displayed.

I have (double)checked *NIX permissions for the /albums, /albums/userpics, and /albums/edit directories. All are set to 777. I have also configured my Coppermine to allow only a single file to be uploaded at once.

I've been searching in these forums for "The previous file could not be placed" and that search returns several threads. (This and this and this and this, but no solution so far???) I'm trying to get Coppermine to work for several days now, so now I registered to this forum and post my problem.

Any help would be appreciated?!!

Thanks,
Igor.

[edit]Oh, and I can add that I don't use imagemagic, but using gd2 instead.... [/edit]
[edit2]If somebody is willing to help me: http://fotoalbum.freefronthost.com (tester/tester)[/edit2]
[edit3]Weird, I wanted to supply my link to the phpinfo.php file, but when trying to access: http://fotoalbum.freefronthost.com/phpinfo.php I got error: You don't have permission to access this page. Would that be related? Meanwhile, I have a working1 here: http://ikerstges.freefronthost.com/phpinfo.php[/edit3]
« Last Edit: February 22, 2005, 04:27:52 pm by ikerstges »
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website

500 errors are typically due to a server problem and not a script problem.  You may find more detailed information in your server error logs.  Without any further information, there's not much we can do to help you isolate what's causing this error.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

reuelv

  • Coppermine newbie
  • Offline Offline
  • Posts: 1

I got a Server Error 500 after after the 'place file' page.
Then I found that small files worked OK, large ones fail.
This points to being something to do with memory usage.
My webhost said the error is caused by a php failure before headers are sent out.
On inspection of upload.php, I found that headers are only sent out in conditional blocks.
I don't think there is any default header that is sent out.

To fix this temporarily, I added:
             pageheader('TESTHEADER');
after the line
###### MAIN CODE BLOCK #########
in upload.php

Then I tried uploading and got the true error message:
Allowed memory size exhausted
...which agrees with the diagnosis - (See FAQ on this problem).

In your case it may be another problem but hopefully this will help finding it.
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 19 queries.