Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: empty user albums invisible to admin (same as fixed 1.2x bug)  (Read 3997 times)

0 Members and 1 Guest are viewing this topic.

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
empty user albums invisible to admin (same as fixed 1.2x bug)
« on: February 14, 2005, 10:27:15 am »

This has crept back in somehow.  If a user album is empty, and the user has no other albums, or only empty albums, then admin cannot see this users sub-cat or albums.  The same workaround used for the 1.2x bug does work.

In these screenshots, another user has an empty album, which the logged in user (admin) cannot see.
« Last Edit: February 24, 2005, 05:17:26 pm by Casper »
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: empty user albums invisible to admin (same as fixed 1.2x bug)
« Reply #1 on: February 14, 2005, 05:05:25 pm »

Casper,

could you apply the cpg1.2-fix then? Thanks in advance.

Joachim
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: empty user albums invisible to admin (same as fixed 1.2x bug)
« Reply #2 on: February 14, 2005, 05:42:01 pm »

Joachim,

sorry, I know the workaroud to delete these albums, but not the fix to make them show.

it is not the actual albums that don't show, they do if you manually type the url, it is the category.  If the cat 10002 has no pics in it, then the cat is not shown in the user galleries.

Hope that is clear.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

Nibbler

  • Guest
Re: empty user albums invisible to admin (same as fixed 1.2x bug)
« Reply #3 on: February 14, 2005, 06:25:31 pm »

The issue is with the query in list_users_query() in udb_base.php. It needs a pic to be in the album for the gallery icon feature to function, if there is no pic in the album then the join gives you no results.
Logged

omniscientdeveloper

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 901
Re: empty user albums invisible to admin (same as fixed 1.2x bug)
« Reply #4 on: February 14, 2005, 06:50:07 pm »

Ok. I'll fix this one also. I have to reinstall my dev version, so it'll be tomorrow evening before I can commit it.

....Changing it to a left join should fix it.
Logged

omniscientdeveloper

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 901
Re: empty user albums invisible to admin (same as fixed 1.2x bug)
« Reply #5 on: February 18, 2005, 01:38:02 am »

I just noticed that I accidently committed this "left join" change, before I tested it. Can someone verify that it works. I won't be able to test it (fix if broken) for a couple hours.

Fixed. Please verify that it's giving the expected behaviour. Once it's verified, I'll remove the old code and recommit.
« Last Edit: February 18, 2005, 09:20:14 am by omniscientdeveloper »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: empty user albums invisible to admin (same as fixed 1.2x bug)
« Reply #6 on: February 24, 2005, 10:15:41 am »

Casper, can you confirm Omni's fix?

Joachim
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: empty user albums invisible to admin (same as fixed 1.2x bug)
« Reply #7 on: February 24, 2005, 05:18:33 pm »

Yes, it now works as expected.

Thread marked as fixed.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.