Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: batch upload: No new file was found  (Read 8509 times)

0 Members and 1 Guest are viewing this topic.

boesh

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
batch upload: No new file was found
« on: March 19, 2005, 04:40:47 pm »

With FTP I submitted a set of photo's to the server in a particular folder and I selected : Add batch files (just as I did last week).

But this week Coppermine says: No new file was found.

How come? Anybody any idea where to look?
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: batch upload: No new file was found
« Reply #1 on: March 19, 2005, 07:22:34 pm »

Did you put them in userpics? That's where they should not go.
Logged

boesh

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: batch upload: No new file was found
« Reply #2 on: March 20, 2005, 06:49:34 pm »

Nope, just made a directory.. we've got zillions of albums that do work.. but suddenly we get the message No new file was found.  ???
« Last Edit: March 23, 2005, 09:16:40 am by boesh »
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: batch upload: No new file was found
« Reply #3 on: March 20, 2005, 06:56:04 pm »

Have you searched for the error message "No new file was found". I found a couple with different answers.
Logged

boesh

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: batch upload: No new file was found
« Reply #4 on: March 20, 2005, 10:40:56 pm »

None of the other topics are solved...

Code: [Select]
USER:
------------------
Array
(
    [ID] => f1be6055ac21be2d1a3891c2d38ee362
    [am] => 1
    [liv] => Array
        (
            [0] => 3855
            [1] => 3856
            [2] => 3857
            [3] => 3864
            [4] => 3878
        )

    [uid] => 3
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 3
    [user_group] => 1
    [user_active] => YES
    [user_name] => boesh
    [user_password] => ********
    [user_lastvisit] => 2005-03-19 16:17:16
    [user_regdate] => 2004-08-08 19:22:10
    [user_group_list] => 2
    [user_email] => my@email.nl
    [user_website] => http://www.other_domain.nl
    [user_location] => City
    [user_interests] => 200 meter
    [user_occupation] => Ja
    [user_actkey] =>
    [user_favpics] =>
    [disk_max] => 1024
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
    [groups] => Array
        (
            [0] => 2
            [1] => 1
        )

)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content FROM cpg131_filetypes;
    [1] => SELECT * FROM cpg131_users WHERE user_id='3'AND user_active = 'YES' AND user_password != '' AND BINARY MD5(user_password) = 'some_md5_secret_stuff'
    [2] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg131_usergroups WHERE group_id in (2,1)
    [3] => SELECT group_name FROM  cpg131_usergroups WHERE group_id= 1
    [4] => DELETE FROM cpg131_banned WHERE expiry < 1111356681
    [5] => SELECT * FROM cpg131_banned WHERE ip_addr='66.666.66.666' OR ip_addr='66.666.66.666' OR user_id=3
    [6] => SELECT filepath, filename FROM cpg131_pictures WHERE filepath LIKE 'clubcross05/mannen%'
)

==========================
GET :
------------------
Array
(
    [startdir] => clubcross05/mannen
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 4.3.10 - OK
------------------
mySQL version: 3.23.58
------------------
Coppermine version: 1.3.1
==========================
Module: gd
------------------
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled
==========================
Module: mysql
------------------
Active Persistent Links 5
Active Links 6
Client API version 3.23.58
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.1.4
Linked Version 1.1.4
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | On
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/usr/share/pear | .:/usr/share/pear
open_basedir | /usr/local/psa/home/vhosts/domain.nl/httpdocs:/tmp | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 2M | 2M
post_max_size | 20M | 20M
==========================
Page generated in 0.051 seconds - 7 queries in 0.008 seconds - Album set :
« Last Edit: March 20, 2005, 11:09:27 pm by boesh »
Logged

boesh

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: batch upload: No new file was found
« Reply #5 on: March 20, 2005, 11:22:31 pm »

I also found this one... after logging out
Notice: Undefined index: offline in /usr/local/psa/home/vhosts/domain.nl/httpdocs/copper/include/init.inc.php on line 380

Line 380 says:
Code: [Select]
if (!USER_IS_ADMIN && $CONFIG['offline'] && !strstr($_SERVER["SCRIPT_NAME"],'login')) {
pageheader($lang_errors['offline_title']);
msg_box($lang_errors['offline_title'], $lang_errors['offline_text']);
pagefooter();
exit;
}
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: batch upload: No new file was found
« Reply #6 on: March 21, 2005, 07:00:51 am »

disable notices_display in coppermine's config if notices don't mean anything to you.
Make sure your albums folder (and everything within it) is CHMODed as suggested in the docs.

Joachim
Logged

boesh

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: batch upload: No new file was found
« Reply #7 on: March 21, 2005, 09:17:07 pm »

Yes alle folders are CHMOD'ed.
We have without any problems 1635 files in 38 albums and 6 categories. So .... now suddenly we get the message "No new file was found".
What's wrong?

Any suggestions to check on certain items / things / settings ?
Where to look for what?
« Last Edit: March 21, 2005, 09:40:32 pm by boesh »
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: batch upload: No new file was found
« Reply #8 on: March 21, 2005, 11:14:45 pm »

If you want, PM me your FTP info and a Coppermine admin user, and I'll take a look at it.

Regarding the files you uploaded, are pictures with the exact same name already in the database?
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

boesh

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: batch upload: No new file was found
« Reply #9 on: March 22, 2005, 11:11:34 am »

In close harmony with our provider we out-comnented in de file searchnew.php the following code (line 198):
 
if ( strncmp($file, $CONFIG['thumb_pfx'], strlen($CONFIG['thumb_pfx'])) != 0 &&  strncmp($file, $CONFIG['normal_pfx'], strlen($CONFIG['normal_pfx'])) != 0 && $file != 'index.html')

We think this is part that prevents the files from being seen.

Where can we find this CONFIG[] ?
 
Logged

boesh

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: batch upload: No new file was found
« Reply #10 on: March 22, 2005, 11:12:20 am »

Regarding the files you uploaded, are pictures with the exact same name already in the database?

That is possible. I'll check on that..

In the database table cpg131_config the "normal_pfx" was empty.
Is it possible that causes all the trouble?
« Last Edit: March 22, 2005, 11:24:09 am by boesh »
Logged

boesh

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: batch upload: No new file was found
« Reply #11 on: March 22, 2005, 11:43:24 am »

Just found out that normal_pfx is being defined in the page config --> The prefix for intermediate pictures * and the litttle star says: (*) This settings mustn't be changed if you already have files in your database.

I think someone did change that normal_pfx.

But on the other hand: Hey, if it is that important why give the oppertunity to change it !  Block this option if the database contains files !
Think about it.
Logged

wildnsyko

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: batch upload: No new file was found
« Reply #12 on: March 26, 2005, 08:16:13 pm »

Nope, just made a directory.. we've got zillions of albums that do work.. but suddenly we get the message No new file was found.  ???

Depending on what version of coppermine, you have to put your folder in albums and then it will work.  I had same problem.  Moved and then could upload pics.

Chris
Logged

efferent

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: batch upload: No new file was found
« Reply #13 on: April 10, 2005, 09:23:30 pm »

Quote
Depending on what version of coppermine, you have to put your folder in albums and then it will work.  I had same problem.  Moved and then could upload pics.

i'm having this 'no new files added' prob.... has also worked in the past but not now. i have all my folders in the 'albums' folder.

ez
dekade
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 21 queries.