Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: PHP v 4.3.10 and Coppermine  (Read 23067 times)

0 Members and 1 Guest are viewing this topic.

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
PHP v 4.3.10 and Coppermine
« on: December 27, 2004, 10:26:04 am »

If you have issues with Coppermine after upgrading (or your host upgraded) to php 4.3.10, it is due to using an outdated Zend Optimizer. It must be updated to v. 2.5.7

This is not an issue with coppermine. It is the incompatibility of an old Zend Optimizer and new PHP.
« Last Edit: January 01, 2005, 04:28:40 pm by GauGau »
Logged

MC6800

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 3
    • MC6800's Intranet Home WWW Server
Re: PHP v 4.3.10 and Coppermine
« Reply #1 on: December 28, 2004, 10:36:18 am »

Thank you.

I thank for the information that you brought about.   :D
Logged

eric.com.my

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
  • Eric Chooy
    • Eric's Heaven
Re: PHP v 4.3.10 and Coppermine
« Reply #2 on: February 15, 2005, 03:09:01 am »

If you have issues with Coppermine after upgrading (or your host upgraded) to php 4.3.10, it is due to using an outdated Zend Optimizer. It must be updated to v. 2.5.7

This is not an issue with coppermine. It is the incompatibility of an old Zend Optimizer and new PHP.

I am using  Coppermine version 1.3.2 and it was working fine all along but it have this Critical error "There was an error while processing a database query" Is this due to the Zend Optimizer version as well? How can I check what is my Zend Optimizer version?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: PHP v 4.3.10 and Coppermine
« Reply #3 on: February 15, 2005, 06:08:35 am »

When logged in as admin, go to "admin tools" and then "phpinfo". Take a look at the very first section on the page that has the Zend logo (after the first table), the text should say something like
Quote
This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies with Zend Extension Manager v1.0.6, Copyright (c) 2003-2004, by Zend Technologies with Zend Optimizer v2.5.7, Copyright (c) 1998-2004, by Zend Technologies

If you get
Quote
There was an error while processing a database query
, go to coppermine config and enable debug_mode to see the actual query that failed. Your problem is probably not related.

Joachim
Logged

eric.com.my

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
  • Eric Chooy
    • Eric's Heaven
Re: PHP v 4.3.10 and Coppermine
« Reply #4 on: February 15, 2005, 08:41:59 am »

Thanks a lot for your information.

It's funny that I still can login the user name but when I go into config menu, I cannot see any configuration from there. Please refer to attachment for clear picture.

Hope you guys can help put here. Million thanks..!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: PHP v 4.3.10 and Coppermine
« Reply #5 on: February 15, 2005, 09:05:25 am »

It looks like you haven't uploaded all files, or you're running a "customized" version of coppermine. Where did you get your coppermine package from? Also post a link to your site.

Joachim

P.S. This is not related to the original subject of this thread, after your next reply I will split this your question from this thread, so you should look for my answer to your next reply in a separate thread.
Logged

eric.com.my

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
  • Eric Chooy
    • Eric's Heaven
Re: PHP v 4.3.10 and Coppermine
« Reply #6 on: February 15, 2005, 09:44:42 am »

Hi there,

I downloaded the scripts from this website as well & have not modify anything from the original script.

Here's the link to my page

http://photo.eric.com.my/mis

Thank you so much for your help.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: PHP v 4.3.10 and Coppermine
« Reply #7 on: February 15, 2005, 07:25:35 pm »

use a tool like phpMyAdmin to browse your database, edit coppermine's config table and enable debug_mode by setting it to "1". Then post the actual query that fails. Also check if you have the minimum requirements needed for coppermine.

Joachim
Logged

eric.com.my

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
  • Eric Chooy
    • Eric's Heaven
Re: PHP v 4.3.10 and Coppermine
« Reply #8 on: February 16, 2005, 09:14:37 am »

Hi there, thank you so much for your time. I had followed the steps that I got from your previous post and I got this as the message

While executing query "SELECT aid FROM cpg132_albums WHERE category = " on 0

mySQL error: You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

I think my version should be OK because I was using it just fine way back before this problem got me   ???

My PHP & SQL version is as below

PHP version 4.3.10
MySQL version 4.0.23-standard
« Last Edit: February 16, 2005, 09:21:01 am by eric.com.my »
Logged

eric.com.my

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
  • Eric Chooy
    • Eric's Heaven
Re: PHP v 4.3.10 and Coppermine
« Reply #9 on: February 21, 2005, 05:40:20 am »

I did a complain to my hosting server and suddenly my Coppermine Gallery is OK! Really don't know why  ???. Thanks man for everything  :)
Logged

whmeeske

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 68
    • WHMEESKE.NL
Re: PHP v 4.3.10 and Coppermine
« Reply #10 on: April 06, 2005, 03:30:02 pm »

If you have issues with Coppermine after upgrading (or your host upgraded) to php 4.3.10, it is due to using an outdated Zend Optimizer. It must be updated to v. 2.5.7

This is not an issue with coppermine. It is the incompatibility of an old Zend Optimizer and new PHP.
OK, thanks for the info.
Question : should Zend Optimizer always be updated, even if there seems to be no problems with it? What does Zend Optimizer do?
Logged

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
Re: PHP v 4.3.10 and Coppermine
« Reply #11 on: April 06, 2005, 04:50:57 pm »

Yes Zend Optimizer should always be updated
Logged
SANIsoft PHP applications for E Biz

jmro

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 1
Re: PHP v 4.3.10 and Coppermine
« Reply #12 on: May 06, 2005, 11:42:14 pm »

Hello, if you run whm / cpanel and have root access to your server run: /scripts/installzendopt can save you a lot time.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 21 queries.