Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Last Upload on the homepage shown & an error !  (Read 2726 times)

0 Members and 1 Guest are viewing this topic.

NEOo

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 10
Last Upload on the homepage shown & an error !
« on: December 24, 2004, 10:27:49 am »

hi

i have a question:
i dont know if its possible but i hope so.

i have a site en in the site i just have some pages etc. etc.
now i want if its possible the 4 last uploaded pics on the homepage shown.
i hope you understand my question and i hope someone can help me with it!
« Last Edit: December 25, 2004, 10:16:16 pm by NEOo »
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Logged

NEOo

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 10
Re: Last Upload on the homepage shown (not the photoalbum)
« Reply #2 on: December 24, 2004, 11:23:27 am »

oke thnx

i think its a great thing if it works.

i get this error:
Fatal error: Cannot instantiate non-existent class: cpm in /usr/home/neoeo/public_html/site2/main.php on line 170

i have this code:
Code: [Select]
<?php
include "http://www.neoeo.nl/fotoalbum/include/config.inc.php";
include "http://www.neoeo.nl/site2/copperminefetch/coppermine.php";
$objCpm = new cpm($CONFIG['neoeo_database'], $CONFIG['localhost'], 
                  $CONFIG['username'],$CONFIG['pass'], 
                  $CONFIG['TABLE_PREFIX'], '/');
?>

<?php $objCpm->cpm_viewLastAddedMedia(3,1); ?>

but there is nog such file as config.inc.php.....

help please?
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Last Upload on the homepage shown (not the photoalbum)
« Reply #3 on: December 24, 2004, 01:51:11 pm »

You lost the config.inc.php file which should be in the folder include ?? You got a problem :).

*edit: your config.inc.php is where it is supposed to be. Otherwise, if the config.inc.php was not there you would get this

Coppermine Photo Gallery seems not to be installed correctly, or you're running coppermine for the first time. You'll be redirected to the installer. If your browser doesn't support redirect, click here.

Trace back your steps and get your album to where it was before you used the mod as suggested by TranzNDance.
Follow that mod step by step and first read that thread very carefully. Twice. Using a mod is not always a walk in the park, it takes some knowledge of what your are doing and always backup the files which are going to be edited before you even begin editing them.

Still I don't understand how you could have lost your config.inc.php file completely.

Try restoring your gallery to its original state first and start by backing up your files before you begin.
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Last Upload on the homepage shown (not the photoalbum)
« Reply #4 on: December 24, 2004, 05:35:18 pm »

The config file is in the include folder.

You should request help in the thread where the mod originated.

Please do not send unsolicited PMs to dev team members. This is a perfect example of why we do not reply. You also posted your question here and someone replied. This would have resulted in wasted effort had I replied. We have a forum so people can benefit from past replies. Private assistance breaks that system.
Logged

NEOo

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 10
Re: Last Upload on the homepage shown (not the photoalbum)
« Reply #5 on: December 25, 2004, 10:14:38 pm »

oke thnx for all it works very well now!

only i have one question left:
i want to have the pics align-center, does somebody know how to do it?

and i've got an error in the photoalbum:

when i want to do the install its:
mySQL Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'Array' at line 1

and just in the home of the photoalbum:
There was an error while processing a database query
« Last Edit: December 25, 2004, 10:20:48 pm by NEOo »
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Last Upload on the homepage shown & an error !
« Reply #6 on: December 25, 2004, 10:32:18 pm »

We have a one question per thread policy.  Please respect it.

You can find answers to your new questions by searching the forums as they have already been answered in other posts.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.