Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Album Settings  (Read 5536 times)

0 Members and 1 Guest are viewing this topic.

ValleyTrojan

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Album Settings
« on: November 30, 2004, 05:58:32 am »

Hello,

Please bear with me, I am new to Coppermin and truly love it.  Coppermine is being offered by my webhost as part of their package.  Therefore I'm not quite sure which version it is.  I did search the files and found an update from 1.1 to 1.2, which I am hopeing is the current version.

Question:  I seemed to have removed comments and ratings from my album screen, not sure how I did so.

I have checked the "group" settings numerous times and "yes" is selected for both anonymous "comments" and "rate".
When I go to the album "properties", this is all I see:
Permissions for this album 
Album can be viewed by   
visibility 

Visitors can upload files *   
uploads 

Visitors can post comments *   
comments 

Visitors can rate files *   
votes 

(*) depending on groups settings


No drop down menu!

Lastly, upon reviewing the configuration setting, I see the following entry under "Album list view" and "The content of the main page"

breadcrumb/alblist/random,2/lastup,2

I believe I actually did see ratings and comments at one time, but now I can find them anywhere.

Thanks for any help you may provide.
Valley
 
« Last Edit: December 11, 2004, 11:24:27 pm by Casper »
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Album Settings
« Reply #1 on: November 30, 2004, 06:25:27 am »

Link, please.
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Album Settings
« Reply #2 on: November 30, 2004, 12:21:37 pm »

The latest stable version is 1.3.2, which you should update to.  You can get it here

Upgrading is easy, and will probably cure your problem.   The way you desribe your album properties, are you looking at these in the database, or from the album properties page within coppermine?
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

ValleyTrojan

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Comments and Rating disapper
« Reply #3 on: December 11, 2004, 04:43:56 am »

Hello all,

I am pretty sure I have version 1.3.2 installed.  I did find a file called CPG132 within my directories.

Here's my question:
I have been having problems with comments and ratings appearing.  I checked the setting a million times yet they are gone.  I noticed recently that they appear up until the point that I edit my albums properties with the name of the album, description, etc.

Has anyone else found this problem?  Is there a fix out there that I am missing?

Here's the location:
http://www.valleytrojan.com/photos.valleytrojan.com/

The only album which allows comments or ratings is the MPG file, because I have not edited the album properties yet.

Thanks for any help.

Valley
Logged

ValleyTrojan

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Album Settings
« Reply #4 on: December 11, 2004, 04:57:34 am »

Hey Casper,

I am looking at the Config setting menu when I copied/pasted that information on.

I believe I have version 1.3.2

I may have found the source, but not the remedy.  It appears that my comments and ratings appear up until I edit my Album properties with description, etc.  Then the comments disappear.  This has happened twice to me.

The last time, when adding a MPEG file, I didn't edit the album properties and the comments / rating are visible.

here's the link:
http://www.valleytrojan.com/photos.valleytrojan.com

I only recently purchase my first website and didn't realize I could add this.  My ISP added Coppermine as a feature.  Hence, I guess I may have to reinstall CPG from scratch to solve the problem if I can't any other way.

Thanks for the help.

P.S. Oops, just found out that mstralka is a Notre Dame grad, please don't show him that MPG file.....lol!!
« Last Edit: December 11, 2004, 05:16:41 am by ValleyTrojan »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Comments and Rating disapper
« Reply #5 on: December 11, 2004, 10:02:39 am »

Hello all,

I am pretty sure I have version 1.3.2 installed. I did find a file called CPG132 within my directories.

Here's my question:
I have been having problems with comments and ratings appearing. I checked the setting a million times yet they are gone. I noticed recently that they appear up until the point that I edit my albums properties with the name of the album, description, etc.

Has anyone else found this problem? Is there a fix out there that I am missing?

Here's the location:
http://www.valleytrojan.com/photos.valleytrojan.com/

The only album which allows comments or ratings is the MPG file, because I have not edited the album properties yet.

Thanks for any help.

Valley

enable rating and comments on the "groups" control panel and set the properties of the particular album accordingly. This is all being covered in the documentation that comes with coppermine inside the docs folder and that is available here as well (the link "documentation" at the top of this screen). Please read the docs before posting in the future.

Joachim
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Album Settings
« Reply #6 on: December 11, 2004, 10:08:23 am »

@ValleyTrojan: merged your two threads that deal with the very same thing into one. In the future, do not double post nor cross post if you want to avoid making supporters mad. Your double posting means double work for supporters >:( .

Joachim
Logged

ValleyTrojan

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Oops
« Reply #7 on: December 11, 2004, 11:15:09 am »

Sorry, my first post was a couple weeks ago and now I got around to reading it.

How do I combine (merge) the posts?

Additionally, I did change the groups several times, back and forth, hoping the problem would go away with no success.  Under album properties there are no selections (drop down menu).  All I get is that the settings are controlled under "groups".  Does this mean I have an older version?

Thanks again for an excellent program and I appologize for the double entry.

Valley

Here's my group setting:
(http://www.valleytrojan.com/photos.valleytrojan.com/albums/userpics/10001/Slide1.JPG)

And my Album properties on one of the albums not functioning properly:
(http://www.valleytrojan.com/photos.valleytrojan.com/albums/userpics/10001/Slide2.JPG)

As you can see, the comments and ratings work on this album that I created for these shots:
http://www.valleytrojan.com/photos.valleytrojan.com/thumbnails.php?album=11
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Album Settings
« Reply #8 on: December 11, 2004, 12:40:07 pm »

That screenshot shows there is something wrong with your modifyalb.php, as it should not look like that.
I suspect it is an older version from before you upgraded.

Using your ftp app, delete the existing file and replace it with a new copy.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

ValleyTrojan

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Album Settings
« Reply #9 on: December 11, 2004, 05:39:04 pm »

Thanks for the advice Casper.  In your opinion, should I just change that one file or all the files just to be sure?  If all, could you please point me in the right direction for keeping my present albums?  I searched last night and could not find the update instructions to save my life.

I found it several nights ago just surfing for answers, but not when I actually needed it.....doh!!

Thanks again.
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Album Settings
« Reply #10 on: December 11, 2004, 05:45:29 pm »

The update instructions are in the docs folder, index.html.

You should first just try that file.  Make sure you delete the old file first, then upload the new one.

If you need to do them all, just don't do the albums folder, and make sure you keep your existing include/config.inc.php and include/install.lock files.  All the others can be removed and then replaced.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

ValleyTrojan

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Album Settings
« Reply #11 on: December 11, 2004, 05:55:44 pm »

Thanks, I'll give that a try tonight.  It's only 9 am here (I believe you are in the UK).

Thanks again.
Logged

ValleyTrojan

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Album Settings
« Reply #12 on: December 11, 2004, 11:20:12 pm »

THANK YOU VERY MUCH CASPER!!!!!

The comments and ratings are now selectable.  You don't know how much time I've spent on this thing before I finally broke down and searched for help.

Thanks again!!    :)
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 19 queries.