Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: GD "No JPEG / GIF support" (ImageCreateFromJpeg)  (Read 12786 times)

0 Members and 1 Guest are viewing this topic.

DJMaze

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 831
    • Dragonfly CMS
GD "No JPEG / GIF support" (ImageCreateFromJpeg)
« on: November 02, 2003, 12:50:23 am »

Errors uploading Jpeg or Gif ?

You need to find more info then you ever thought existed about your php installation
make a file with just
Code: [Select]
<?php phpinfo(); ?> in it and view it in your browser from your server (don't forget to delete when done, some see this a security risk if not).
The page says which GD version you have.

YOU NEED GD 1.8.3 OR ABOVE.
Because only those versions fully support JPEG images and Coppermine works with those.

GIF support is only supported in GD 1.6.x or below due to license restrictions.
GIF has also a lower image quality and therefore not supported in Coppermine.
ImageCreateFromGif is not supported untill 7th of July 2004 because then the license is worldwide ended.

GD could also be compiled including GIF support but then you need:
- a compiler
- own server that you can control fully
- latest OS

If not:
Ask your host if they want to install GD 2.x for your site.
Logged
There are 2 kinds of users in this world: satisfied and complainers.
Why do we never hear something from the satisfied users?
http://coppermine-gallery.net/forum/index.php?topic=24315.0
Pages: [1]   Go Up
 

Page created in 0.025 seconds with 18 queries.