Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [fixed] Parse error - upgrade from 1.0 to 1.2  (Read 4320 times)

0 Members and 1 Guest are viewing this topic.

skip

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
[fixed] Parse error - upgrade from 1.0 to 1.2
« on: October 30, 2003, 08:51:31 am »

I get this error when trying to evoke upgrade-1.0-to-1.2.php:

Quote
Parse error: parse error, expecting `','' or `';'' in /home/u2/techsession/html/gallery2/upgrade-1.0-to-1.2.php on line 64


Please help.  Thanks.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
[fixed] Parse error - upgrade from 1.0 to 1.2
« Reply #1 on: October 30, 2003, 11:11:32 am »

do you have any special chars (other than letters, numbers and underscore) in your mySQL table names?

GauGau
Logged

skip

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
[fixed] Parse error - upgrade from 1.0 to 1.2
« Reply #2 on: October 30, 2003, 07:20:29 pm »

no sir - all of my mySQL table names are valid.  Thanks for the reply!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
[fixed] Parse error - upgrade from 1.0 to 1.2
« Reply #3 on: October 31, 2003, 04:39:47 am »

OK, this sounds silly, but try upgrading from 1.0 to 1.1 first and then from 1.1 to 1.2 (file should be in the package you downloaded as well).

GauGau
Logged

jasendorf

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 350
    • http://www.338tharmyband.com
[fixed] Parse error - upgrade from 1.0 to 1.2
« Reply #4 on: October 31, 2003, 04:06:29 pm »

Actually, the problem is described (and the fix), here:

http://forum.coppermine-gallery.net/index.php?topic=606&highlight=upgrade
Logged
Read the Online DOCs,FAQ, and SEARCH the board BEFORE posting questions for help.

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
[fixed] Parse error - upgrade from 1.0 to 1.2
« Reply #5 on: October 31, 2003, 05:06:39 pm »

Is it in the CVS - can someone start and close a tracker on this please
Logged
SANIsoft PHP applications for E Biz

skip

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
[fixed] Parse error - upgrade from 1.0 to 1.2
« Reply #6 on: October 31, 2003, 08:05:59 pm »

Thanks, guys!  That sure did do it.  Here's our gallery if anyone here is a Porsche fan:

http://www.tech-session.com/gallery2/
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
[fixed] Parse error - upgrade from 1.0 to 1.2
« Reply #7 on: November 01, 2003, 02:50:26 pm »

Tracker https://sourceforge.net/tracker/index.php?func=detail&aid=833482&group_id=89658&atid=590907 closed

Sorry guys, I should have done a search first before starting the tracker. :oops:

GauGau
Logged

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
[fixed] Parse error - upgrade from 1.0 to 1.2
« Reply #8 on: November 02, 2003, 05:30:03 am »

Quote from: "gaugau"
Sorry guys, I should have done a search first before starting the tracker. :oops:

No - IMO - Having a tracker for every bug known is  good - In-fact I will have  to remember to start trackers before I fix a bug rather than just fix a bug and commit :oops:
Logged
SANIsoft PHP applications for E Biz
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.