Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Strange signs in browsers other then IE  (Read 4274 times)

0 Members and 1 Guest are viewing this topic.

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Strange signs in browsers other then IE
« on: November 06, 2004, 06:48:27 pm »

HI,

I just got some comments from visitors to my website that there are a few strange signs which can be seen in upper left corner of my website. This what they see: ´"┐. I'm using Internet Explorer and don't see them, but when I switch to Opera or Firefox, I can see them as well.

This is how it look like:

(http://members.lycos.nl/michaelkiewiet/CM_signs.gif)

Any idea where they come from and in what file I can find (and delete) them?

Thanks and kind regards,
Michael
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Strange signs in browsers other then IE
« Reply #1 on: November 06, 2004, 06:59:59 pm »

To make it easier for those trying to replicate the problem, here's the link: http://www.misy.nl/fotografie/thumbnails.php?album=lastup&cat=0

I see the characters in FF, too.
Logged

Joachim MŘller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Strange signs in browsers other then IE
« Reply #2 on: November 06, 2004, 07:28:55 pm »

This is usually caused if you touch the language files with an editor you're not suppossed to touch them with - make sure you haven't edited any of your coppermine files using a wysiwyg editor like Dreamweaver or MS Frontpage. If you did: get a fresh copy of the files and overwrite the ones on the server. If you're not sure what file to edit/replace, use the search function of your operating system, searching for files "*.php" containing the string "´"┐<php" (without the quotes of course).

Joachim
Logged

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Strange signs in browsers other then IE
« Reply #3 on: November 28, 2004, 03:53:46 pm »

Well, Joachim, I've finally foudn some time to search through all files for those signs. And I didn't found them.... :-[

I've used the search-function in XP to search for those signs in all files but no results. I've changed the language file to be used to an original version and that didn't help either.

So, what next?

Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Strange signs in browsers other then IE
« Reply #4 on: November 28, 2004, 04:32:09 pm »

These are at the very start of the utf-8 language files, and 1 or 2 other files.  They cannot be seen by some editors, including notepad.

Try changing from the utf-8 to the iso language file, and change your config encoding setting to default language file
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Strange signs in browsers other then IE
« Reply #5 on: November 28, 2004, 05:05:24 pm »

These are at the very start of the utf-8 language files, and 1 or 2 other files.  They cannot be seen by some editors, including notepad.

Try changing from the utf-8 to the iso language file, and change your config encoding setting to default language file

I thionk I've already done both, Casper.... Language setting is back to the non-UTF-setting and encoding is default and I still see it....
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Strange signs in browsers other then IE
« Reply #6 on: November 28, 2004, 05:14:09 pm »

Your source code is showing you still have utf-8 as the language file.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Strange signs in browsers other then IE
« Reply #7 on: November 28, 2004, 06:05:43 pm »

Do you believe me if I tell you that if I change it to Dutch and confirm it by saving the new configuration, that when I then return to the setting it still (or again) says Dutch-UTF-8 as language file???
That's why I said I changed it, I did, but the it changes again to the UTF-setting.... ???
Logged

chtito

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 186
  • I run Mac OS X, despite the penguin ;)
Re: Strange signs in browsers other then IE
« Reply #8 on: November 28, 2004, 06:13:34 pm »

You have to be smart in order to locate these weird signs using a search function. You have to be sure that you're searching exactly for the following data (in hex): "FFBBBF". For instance, this data does not represent any utf-8 encoded string.

Anyway, apparently all the utf-8 language files are "contaminated" by these three bytes of data (aka BOM).

There might be a quick fix, though: pick a good text editor. Open the incriminated utf-8 file, in utf-8 encoding, of course. Make a minor change to the file: add a space or something. Save the file in text format, utf-8 encoding as well.

Most likely, your editor has stripped off the unwanted data at the beginning of the file, since its usage is not recommended.

I will take care of repairing these utf-8 languages files as soon as i can.

cheers!
Logged
Vous pouvez poser vos questions en franšais sur le forum francophone !

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Strange signs in browsers other then IE
« Reply #9 on: November 28, 2004, 06:37:11 pm »

Thanks for your suggestion; I tried to do what you recommend in UltraEdit (which I use a lot and I think of it as a good text-editor), but unfortunately no result. I've overwritten the language -files on my server with those that were in the download-package, but that didn't change the thing either.
Does this mean that I can see it on everybody's Coppermine-site with -for instance- Opera? Or is it just me... :\'(

Of course, there are more important problems and the majority of the users is using IE, instead of Mozilla or opera, but I got some comments on this and I just want to fix it...

Logged

chtito

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 186
  • I run Mac OS X, despite the penguin ;)
Re: Strange signs in browsers other then IE
« Reply #10 on: November 28, 2004, 06:47:43 pm »

He he, i'm sorry, my idea was not very clever.  ;D

Just open the utf-8 file as a latin1 file; remove the first three character (´"┐); save the file as utf-8. That should work...

Good luck!
Logged
Vous pouvez poser vos questions en franšais sur le forum francophone !

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Strange signs in browsers other then IE
« Reply #11 on: November 28, 2004, 08:26:12 pm »

Done!!!

It took me a while to fin a good Editor which good to the trick, but I've managed to do so...

It is still not ideal as I now got my old problem back (http://forum.coppermine-gallery.net/index.php?topic=10563.0). I solved it by removing all accent signs (Ú, Ű, ´, etc.), but that's more a workaround then a solution, imho.

Thanks for your help!
Logged

chtito

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 186
  • I run Mac OS X, despite the penguin ;)
Re: Strange signs in browsers other then IE
« Reply #12 on: November 28, 2004, 08:53:01 pm »

Right! Dutch is one of the many broken utf-8 language files (although i haden't noticed at first sight, because dutch doesn't seem to have many diacritics).

I uploaded the corrected utf-8 dutch file.

Hope that everything will be back to normal!

cheers!
Logged
Vous pouvez poser vos questions en franšais sur le forum francophone !
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 19 queries.