Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: page loading  (Read 2902 times)

0 Members and 1 Guest are viewing this topic.

michael singer

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 42
  • random image from: www.a-visual-notebook.at
    • a visual notebook
page loading
« on: November 03, 2004, 01:33:29 pm »

i hope this is not a too silly question:

i'm wondering about the following behaviour of page loading in IE:

when clicking on a thumbnail of my site, then always the whole page is loading again, not only the new images and thumbs.  about one second long i only can see the background of my site, like there were nothing in the browser cache, only after this time the page appears again on the screen. the same happens while reloading the page.

http://www.a-visual-notebook.at

as far as i see, not all coppermine powered sites are loading this way.

is this a browser related item or the standard behaviour of php code? can this be adjusted?
what i would like to have is, background images and layout related stuff staying in browser cache, and just the images  loading.

any ideas?


Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: page loading
« Reply #1 on: November 03, 2004, 01:54:44 pm »

I see your pages fine, and I got no white page, except at the very first visit for a very short time.

I suspect this is down to your browser settings.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

michael singer

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 42
  • random image from: www.a-visual-notebook.at
    • a visual notebook
Re: page loading
« Reply #2 on: November 03, 2004, 05:45:03 pm »


this is strange, because with my browser at work (IE) it's just the same: after reloading or klicking a thumb, the main table of my site is disappearing for a short time, in this moment all i can see is the light gray background-image of the body, after this then the (black) maintable is coming back again.
it seems that IE is always completely reloading the same page again, despite all cached information of the maintable of my site.

sorry, i don't want to bore you. but what i was thinking about was, that there might be some php.code, that tells the browser to completely reload the page.
with mozilla firefox there is no problem, the page stands without movement, only the images are changing. this looks much more better to me.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: page loading
« Reply #3 on: November 03, 2004, 06:38:03 pm »

In IE, click "Tools" - "Internet Options..." - tab "General" - Button "Settings..." in the section "Temporary Internet files". Set it to "Automatically" and make sure the amount of disk space is set to a high enough value (around 300 recommended). For a german IE, the commands are "Extras" - "Internetoptionen" - Registerkarte "Allgemein" - "Temporäre Internetdateien" - "Einstellungen".

Joachim
Logged

poubao

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: la
  • Offline Offline
  • Gender: Male
  • Posts: 277
    • Collections du Laos
Re: page loading
« Reply #4 on: November 03, 2004, 07:47:50 pm »

@ okapi
hi !
i think you have a problem with your "next" and "prev" button
poubao ???
Logged
L'incohérence de ceux qui nous dirigent, l'incompétence de ceux qui nous commandent,sont un vibrant hommage pour ceux qui exécutent.
                                          **Général Patton**

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: page loading
« Reply #5 on: November 03, 2004, 07:59:31 pm »

Well spotted poubao, they are the wrong way around.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

michael singer

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 42
  • random image from: www.a-visual-notebook.at
    • a visual notebook
Re: page loading
« Reply #6 on: November 04, 2004, 09:50:08 am »


thank you for the hint, joachim!
i'm aware of these settings, unfortunately they don't change the above described behaviour.
maybe my new experiences with firefox turned my attention to this.
anyway, as nobody else is worrying about it, it may not be a big problem.

thank you, poubao!
no idea why i mixed it up... 

michael
Logged
Pages: [1]   Go Up
 

Page created in 0.232 seconds with 28 queries.