Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Small problem in Dutch translation  (Read 4720 times)

0 Members and 1 Guest are viewing this topic.

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Small problem in Dutch translation
« on: October 04, 2004, 10:34:47 am »

HI,

I've got a small problem in the Dutch translation; the button "Categories" (in Dutch: Categorieën) looks like this: (http://members.lycos.nl/michaelkiewiet/Copp_button.gif).

Is this a text-problem which I can fix somewhere myself?

Another question (off topic, I'm sorry): is it possible to show only the English-languageflag while I'm using Dutch as standard? Or is the UTF-Unicode-automatic-lanuage-thingy the best option to use ?
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Small problem in Dutch translation
« Reply #1 on: October 04, 2004, 11:17:09 am »

Are you using the dutch-utf-8.php file, or dutch.php?
What is your config setting for  Character encoding, is it 'default, language file', or 'utf-8'.

For the flags, if you have them turned on, they will show the flag for each language you have in the language folder.  Just remove the files except dutch and english, then they are the only ones that will show.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Small problem in Dutch translation
« Reply #2 on: October 04, 2004, 11:40:02 am »

I've tried both Dutch and Dutch-utf-8 and all reasonable settings forr Character-encoding and all settings show the same result as in my first post.

Thankx for the flag-solution, that's very simple....
Logged

Nibbler

  • Guest
Re: Small problem in Dutch translation
« Reply #3 on: October 04, 2004, 03:16:06 pm »

Can you post a link ?

If you are using apache 2, grab an updated version of your theme.php from the CVS.
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Small problem in Dutch translation
« Reply #4 on: October 04, 2004, 03:16:33 pm »

I've tested this, and cannot replicate it.  Both the dutch.php with setting at 'default language file'and dutch-utf-8.php with setting at utf-8 work correctly, see screenshot below.

(http://www.hsocuk.com/images/shot_003.jpg)

Open your 2 files, and find the cvs id number, near the top, which will look like this;

Code: [Select]
// CVS version: $Id: dutch.php,v 1.9 2004/09/15 10:48:03 caspershadow Exp $
Let us know which versions you have

EDIT, the attachment facility is not working, so cannot add screenshot at the moment, sorry.
« Last Edit: October 04, 2004, 03:25:06 pm by Casper »
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Small problem in Dutch translation
« Reply #5 on: October 04, 2004, 03:30:43 pm »

@ NIbbler: http://www.misy.nl/photography/index.php this is my site which is still in construction (no content at the moment)

@Casper:

Dutch.php:
Code: [Select]
CVS version: $Id: dutch.php,v 1.7 2004/07/24 15:04:02 gaugau Exp $
Dutch-utf-8.php
Code: [Select]
CVS version: $Id: dutch-utf-8.php,v 1.7 2004/07/24 15:04:02 gaugau Exp $
You are using v1.9 while I'm still on 1.7 (I downloaded CPG on the 29th of September), can this be the solution (upgrading to 1.9 ?) ?

Thanks for your help!

Michael
Logged

Nibbler

  • Guest
Re: Small problem in Dutch translation
« Reply #6 on: October 04, 2004, 03:52:13 pm »

As I said: Update your theme.
Logged

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Small problem in Dutch translation
« Reply #7 on: October 04, 2004, 04:38:58 pm »

@Nibbler: I've replace my theme.php from the Mac Ox-X theme with the theme.php from your link, but that didn't help. I've got the problem with all themes, so that should mean I need to replace all theme.php-files? And it doesn't help with the current-theme; changed it back to the classic-theme, but the problem still persists...
Logged

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Small problem in Dutch translation
« Reply #8 on: October 04, 2004, 08:38:03 pm »

Well, the solution is much easier than expected: the Dutch language file is not the best in the world... :(
The strange signs are in the Dutch...php files.. I've corrected them manually and the problems are gone...

Thanks anyway for your time!

Michael
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Small problem in Dutch translation
« Reply #9 on: October 04, 2004, 08:38:53 pm »

Please tellus where, so we can help other dutch users.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Small problem in Dutch translation
« Reply #10 on: October 04, 2004, 09:05:23 pm »

Quote
Please tellus where, so we can help other dutch users.

What I'll do is change both files and correct the errors and sent them to you, is that a good solution? You can then compare them with the originals. In short: every character having accents (ë, é, etc) was written with strange signs in them (like the small screenshot from my original post). I know HTML does need some extra info fro reading signs, but when I corrected them in my php-files and uploaded them to my webspace, the problem was gone.

To which emailadress shall I send the updated language files ?
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Small problem in Dutch translation
« Reply #11 on: October 05, 2004, 12:01:16 am »

Just re-name them to have a txt or zip extension, then attach them here, using the 'additional options' link below.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Small problem in Dutch translation
« Reply #12 on: October 05, 2004, 07:41:16 am »

The attachment feature should now be working again, sorry for the temporary error.

Joachim
Logged

mikekiwi

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Small problem in Dutch translation
« Reply #13 on: October 05, 2004, 09:28:23 pm »

I've included the dutch-utf-8.php; the regular dutch.php seems to be o.k. . Please do some testing if it looks o.k. on any other demo-install as it may function for me, but - as a very inexperienced user - I'm afraid that I might have overlooked something...

Ciao,
Michael
Logged
Pages: [1]   Go Up
 

Page created in 0.066 seconds with 20 queries.