No Support > General discussion (no support!)

Typical Error: Can't open file: 'cpg131_pictures.MYI'. (errno: 145)

(1/4) > >>

The error:

Can't open file: 'cpg131_pictures.MYI'. (errno: 145)

The problem:

Your table is corrupted.

The solution:

Use your website's Control Panel to repair the table, or use phpMyAdmin to execute this sql query: repair table cpg131_pictures
(Replace cpg131_pictures with your table name)

I had the same problem, and I tried youre solution. I did the sql-query "repair table cpg_pictures" but all i got is the same error mesage agein. he can't open th e file so he can't repair the file.'
I do noticed that it was the only table with the message "in use" what does that mean?

Any ideas on what to do next?
I have hardly any experience with this kind of stuf so I hope it doesn't become to technical for my

Joachim Müller:
ask your webhost for support, this issue is not directly related to coppermine.

Check your user.  Mine had a name like O'Keefe.  Guess what threw the code???  Yup, someone didn't check names for apostrophes.  Renaming that user to Okeefe did the trick.  Interestingly, the user had no trouble regestering.  Can't promis you the same luck.   

With all go one

hi i have the same error

There was an error while processing a database query

and when i check pictures table and i found this erorr

Problems with indexes of table `amooorah_pictures`
 More than one INDEX key was created for column `aid`

the phpadmin can't repair the erorr i think it's a bug in the programing ?


[0] Message Index

[#] Next page

Go to full version