Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: problem with greek language in cpg 1.3.2  (Read 5950 times)

0 Members and 1 Guest are viewing this topic.

versus7

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • www.oixalia.gr
problem with greek language in cpg 1.3.2
« on: September 21, 2004, 06:11:28 am »

hello i have a problem with greek language, when i choose greek its all characters like chinese :o and i must always set manually the greek iso-8859-7 from my browser...
can any help me ?

my gallery is http://www.neoxori.greatnow.com/gallery/index.php

sorry for my bad english
« Last Edit: September 21, 2004, 10:55:35 pm by TranzNDance »
Logged
(http://www.oixalia.gr/gall/cpmfetch/cfimageget.php)

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: problem with greek language in cpg 1.3.2
« Reply #1 on: September 21, 2004, 06:14:39 am »

Just to make sure...do other Greek sites look OK to you? I looked at that page in Firefox and IE and the characters look different, although it was on the same PC. Could you please take a screenshot to show what the characters are supposed to look like?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: problem with greek language in cpg 1.3.2
« Reply #2 on: September 21, 2004, 09:07:08 am »

The page looks broken for me in both browsers, so a blind guess would be your greek language files are broken. Get a fresh copy of the coppermine package and overwrite the greek language files on your page with the ones from the package (without modifying them, use a "regular" ftp application, no web suite like dreamweaver, golive or frontpage).

Joachim
Logged

versus7

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • www.oixalia.gr
Re: problem with greek language in cpg 1.3.2
« Reply #3 on: September 21, 2004, 10:19:44 am »

where can i find this paket, have you a link please ?
Logged
(http://www.oixalia.gr/gall/cpmfetch/cfimageget.php)

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: problem with greek language in cpg 1.3.2
« Reply #4 on: September 21, 2004, 10:25:50 am »

Get the most recent stable from the web cvs: http://cvs.sourceforge.net/viewcvs.py/coppermine/stable/lang/greek.php
, or download a fresh copy of the coppermine package from the downloads section (link at top of this page). Where did you get the package you're currently using from?

Joachim
Logged

versus7

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • www.oixalia.gr
Re: problem with greek language in cpg 1.3.2
« Reply #5 on: September 21, 2004, 10:35:26 am »

Logged
(http://www.oixalia.gr/gall/cpmfetch/cfimageget.php)

versus7

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • www.oixalia.gr
Re: problem with greek language in cpg 1.3.2
« Reply #6 on: September 21, 2004, 10:38:24 am »

i downloaded the cpg 1.3.2 and i dont made changes in lang files
Logged
(http://www.oixalia.gr/gall/cpmfetch/cfimageget.php)

versus7

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • www.oixalia.gr
Re: problem with greek language in cpg 1.3.2
« Reply #7 on: September 21, 2004, 10:56:34 am »

i made what did you say but i don't have see changes  :\'(
Logged
(http://www.oixalia.gr/gall/cpmfetch/cfimageget.php)

Nibbler

  • Guest
Re: problem with greek language in cpg 1.3.2
« Reply #8 on: September 21, 2004, 03:27:57 pm »

Can you overwrite your existing themes/classic/theme.php with the one from this zip and tell me if that solves the problem.
Logged

versus7

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • www.oixalia.gr
Re: problem with greek language in cpg 1.3.2
« Reply #9 on: September 21, 2004, 10:53:53 pm »

Ohhhhhhhhh yesssssssssss thats it

what is the changes between the old and the new theme ?

thank you very very much Nibbler  ;)

you are great!!!!!!!!!!!!!!  :o :D
Logged
(http://www.oixalia.gr/gall/cpmfetch/cfimageget.php)

Nibbler

  • Guest
Re: problem with greek language in cpg 1.3.2
« Reply #10 on: September 21, 2004, 11:12:19 pm »

It's an issue with the AddDefaultCharset directive in Apache 2. If the script doesn't send a content type header (which cpg doesn't) then apache will by default send it's own header setting the character encoding to ISO-8859-1 which overrides the meta info specifying the character encoding we read from the lang file. I added such a correct content type header into that theme file so Apache won't send it's own (incorrect) header. The change is fairly minor. See Apache bug #23421 for more details.

@devs: I will commit this to all theme files tonight.
Logged

versus7

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • www.oixalia.gr
Re: problem with greek language in cpg 1.3.2
« Reply #11 on: September 21, 2004, 11:23:19 pm »

this is in my phpinfo

iconv support enabled

Directive Local Value Master Value
iconv.input_encoding
 ISO-8859-1 ISO-8859-1
iconv.internal_encoding
 ISO-8859-1 ISO-8859-1
iconv.output_encoding
 ISO-8859-1 ISO-8859-1

Logged
(http://www.oixalia.gr/gall/cpmfetch/cfimageget.php)

Fosy

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: problem with greek language in cpg 1.3.2
« Reply #12 on: October 10, 2005, 07:50:23 pm »

Hi, i have the same problem...so with spanish languaje..
please any with code for modification?

attach my original file of my theme (not is classic theme), for anyone edit code for me :) no have experience...

Thanks in advance...
Logged

Nibbler

  • Guest
Re: problem with greek language in cpg 1.3.2
« Reply #13 on: October 10, 2005, 08:00:38 pm »

 ;)
Logged

Fosy

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: problem with greek language in cpg 1.3.2
« Reply #14 on: October 10, 2005, 08:05:42 pm »

WoWz, working 100%
i am happy now friend....

u have the neccesary code for the nexts themes? possible changes, etc...

Many Thanks again!!!
Logged
Pages: [1]   Go Up
 

Page created in 0.036 seconds with 19 queries.