forum.coppermine-gallery.net

Support => cpg1.6.x Support => cpg1.6 upgrading => Topic started by: micropalla on September 02, 2019, 06:42:27 pm

Title: White page after upgrading
Post by: micropalla on September 02, 2019, 06:42:27 pm
Hello.
I upgraded from 1.5.46 to 1.6.3 with the script.
Everything was fine as I was logged in. I uploaded files, I deleted some, all was ok.

Unfortunately as i logged out i received a white page.
This happens only if I set PHP 7.0 or above. If i set PHP 5.6 i see the gallery in both cases, logged in or logged out.... :-\

Which could be the problem?

This is the link: https://www.fotoferrovie.info/index.php

Thanks!!
Title: Re: White page after upgrading
Post by: Phill Luckhurst on September 02, 2019, 11:46:01 pm
Hard to tell exactly what the problem is as your gallery is currently running.

The easy way to diagnose is to set your gallery to PHP 7 then check the servers error logs for the time the error occurs. A white page means the server has encountered and error, but for security reasons does not display that error. Instead it places it in the logs.

Title: Re: White page after upgrading
Post by: ron4mac on September 03, 2019, 12:59:22 am
First of all ... you should have upgraded to CPG 1.6.06 (the current latest version).

Your issue is being caused by something not compatible with CPG 1.6.x or PHP 7 ... your theme or a plugin.  Disable all your plugins. If it then runs correctly, enable plugins one at a time until you find the one causing the problem.
Title: Re: White page after upgrading
Post by: micropalla on September 03, 2019, 08:10:35 am
Ok, you were right, it was plugin External Tracker.

I disabled it and now it works!

Thanks a lot!! :)
Title: Re: White page after upgrading
Post by: micropalla on September 03, 2019, 04:21:53 pm
I realize there is still some problem.

This evening I tried to login but i wrong the password so many times the system blocked.
Once again a white page... :(

I really don't understand this time.
Title: Re: White page after upgrading
Post by: micropalla on September 03, 2019, 04:28:27 pm
Ok white page also as I login as a user!!!

https://www.fotoferrovie.info/index.php?message_id=7b3861b5e60ac1a224be18fbdc9febf1&message_icon=info&message_id=e0de68b999ca5b3cdd6170dc6f776261&message_icon=success#cpgMessageBlock

and white page
Title: Re: White page after upgrading
Post by: micropalla on September 03, 2019, 04:37:41 pm
Ok this time the ptoblem is the shorturl plugin.
Is it a new plugin? I don't remember it in previous versions...
Title: Re: White page after upgrading
Post by: micropalla on September 03, 2019, 04:38:40 pm
I answer to myself, old plugin no more working...
This could be useful for all  :D